Knowledgebase
MapScenes Forensic CAD 2013 Release Notes
Posted by Brian Sloman on 25 August 2015 10:36 AM

Release History

MapScenes Forensic CAD 2013 (v13.0.2.7) - June 21, 2013

MapScenes Forensic CAD 2013 SP0 (v13.0.3.22) - November 27, 2013

MapScenes Forensic CAD 2013 SP1 (v13.1.1.300) - April 4, 2014


Important Notes

Activating or Updating your USB License Key

If you are licensing MapScenes for the first time you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MapScenes 2010/2008, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MapScenes 2006 or previous, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MapScenes, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MapScenes Service Pack updates. For a detailed explanation of MicroSurvey's Maintenance Subscription Support Plan (MSSP) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your Maintenance Subscription has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the MSSP by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date.

If your MSSP has expired, you can phone us at 1-800-668-3312 or +1-250-707-0000 to renew it. Without a current maintenance subscription plan, you will not be able to update your key to work with the new version.

MicroSurvey Transfer Program for Evidence Recorder Users

Evidence Recorder users need to download a copy of the MicroSurvey Transfer program to simplify the process of transferring Evidence Recorder projects between your data collector and MapScenes.

If you have a copy of MicroSurvey Transfer already installed from use with MapScenes 2010 or previous, you will need to update it to recognize MapScenes Forensic CAD 2013. Previous versions of MicroSurvey Transfer will NOT show MapScenes Forensic CAD 2013 as a sync option in the Options screen.

MicroSurvey Transfer can be downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

The MicroSurvey Network License Server program has not changed significantly since the release of MapScenes 2008. This is only necessary for users who are setting up a MapScenes 2008 or newer network license for the first time.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MapScenes Forensic CAD 2013 is compatible with 32-bit and 64-bit versions of Microsoft Windows XP SP3, Windows Vista SP2, Windows 7 SP1, and Windows 8.

MapScenes Forensic CAD 2013 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, aside from a compatible video card for the 3D rendering, point cloud, and animation engines. Please refer to this online article for a list of compatible video cards.

Windows Vista, Windows 7 & Windows 8 Notes

Run as Administrator

If installing on Windows Vista/7/8 you must run the program at least once elevated with "Run as admininstrator" privileges, even if you are already logged in with an "Administrator" account on the computer.

After this is done, it can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MapScenes Forensic CAD 2013 icon.
  2. Choose "Run as administrator".
  3. Select "Yes" on the "User Account Control" dialog when prompted to allow the program to make changes to your computer.

What's This? Help

If you wish to use the What's This? Help feature under Windows Vista/7/8, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


Online Resources

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MapScenes Forensic CAD 2013 Frequently Asked Questions topic in our online helpdesk.

Upgrade Notes

For a guide on upgrading from a previous version of MapScenes, please visit the MapScenes Forensic CAD 2013 Upgrade Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MapScenes Forensic CAD 2013 Known Issues topic in our online helpdesk.

Training Movies

For training movies that you can watch online or download for offline viewing, please visit the MapScenes Online Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at http://helpdesk.microsurvey.com/ where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are now answered in your Help file and Manuals.

For technical support, please visit our helpdesk at http://helpdesk.microsurvey.com/ to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Maintenance Subscription Support Plan (MSSP).

To purchase or renew your MSSP, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000 or visit our online store at http://store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to vote on other users' feature requests, please visit our Feedback Forum at http://feedback.microsurvey.com.


MapScenes Forensic CAD 2013 Notes

New Features

MapScenes Forensic CAD 2013 with Animation and Point Cloud modules
MapScenes Forensic CAD 2013 is now available as one single product with optional Animation and Point Cloud modules providing four different product levels: MapScenes Forensic CAD, MapScenes Forensic CAD + Animation module, MapScenes Forensic CAD + Point Cloud module, and MapScenes Forensic CAD + Animation module + Point Cloud module.
All modules are pre-loaded and available in the MapScenes Forensic CAD 2013 install, and are enabled directly by your USB license key - no more seperate Forensic CAD, Capture, and Point Cloud installations!
The core MapScenes Forensic CAD module is the base product that has everything you need for creating 2D or 3D forensic drawings.
The optional Animation module adds powerful 2D or 3D animation capabilities, allowing you to create and produce compelling .avi video presentations.
The optional Point Cloud module adds powerful point cloud drawing capabilities, allowing you to draw features caught via stationary, mobile, or airborne laser scanners.
Powered by IntelliCAD 7.2a
MapScenes Forensic CAD 2013 is built on the latest IntelliCAD engine, IntelliCAD 7.2a. See below for a summary of new IntelliCAD features.
Google Maps™ Support
View your georeferenced points in Google Maps by clicking new Map buttons located in both the Single Point Editor and the Active Coordinate Editor.
Select MsPoints | Store and Edit Points or MsPoints | Active Coordinate Editor from the menus, or type EDITP or COORDEDIT at the command line.
Google Earth™ Support
Export your georeferenced points and linework to a .kml or .kmz file and view them in Google Earth.
Select MsPoints | Export to Google Earth from the menus, or type WRITEKML at the command line.
AutoMAP Substitution Codes
Access field-coded parameters directly from your point descriptions and automatically include them in your plotted annotations.
Substitution codes follow LDD syntax, and include $0 to substitute the code, $1-$9 to substitute the first through ninth space-delimited parameter following the code, $+ to substitute all parameters following the code, $* to substitute the entire description including the code plus all parameters, and $$ to substitute a literal "$" character.
For example, specify a plotted description like $1 TREE (ht=$2’, trunk dia=$3”) in AutoMap to dynamically label your TREE points like TREE OAK 9 12 and TREE ELM 6 8 as OAK TREE (ht=9’, trunk dia=12”) and ELM TREE (ht=6’, trunk dia=8”).
AutoMAP Leading Wildcards
Use AutoMap entries with a leading wildcard like *CODE, a trailing wildcard like CODE*, or both a leading and trailing wildcard like *CODE* to make partial matches of your point descriptions.
For example, an AutoMap entry like *TIRE* will now match points with descriptions like "LEFT FRONT TIRE FLAT" and you can use the new Substitution Codes described above to produce appropriate plotted descriptions.
Distance Labeling Options
Include a customizable prefix and/or suffix in your distance annotation defaults.
Include a unit symbol (' or m) in your distance annotation defaults. (Previously only ' was supported.)
Select MsLabeling | Labeling Defaults | Distances from the menus, or type CNF_EDIT_DISTANCES at the command line.
Draworder Wizard
A new Draworder Wizard command is available to help you quickly fix the most common draworder issues, such as moving raster images and hatches to the back of your drawing, and moving wipeouts, blocks and annotations to the front.
Select MsTools | Draworder Wizard from the menus, or type DRAWORDERWIZARD at the command line.
Import Improvements
When importing an Evidence Recorder or TDS raw file containing GK (GPS stakeout) records, they are now imported into the measurement file.
When recoordinating a measurement file, an Abort option is now available on the point protection dialog.
When importing an ASCII coordinate file, an Abort option is now available on the point protection dialog.
List Unused Points in Range
The List Unused Points command has a new option to specify a point range for your search.
Select MsPoints | List Points (Used and Unused) | List Unused Points, or type LIST_UNUSED at the command line.
Import Leica DBX
Import points, linework, raw TPS/GPS observation, images and scans directly from Leica DBX databases.
Select MsMeasurements | Read Collector Files In | Leica DBX from the menus, or type DBXIN at the command line.
Improved Job Defaults dialog
The General Configuration Options dialog that appears when opening a new or existing drawing has been improved with options to select the drawing's AutoMAP Library file, Feature List File (for GIS data), and Coordinate System.
Align Between Drawings
A new Align Between Drawings command is now available for copying and aligning entities between two open drawings.
Select Modify | Align Between Drawings from the menus, or type MSALIGN at the command line.
Auto-Add Points to Blocks & Text
The Auto-Add Points to Objects command now supports Blocks, and will store a point at the Insertion Point of any selected Block entities.
The Auto-Add Points to Objects command now supports Text, and will store a point at the Insertion Point of any selected Text entities.
Select MsPoints | Auto-Add Points to Objects from the menus, or type AUTOP at the command line.
Evidence Recorder SyncWizard Default Folder
The default Evidence Recorder Upload and Download folders have been moved to make them more easily accessible.
Old location, Windows XP and earlier: C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes Forensic CAD\2010\SyncWizard\Downloads, Uploads
Old location, Windows Vista and newer: C:\ProgramData\MicroSurvey\MapScenes Forensic CAD\2010\SyncWizard\Downloads, Uploads
New location: My Documents\MicroSurvey\SyncWizard\Downloads, Uploads
Rescale Drawing Wizard
Easily rescale drawings from one base unit to another.
It is typical for architectural drawings to be in either inches or millimeters, and these drawings need to be rescaled to feet or meters.
Select MsTools | Rescale Drawing Wizard from the menus, or type DWG_RESCALE at the command line.
AutoSave with MapScenes Database
The IntelliCAD AutoSave feature now also saves a copy of the current database.
The AutoSave folder is your system Temp folder by default, and can be defined in the OPTIONS command.
The AutoSave drawing file extension is .SV$ by default and can be customized in the OPTIONS command.
The AutoSave database file extension is .MZ$ and cannot be customized.
To recover an AutoSave drawing, you must rename the .SV$ and .MZ$ file extensions to .DWG and .MSZ respectively.
Select Tools | Options from the menus, or type OPTIONS at the command line.
Copy & Rotate Symbol
Easily make multiple copies of a symbol with varying positions and orientations in your drawing, all in one command.
For example, use this to place a vehicle symbol at key points during a collision, aligned to skid marks collected on scene.
Select MsLabeling | Add Symbols | Copy Symbol from the menus, or type COPYROTSYM at the command line.
Insert Picture Improvements
Over 150 image formats are now supported, including: .bmp, .png, .jpeg, .gif, .tiff, and many more!
Show or Hide the Options and Picture Attributes shown along the left-hand side of the View Picture window, maximizing the screenspace for the actual image.
View Picture options (window position, window size, and image display size) are remembered when the View Picture dialog is closed and reopened - for example, to view a different image.
Open the image in your default picture viewer (ie, Windows Photo Viewer or other third-party application), allowing you to Print, Rotate or Zoom the image, etc.
Updated Vehicle Database Browser
Scene Analysis tool contains the most recent vehicle specifications database (v2012.2), which includes all 1971-2012 models and some 2013 models.
The vehicle specifications database is compiled by the Collision Investigation and Research Division of Transport Canada.
Select MsTools | Scene Analysis from the menus, or type ANALYSIS at the command line.
Leica Nova MS50 MultiStation Support (Leica DBX Import)
MapScenes Forensic CAD now supports importing Leica DBX projects mapped with the new Leica Nova MS50 MultiStation, including its images and 3D scans.
Images can be imported and displayed in all levels of MapScenes Forensic CAD.
Scans can be imported and displayed only in MapScenes Forensic CAD with the optional Point Cloud module.
To import a Leica DBX database: select MsMeasurement | Read Collector Files In | Leica DBX | Read DBX Database from the menus, or type DBXIN at the command line.
To manage all imported databases: select MsMeasurement | Read Collector Files In | Leica DBX | Manage Imported Databases from the menus, or type DBXMANAGE at the command line.
To view images taken from a specific station: press the Image buttons in the Active Coordinate Editor or the Single Point Editor.
To view all imported images: select MsMeasurement | Read Collector Files In | Leica DBX | View Imported Images from the menus, or type DBXIMAGES at the command line.
To view all imported scans: select MsMeasurement | Read Collector Files In | Leica DBX | View Imported Scans from the menus, or type DBXSCANS at the command line.

Important Fixes

  • [D2844] Active Coordinate Editor - The Shift Selection, Scale Selection, and Rotate Selection commands could cause arcs to be removed from the figures database.
  • [D4930] Active Coordinate Editor - The Rotate Selection command could use 0,0,0 as the rotation base point instead of the specified point.
  • [D4942] Active Coordinate Editor - The Shift Selection command could cause shifted arcs to not be erased when they are redrawn with the shifted points.
  • [D4943] Active Coordinate Editor - The Rotate Selection command could cause rotated arcs to not be erased when they are redrawn with the rotated points.
  • [D4990] Active Coordinate Editor - Point Tracking may not be correct when in Surveyors View
  • [D4991] Active Coordinate Editor - Zoom Selection may not be correct when in Surveyors View
  • [D2344] AutoMap Library - Using both the "Rotate to Previous Point" and "Scale to Previous Point" options together causes rotation to be calcualted to the incorrect point.
  • [D4260] AutoMap Library - Using the "Rotate to Previous Point" option can cause an error if there is not a previous point id.
  • [D5045] AutoMap Library - Using the "Scale to Previous Point" option can cause an error if there is not a previous point id.
  • [D4071] Coordinate Order - the "List E,N (X,Y) Format" system toggle was not always retained.
  • [F1759] Coordinate Order - the "List E,N (X,Y) Format" system toggle will now be honoured for the default column order within the Active Coordinate Editor.
  • [D3819] Dialogs - the CAD Lines, CAD Curves, Single Point Edit, and Quick Text Edit dialogs may not always appear when clicking an appropriate entity.
  • [F1701] Evidence Recorder Export - linework is now automatically exported to Evidence Recorder in an R12 DXF format instead of the default DXF format to avoid exporting incompatible entity types.
  • [D2291] Linework - grip-editing a smart line did not disassociate the line from its previous points in the database.
  • [D2779] Linework - moving a smart line removes its bearing and distance labels from the database.
  • [D3955] Linework - entity snaps could not be used when drawing a curvey leader.
  • [D5021] Linework - 3D .XYZ-Linework can become corrupted after a rescale.
  • [D2813] Nikon Raw File Import - when importing a Nikon 700 raw file with ENZ coordinates, they would be interpreted and imported as NEZ coordinates.
  • [D3967] Polar Snapping - using polar snaps within the Connect Dots Point to Point (_connect_points) command did not work correctly.
  • [D2581] Project Manager - deleting a project from the project manager did not delete its associated .msj database folder.
  • [D4851] Rotate Blocks to Line - the Rotate Text to Line (_ms_rotoline) command stopped working with blocks in the last MapScenes 2010 service pack, this functionality has been restored.
  • [D4987] Run As Administrator - the "Run as administrator" message that can appear under Windows Vista/7/8 has been reworded such that it does not only apply to Vista.
  • [D5077] Saving - Error ASLK8K8K and a crash can occur when running QSAVE after running SAVEAS.
  • [D4263] Scaling - scaling with a fractional value instead of a decimal value was being inappropriately intercepted by the inches-to-feet conversion added in MapScenes 2010.
  • [D4852] Select Point - when selecting a point from the drawing which is stored in the coordinate database, if there is another points within either 0.01 or 0.001 units of it (depending on the command) the incorrect point may be retrieved from the database.
  • [D1931] Sheet and Title Block - a crash may occur when using the Add Sheet and Title Block (_tb) command if your ATTDIA system variable is set to Off.
  • [D4984] Sheet and Title Block - the ATTREQ system variable was not being used correctly.
  • [D5030] Stability - interference between MapScenes and some virus scanners or other resident utilities could cause slowness, error messages, or crashes.
  • [D5002] Surface Modeling - the specified "honour boundary method" option (All Points / Any Point / Center Point) was not applied correctly.
  • [D5598] Alphanumeric Points - Dashes in alphanumeric point IDs can cause the program to stop responding when iterating through the database in some situations.
  • [D4206] Alphanumeric Points - Incrementing alphanumeric point IDs had some inconsistent behaviour. For example, the Next point after "a" may be either "a0" or "a1" depending on the command.
  • [D6121] AutoMap Library - An AutoMap Library located outside of the default folder could not be automatically opened, so the mscad.csv library would load instead.
  • [D6045] Render - A performance issue when rendering Text entities is resolved via a new "Render Text" view option which suppresses the rendering of all text entities for improved performance.
  • [D6098] Roading - Cut Sheets (for Slope Staking, Offset Staking, and Point/Offset Staking) have been removed from the Active Measurements Editor since this functionality is not available with Evidence Recorder.
  • [D6129] Surface Modeling - In the Surface Color Options dialog, selecting Surface Color Method = None does not work.
  • [D6123] Surface Modeling - In the Surface Color Options dialog, when "Drawing Legend" is enabled it may not draw onto the same layer as the surface.
  • [D6045] Point Cloud Linework - A performance issue when rendering Text entities is resolved via a new "Render Text" view option which suppresses the rendering of all text entities for improved performance.
  • [F2227] Point Cloud Linework - When drawing in the point cloud viewer, the AutoMap Library did not control how linework is drawn (including: layer, linetype, 2D/3D, Lines/Polylines).

New Features in IntelliCAD 7.0

Interactive Graphic Elements
Selection crossing/window shows transparent colorization.
Selected entities appear in color during dragging.
Additional grip functionality (arrow grips with more control).
Point indicators to help in graphics creation (e.g., when drawing a 3-point circle).
Paperspace sheet color.
Automatic creation of mview viewport on initial activation of Layout tab.
User Interface
24-bit color icons.
Pulldown menus include support for re-organized commands and the display of icons.
Several dialogs include 24-bit icons or have been re-written.
New docking properties pane with the ability to pin or hide the window.
IntelliCAD Drawing Explorer is enhanced with 24-bit icons, improved layer handling with multi-select support, icons in the list control, and improved usability.
Improvements in handling blocks, views, dimensions, and text styles.
Improvements to snap and selection.
Multiple windows can be open with different views or layouts.
Paperspace supports non-rectangular viewports.
Display Devices
New support for choosing a display device directly from the status bar.
Choose between DirectX, OpenGL, and the computer's default device.
Three new system variables for managing display devices: GSCURRENT, GSPRIMARY, and GSALT.
Graphics Display
Real-time hidden-line and shaded viewing.
Display gradient hatches.
Improved draw order and dragging in color.
Non-rectangular viewports.
Display proxies in blocks and xreferences.
Display ADT and Civil 3D objects.
DWF and DGN overlays.
APIs
IntelliCAD 7 is now using DWGdirect as its internal database.
More New Features
Direct integration with the DWGdirect libraries allows for faster ODA updates.
New Page Setup Manager.
Enhanced Print dialog.
Export STL files.
LAYBYENT command allows you to select an entity to control layer settings or VPLayer settings.
REFEDIT command allows you to edit blocks even if they are in external drawings (Xrefs).
GSCURRENT allows you to change graphics display devices.
Options dialog allows you to change languages on the fly.
Dozens of new hatch patterns.
New FEEDBACK command for users to send in feedback.
Direct access to the User Guide PDF from the Help menu.
Support for visual styles.
New 3D orbit command for easier dynamic rotation and 3D viewing.
New dimension styles.
Ability to display print styles in paper space.
Support for associative dimensions.
Support for relative paths for images and Xreferences.
Performance Enhancements
Opening and saving files.
Real-time rotating, hidden line, and shading.
Double buffer display.
Because DWGdirect is the database, more modern data structures are used which are faster (maps and vectors verses arrays).
Demand loading features as DRX applications, including the Properties pane, IntelliCAD Explorer, External Reference Manager, Image Manager, solids creation/editing, mesh entity creation, and more.
The drawing database is persistent and this speeds access for saving, printing, layout issues, etc.

New Features in IntelliCAD 7.1

Multiline Text
Multline text options menu supports stacked text, overline text, number/list settings, background settings, and more.
DDEDIT supports editing dimension text.
Printing
Enhanced ability to print using previous print settings regardless of IntelliCAD sessions.
Increased zooming capability for Print Preview.
Performance Enhancements
Opening and saving files.
Displaying images.
Selection and deselection.
APIs
IntelliCAD 7.1 uses Teigha for .dwg files version 3.4.1 from the Open Design Alliance (updated from version 3.2). DRX programs and extensions are now named TX.
More features
Support for future Parallel entity snapping. Note that the PARALLEL command was renamed to OFFSET to support the development of Parallel entity snaps for a future update.
Layouts can be copied between drawings in IntelliCAD Explorer.
Exporting to a .pdf file allows setting of portrait or landscape orientation and accepts a paper size in inches in addition to millimeters.
Clipping an image in Professional versions can be inverted, that is, the hidden portion can be either inside or outside of the clip boundary.
Type SETVIEWSIZE at the command prompt to set the IntelliCAD screen size.
Dimension style names can be edited directly in the Dimension Style dialog box without having to click Rename.
Use the DGNATTACH command to attach .dgn files.
New System Variables
Added LOGFILEPATH, MODELTOOLTIPBKGCOLOR, MODELTOOLTIPCOLOR, MTEXTEXPFIELDTOSOLID, ODGELIB, ODGELOG, OSNAPNODELEGACY, and PREVIEWFILTER.
Removed BLOCKCACHESIZE (IntelliCAD now uses the Teigha block cache, which does not have the ability to set the minimum size).
Renamed HELP system variable to HELPPREFIX.

New Features in IntelliCAD 7.2

Performance Enhancements
Graphics device performance improved using OpenGL for graphics cards that support it properly. This greatly improves dynamic pan, zoom, redraw, and rota­tion, especially for large files.
File size and print time reduced for PDF printing.
Grip handling, trimming, and extending improved for splines and polylines with very large segment counts (5,000+) due to improved geometric functions for com­plex curves.
Divide command performance improved.
Dynamic display performance improved in large drawing files using new ZOOMDETAIL and DRAGDETAIL system variables.
Snapping for large drawing files improved.
Dynamic dragging improved during entity creation and modification in large drawing files.
Memory consumption reduced for raster images.
Entity Snaps
Use entity snap tracking.
Use new entity snaps: Parallel Snap, From Point, Temporary Tracking Point, and Midpoint Between 2 Points.
Snap to the center of a polygon (closed polyline).
Working with Other Files
Import .dgn files.
Export Collada format files (.dae files).
Insert underlays from .pdf, .dgn, and .dwf files.
Attach MrSID format files (.sid files).
Specify files and paths for working with IntelliCAD using the new Paths/Files tab interface in the Options dialog box.
Layouts
Clip layout viewports.
Right-click a Layout tab includes From Template.
APIs
IntelliCAD 7.2 uses Teigha for .dwg files version 3.5.1 from the Open Design Alliance.
More New Features
Purge unused drawing elements using the new Purge dialog box.
Find and replace text.
Use the Notification Manager located in the lower right of the IntelliCAD window to view messages and alerts about drawings and running IntelliCAD.
Use updated selection filters to better select entities by property, type, proxy, and more.
Manage layers using utilities at the command line: LAYCUR, LAYDEL, LAYFRZ, LAYISO, LAYLCK, LAYMCH, LAYMCUR, LAYOFF, LAYON, LAYTHW, LAYULCK, LAYUNISO.
New System Variables
Added BALLOONTIMEOUT, DRAGDETAIL, GRAVITYSNAP, GRIDCOLOR, GRIDPOINSMAX, NOTIFYMANAGER, REGENMODEGLOBAL, REGENONZOOMFACTOR, REGENTOOLTIP, and ZOOMDETAIL.

New Features in IntelliCAD 7.2a

AutoCAD® 2013 .dwg/.dxf File Support
MapScenes Forensic CAD 2013 can now automatically convert and open AutoCAD 2013 and AutoCAD 2014 .dwg/.dxf files, then Save them as R12-2010 .dwg/.dxf format.
Or, use the standalone IntelliConvert conversion utility to manually convert R12-2013 .dwg/.dxf files.
New system variables
AECOBJECTS, AUTOCOMPLETEMODE, DEFSAVEASTYPEINDEX, ETRACKDELAY, EXPXREFVISIBILITY, FINDTEXTINT, GRIDDISPLAY, GRIDMAJOR, GRIDSTYLE, GRIPBYKEYBOARD, LTYPEGEN, MTEXTOBLIQUECOLOR, MTEXTSTACKEDCOLOR, PRINTAUTOROTATE, WNDSHOWPROP.

MapScenes Forensic CAD 2013 SP0 (v13.0.3.22) Notes

Important Fixes

  • [D6537] Point Cloud Module - Running MapScenes Forensic CAD + Point Cloud module did not show the correct product information on the Scene Wizard and About dialogs.

MapScenes Forensic CAD 2013 SP1 (v13.1.1.300) Notes

New Features

Powered by IntelliCAD 7.2d
MapScenes Forensic CAD 2013 SP1 is built on the latest IntelliCAD engine, IntelliCAD 7.2d. See below for a summary of what's new.
2D Draw Mode
A new "2D Draw Mode" System Toggle (in MsTools > MapScenes System Toggles, CAD Drawing Controls tab) is now available which causes all points to be drawn at z=0 while maintaining their true elevation in the coordinate database.
Switching this toggle On/Off will update existing points in the drawing as appropriate, causing them to be redrawn at the appropriate elevation.
The OSNAPZ system variable is also automatically turned On/Off with this mode so that new CAD entities will be drawn in 2D when snapping to 3D entities.
Database auditing tools will recognize when this option is enabled and will not attempt to fix the vertical descrepencies between the drawing and database.
Select MsTools > MapScenes System Toggles from the menus, or type CNF_EDIT_TOGGLES at the command line.
Settings Migration Wizard
Easily backup and restore all program settings into a single file, for transferring to another workstation or for disaster recovery.
Backup and restore IntelliCAD settings including your IntelliCAD profile, template drawings, color books, print styles, printers, custom spelling dictionaries, linetypes, fonts, hatch patterns.
Backup and restore MicroSurvey settings including your configuration options, description translation file, AutoMap library files, AutoMap blocks, title blocks, house library, coordinate systems, surface modeling configuration files, and symbol library.
Select MsTools > Migration Wizard from the menus, or type MIGRATION_WIZARD at the command line.
Drawing Recovery Wizard
When opening a drawing where the expected .msz database file is not opened, the program will alert you and provide several options.
A common scenario is if the program crashes, when you reopen the drawing it would always open with the orphaned .msj database folder which may be out of sync with the drawing (the .dwg and .msz files contain everything as of the last save, but the .msj database folder contains everything as of the crash).
Select a recovery option to reopen the last saved .dwg drawing and .msz database files, the last saved .dwg drawing file with the orphaned .msj database folder (as before), the backup .bak drawing and .mbz database files, the autosave .sv$ drawing and .mz$ database files, and more.
Archive all drawing and database files in their current state, so you don't have to worry about making the wrong choice and losing any data.
There is no command to run; the Recovery Wizard will appear automatically if the program detects that an unexpected database file (not the .msz file) is being opened.
Point Cloud Export
Export the point cloud as a .PTS file which is compatible with many third-party point cloud applications.
Export the point cloud as a .PCI file which is compatible with many MicroSurvey and Leica point cloud applications.
Export the entire point cloud, or constrain it within a cutting cube or profile slice.
Select the new "Export Points" button on the Point Cloud Line Work window. (Available with Point Cloud module only.)
Leica Nova MS50 MultiStation Support (Evidence Recorder SyncWizard)
MapScenes now supports importing Evidence Recorder projects mapped with the new Leica Nova MS50 MultiStation, including its images and 3D scans.
Displaying images is available in all MapScenes Forensic CAD product levels.
Displaying scans is only available in MapScenes Forensic CAD with Point Cloud module.
To import a Evidence Recorder project: select MsMeasurement | Evidence Recorder SyncWizard from the menus, or type SYNCWIZARD at the command line.
To manage all imported databases: select MsMeasurement | Read Collector Files In | Leica DBX | Manage Imported Databases from the menus, or type DBXMANAGE at the command line.
To view images taken from a specific station: press the Image buttons in the Active Coordinate Editor or the Single Point Editor.
To view all imported images: select MsMeasurement | Read Collector Files In | Leica DBX | View Imported Images from the menus, or type DBXIMAGES at the command line.
To view all imported scans: select MsMeasurement | Read Collector Files In | Leica DBX | View Imported Scans from the menus, or type DBXSCANS at the command line.
Pentax Import
Import Pentax DC1 Polar, Pentax DC1 Rectangular, Pentax CSV, or Pentax AUX format data files from a Pentax total station.
The Pentax DC1 Polar format contains raw measurement data.
The Pentax DC1 Rectangular format contain point coordinates only.
The Pentax CSV format contain point coordinates only.
The Pentax AUX format contains raw measurement data.
Select MsMeasurement > Read Collector Files In > Pentax DC1/CSV from the menus, or type PENTAX at the command line.

Improved Features

Updated Vehicle Database Browser
Scene Analysis tool contains the most recent vehicle specifications database (v2013.2), which includes all 1971-2013 models and some 2014 models.
The vehicle specifications database is compiled by the Collision Investigation and Research Division of Transport Canada.
Select MsTools | Scene Analysis from the menus, or type ANALYSIS at the command line.
Auto-Add Points to Objects: Graphical Interface
Set the starting point ID and description to use for the new points.
Set the point description based on the entity's layer name or block name.
Set the selection filter to use only the desired entity types, from: Points, Lines, Arcs, Circles, Polylines, Blocks, and Text.
An alert will be displayed if any of the layers being drawn to are turned off or frozen, alowing you to turn them on and thaw them.
Select MsPoints | Auto-Add Points from Objects from the menus, or type AUTOP at the command line.
Active Coordinate Editor: Select Points by Description
You can now select points by description in the Active Coordinate Editor.
Includes options for case-sensitivity and matching the entire description.
Go to Select > Select By Description, within the Active Coordinate Editor window.
Labeling Defaults: Width Factors
Define text widths for all of the text styles in the MicroSurvey Labeling Defaults.
Select MsLabeling > Labeling Defaults from the menus, or type CNF_EDIT_DISTANCES at the command line.
Updated Coordinate System Engine
The CS-Map coordinate system engine was updated to provide 100% cross-compatibility between MapScenes Forensic CAD and MapScenes Evidence Recorder.

Important Fixes

  • [D6059] Stability - A significant performance issue affecting Windows XP users has been fixed, where the program could stop responding and leave the CPU Usage pinned at 100%.
  • [D6195] 3D Offset - Negative vertical offset (down) values could not be specified.
  • [D6335] Animation - The EXIT, CLOSE and WCLOSE commands were not being monitored while the ANIM command is running, which could result in changes not being saved to the .ani animation file.
  • [D6337] Active Coordinate Editor - Switching drawings in the CAD window may not reliably switch the Coordinate Editor view to match the current drawing.
  • [D6390] AutoMap Library - Switching drawings in the CAD window could cause the program to stop responding if the drawing's AutoMap Library references a block that cannot be found.
  • [D6303] Drawing Cleanup Wizard - The "Bind External References (Xrefs) as Blocks" option did not work because of the new Xref Manager dialog.
  • [D6369] Edit Symbol - CRUSH_END command may incorrectly report "No current crush session has been detected.
  • [D6370] Edit Symbol - Hatch Patterns may be displayed on top of all other entities, requiring a regen.
  • [D6371] Edit Symbol - Associative Hatch Patterns may be placed incorrectly.
  • [D6372] Edit Symbol - A typo "Redefineing block" has been corrected.
  • [D2251] Entity Snaps - Running entity snaps are no longer turned off during the Fence Line, Tree Line, Text Line commands.
  • [D5984] Erase Layer - points and/or figures that are erased were not automatically removed from the database.
  • [D6382] Exit - The program may crash during exit if the render or point cloud windows are open.
  • [D6000] Evidence Recorder Export - Blocks containing non-constant attribute definitions would cause an error message "Error PA2-W5S, Unable to create entity (INSERT) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6351] Evidence Recorder Export - Proxy Entities would cause an error message "Error PA2-W5S, Unable to create entity (ACAD_PROXY_ENTITY) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6352] Evidence Recorder Export - Arc Dimensions would cause an error message "Error PA2-W5S, Unable to create entity (ARC_DIMENSION) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6357] Evidence Recorder Export - Multi-Leaders would cause an error message "Error PA2-W5S, Unable to create entity (MLEADER) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6367] Evidence Recorder Import - Lines and Arcs in the Evidence Recorder project were not automatically added into the figures database and associated with the appropriate points.
  • [D6362] Evidence Recorder Import - The "Archive project upon import" option did not default on/off as appropriate like in previous versions.
  • [D6323] Evidence Recorder Import - An "Error, attempting to create directory" message could occur on startup if the program was installed by a different user account.
  • [D6354] Insert Picture - Insert Picture command was missing from the Insert menu.
  • [D6341] Lineweight Units - A new System Toggle has been added so that the automatic setting of the LWUNITS system variable (added in SP1.1) can be enabled or disabled.
  • [D6018] Save As - Saving to the same filename of another currently open file could cause an error message and crash.
  • [D6052] Save As - Saving to the same filename with a different extension could cause an error message and crash.
  • [D6353] Save As - An error message "Unable to recognize command saveas2. Please try again." would appear, and the new database file was not immediately reopened.
  • [D6409] 3-Point Inverse - Results of the MS_SHOW_ANGLE command are now displayed to the command line, in addition to the existing popup message.
  • [D6529] ASCII Import – importing a space-delimited file with a blank line at the end of the file will zero the last read point.
  • [D2959] Clusters – the Report, Groups, and Both option was being ignored and always used Both.
  • [D2303] Coordinate Database – storing point IDs with leading zeroes (like "001") caused various problems.
  • [D4148] Coordinate Database – converting legacy .msd databases with improper data could cause the program to stop responding.
  • [D4721] Coordinate Database – converting legacy .msd databases with improper data could cause the program to stop responding.
  • [D4299] Coordinate Systems - "Other North American Systems" coordinate system group displays garbled characters.
  • [D2238] Entity Properties – changing the layer of a line/arc will remove it from the database.
  • [D6119] Entity Properties – changing non-geometric properties of a line/arc will remove it from the database.
  • [T1615] Error Log - Problems that occur during use of the program are now logged to a file which can be used by MicroSurvey staff to debug problems.
  • [D4151] Graphic Coordinate Editor – Undo could cause the program to crash.
  • [D4986] Graphic Coordinate Editor – entities could not be removed from groups.
  • [D6120] Graphic Coordinate Editor – adding a large group of points could cause the program to crash.
  • [D2673] Independent Point Numbers – IPN colors cannot be set to Black on a White background.
  • [D5957] Independent Point Numbers – IPN colors did not display correctly on a White background.
  • [D6201] Leica DBX Import - When importing a DBX database from a network location using the UNC path instead of a mapped drive letter may cause an error message "No service capable of opening the requested data set could be found."
  • [D6387] Leica DBX Import - Setup records not used for any point measurements were not imported into the traverse database.
  • [D6302] Leica DBX Import - Resection records were imported with the Instrument Height from the previous setup.
  • [D6379] Point Cloud Linework - The "Grid Cell Count" grid setting was mislabelled as "Arc Segments."
  • [D6398] Point Cloud Linework - When opening .PCI files, the points may not be displayed until pressing the Force Point Reload button.
  • [D6309] Point Cloud Linework - When opening .PTS files, the program may crash.
  • [D6187] Point Cloud Linework - When opening .LAS or .PTS files, the point intensities may not be read.
  • [D6391] Point Cloud Linework - Adjusting the grid manipulators may cause the view to rotate.
  • [D6365] Point Cloud Linework - The Grid Search routine could run extremely slowly, taking hours instead of seconds to complete.
  • [D2294] Printing – when printing a Clusters report or Cut Sheet report, only the first page was printed.
  • [D2737] Printing – when printing from an Active Drawing Technology window, the Print Selection option was always disabled.
  • [D2279] Printing – when doing a Print Preview from an Active Drawing Technology window, the Previous Page and Zoom Out buttons do not work.
  • [D3223] Printing – when doing a Print Preview from an Active Drawing Technology window, clicking the middle-mouse button enters auto-scroll mode which cannot be exited.
  • [D6375] Render/Materials - Materials that could not be found could cause the program to stop responding.
  • [D6376] Render/Materials - Browsing to select a texture file may not start in the default textures folder.
  • [D6377] Render/Materials - Materials placed on some entities were not used in the rendered view.
  • [D5948] Repeat Last Command - Various messages sent by the program to the commandline (including LBD, UPDATEACE, etc) would interfere with the ability to repeat the last command.
  • [D6436] Save As - overwriting an existing drawing would not overwrite the existing database file.
  • [D3586] Surface Modeling - Contour interval color options may not always work as expected.
  • [D6420] Surface Modeling - Drawing cross-sections can produce a message "WARNINg_ Could not get osmode".
  • [D6612] Surface Modeling - Extracting breaklines from a large selection set may cause a crash.
  • [D6039] System Toggles - New options added into the program that are not present in your saved config file may not default to the intended value.
  • [D2001] Transfer Points between MapScenes Files – repeating a point range gives an illegible error message.
  • [D5595] Undo - Undo did not work well under Windows XP because it would undo each command in several steps instead of undoing the entire command in one step.
  • [D5977] Undo – focus can jump to another program after the "MicroSurvey database update report" dialog appears.
  • [D4929] Undo/Redo - Redo was not reliable, it would generate a message that it must immediately follow an UNDO.
  • [D6517] Evidence Recorder Import - The Default Folder and Last Used Folder settings were not being saved and restored correctly.
  • [D6580] Active Coordinate Editor - Sorting the points by Point ID does not sort the points numerically.
  • [D3944] Active Coordinate Editor - Auto-Adding Points to Point Nodes did not update the coordinate editor to show the new points.
  • [D6788] Baseline Offset - An error message "Unable to recognize command run_bat" would occur.
  • [D6792] Delete Project Database - Attempting to delete the current project's database file produced a warning message that was partially cut off.
  • [D5494] Dimensions - Erasing a dimension that was drawn by snapping to a survey line may cause the line to be removed from the database.
  • [D5882] Edit Point - The point node and labels were not highlighted while editing a point.
  • [D5959] Edit Point - The display did not immediately update after storing or editing a point.
  • [D6023] Independent Point Numbers - IPN labels need to be updated when resizing the drawing window.
  • [D6759] Point Blocks - Scanning for Point Blocks with Attributes can cause the mscad.dll to perform an illegal operation.
  • [D6372] Point Cloud Linework - Command was not present in the Capture menu or toolbar.
  • [D6638] Point Cloud Linework - Drawing a curvy polyline arc on a vertical reference plane can cause the program to crash.
  • [D6545] Surface Modeling - A crash may occur when drawing contour labels.
  • [D2991] Undo - After copying database points, an Undo may remove the original points from the database.
  • [D5850] Undo - After copy/paste of database points, an Undo may delete the original points.

Important Fixes in IntelliCAD 7.2b

The following list details some of the new 450+ fixes that were implemented since the 7.2a release.

Working with drawing files
Fixed crash resulting from auditing files in some cases.
Improvements to auto-saving.
Printing
Fixed reported cases where printing or print preview caused a crash.
Fixed Display Print Styles to update display properly.
Fixed printing on large custom paper sizes.
Dimensions
DIMARC added to the Dimensions menu and toolbar.
Update added to the Dimensions menu and toolbar.
Fixes for DIMRADIUS and DIMCENTER for blocks.
Snapping and tracking
Fixed ORTHO priority when ETRACK is enabled.
Fixed issue with OFFSET while also entity snapping.
Fixed Parallel snap when working with both Parallel and Extension snaps enabled.
Improvements to activating multiple snaps from the command line.
Quadrant snap and entity tracking issues fixed when working in UCS.
Entity snapping fixed for entities in paperspace.
Fixed POLAR for a rotated UCS.
Entity snaps fixed for plane surfaces.
Blocks
Fixed rotation issues during block insertion.
Fixed issue when inserting uniform-scale blocks.
Text
Multiline text improvements: Select All, right-click to paste without formatting, clear all formatting.
Multiline text justification improvements.
Fixes where formatting differed in editor and drawing (mtext).
Hatches
Fixed case where hatch disappeared after copying or moving it.
Fixed using the Stretch command with hatches.
Improvements to hatches that displayed with low density.
Improvements to hatch prompts.
More fixes
Crashes fixed during Layout switching in some cases.
Loading a .mnu file from a path with a dot symbol.
Double-click enabled for moving to paperspace while other entities are selected.
Fixed several issues when working with grips.
Improvements for working with OLE objects.
Fix for arc entities, including the Follow option.
Default toolbar layout improved in main window.
New toolbars: Zoom and Draworder. Some commands moved from the View toolbar to the Zoom toolbar.
Fixed display of Drawing Settings dialog box in non-English languages.
Zoom Object command added.
Fixed Zoom Dynamic for NWUCS.
Color selection fixed for cases where a crash was caused.
Multiple issues with wipeouts fixed.
Added recent command list to the context menu for right-clicking in a drawing.
Fixed issues handling large number of groups in IntelliCAD Explorer.
PURGE command now works with unnamed groups.
Fixed EXTRUDE for entities with large coordinates and for extruding regions on a closed polyline.
Fixed issue when drawing boxes with negative Z value.
Hyperlink icon display improved.
Fixes for the Stretch command.
Fix for entity display when layer color changes.
Fixes for Zoom Dynamic.
New system variables
ASYNCINIT, GROUPMAX, HIGHLIGHTLIMIT, HYPERLINKICON, HYPERLINKICONCOLOR, HYPERLINKICONSCALE, OLEBKGCOLOR, PRINTTEXTOUT, RTDISPLAY, and USEOLEBKGCOLOR.

Important Fixes in IntelliCAD 7.2c

The following list details some of the new 200+ fixes that were implemented since the 7.2b release.

Working with drawing files
Fixed conversion for files on read-only network drives.
Export PDF includes U.S./Imperial units support.
Performance for SAVEAS doubled.
Printing
Fixed printing when using the Window option.
Print Preview fixed to display polylines in some cases where they were not visible.
Fixed printing for entities with thickness different from "0".
Printing with a header or footer (Tools > Options > Printing) uses "," character to separate left, middle, and right aligned text.
Snapping and tracking
Center snap fixed when snapping to arc segment of closed polyline.
Nearest snap fixed when using grid and Ortho.
Snapping fixed to work with circles of small radiuses.
Extension snap fixed in UCS for linear entities.
Parallel snapping fixed for external references.
Polar tracking fixed in NWUCS.
Snap INT fixed for multi-line entities.
Entity snap markers visible when they display for entity of same color using the OSNAPXORDRAW system variable.
Text
MTEXT entity display accuracy improved in reported cases.
Text position fixed when changing text.
Alternate fonts fixed to be used for missing TrueType fonts.
Direct entry of Unicode codes is now supported in the Multiline Text dialog box.
More fixes
Association fixed for aligned dimensions.
Selection corrected for 3D line grips.
Draworder fixed for exploded blocks.
Improved context menu when right-clicking drawing window, including the addition of recently used commands.
Fixed SPLINEDIT layer issue.
Clicking and holding down the middle mouse button now activates the Pan command.
Fix for -IMAGE command when detaching.
Modified the order of entities in the selection set to be more consistent.
Performance improvement for DRAWORDER.
Fixed data issues when creating ATTDEF entities.
Added context menu when right-clicking user paths in Tools > Options > Paths/Files.
Fixed wipeout creation using entmake.
IntelliCAD Explorer now works with additional image file formats.
Fixed hatch creation in active viewports.
Fixed the Flatten command when working with leaders.
Enhanced performance of RTPAN.
New system variable
OSNAPXORDRAW.

Important Fixes in IntelliCAD 7.2d

The following list details some of the new 300+ fixes that were implemented since the 7.2c release.

Working with drawing files
Improved file conversion process for 2013 .dwg file versions.
Fixed issue with SAVEAS command on Windows 7 x64 operating systems.
Several improvements to PDF export.
File security improved.
Performance improvements
Selection performance improved in large drawings, including those with many groups or hyperlinks.
Dragging performance improved, including extents drawn when using COPY and COPYCLIP.
Improved speed performance when printing 3D visual styles in viewports.
Printing
Issue fixed when printing gradients.
Fixed issues when printing and previewing drawings with rotated views.
Improvements to printing in color.
Fixed reported issues when printing MTEXT.
Selecting and viewing
Fixed display issues in read-only drawings.
Fixed reported display issues when zooming.
Fixed display issues that previously required REGEN.
Fixed REGEN issues.
Snapping and tracking
Entity snapping fixed when osmode = 0.
Fixes for snap accuracy.
Fixes for reported issues with Perpendicular Snap and Parallel Snap.
Text
Negative oblique angle fixed when using DDEDIT.
Fixed usage of current text style for multiline text.
Fixed Text Fit option.
Background color can now be turned off in the Multiline Text dialog box.
Properties
Image Scale value fixed.
Fixed text direction.
More fixes
Fixed localized versions that were not accepting some command options.
Fix for moving rotated dimensions.
Fixed issue when using Dim Continue on Dim Ordinate with a different UCS.
Fixed PLINE ARC drawn with negative angles in clockwise direction.
Added Bind option to Explorer > External References.
System variables fixed to be read-only: LOCALROOTPREFIX, MYDOCUMENTSPREFIX, and ROAMABLEROOTPREFIX.
Explode command fixed for 3D faces.
EXPLAYOUTS fixed for importing and exporting layouts to/from drawing templates.
Grid density improvements.
Fix for attribute selection order.
Fixes for extruding polylines and regions.
Fixes for stretching dimension text.
Hatch area calculations improved.
Fixed issue during layout viewing/switching when LAYOUTREGENCTL = 1.
New system variables
AUTOCONVERT, FASTIMAGEDRAW, FINDOPTIONS, NETFLOATLICENSE, PRINTIMAGEQUALITY, SPACEASENTER.
(0 vote(s))
Helpful
Not helpful

Comments (0)