Knowledgebase
MicroSurvey CAD 2014 Release Notes
Posted by Brian Sloman on 08 October 2013 09:38 AM

Release History

MicroSurvey CAD 2014 (v14.0.2.13) - November 22, 2013

MicroSurvey CAD 2014 SP1 (v14.1.0.14) - December 20, 2013

MicroSurvey CAD 2014 SP2 (v14.3.1.307) - April 4, 2014


Important Notes

Activating or Updating your USB License Key

If you are licensing MicroSurvey CAD for the first time you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2013/2010/2009/2008, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2005 or previous, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MicroSurvey CAD, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MicroSurvey CAD service pack updates. For a detailed explanation of MicroSurvey's Maintenance Subscription Support Plan (MSSP) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your Maintenance Subscription has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the MSSP by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date.

If your MSSP has expired, you can phone us at 1-800-668-3312 or 1-250-707-0000 to renew it. Without a current maintenance subscription plan, you may not be able to update your key to work with the new version.

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users need to download a copy of the MicroSurvey Transfer program to simplify the process of transferring FieldGenius projects between your data collector and MicroSurvey CAD.

If you have a copy of MicroSurvey Transfer already installed from use with MicroSurvey CAD 2010 or previous, you will need to update it to recognize MicroSurvey CAD 2013 or newer. Previous versions of MicroSurvey Transfer will not show MicroSurvey CAD 2014 as a sync option in the Options screen.

The MicroSurvey Transfer program has not changed since the release of MicroSurvey CAD 2013. This is only necessary for users who are setting up communications between FieldGenius (any version) and MicroSurvey CAD (2013 or newer) for the first time.

MicroSurvey Transfer can be downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

The MicroSurvey Network License Server program has not changed significantly since the release of MicroSurvey CAD 2008 v8.0.0. This is only necessary for users who are setting up a MicroSurvey CAD 2008 or newer network license for the first time.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey CAD 2014 is compatible with 32-bit and 64-bit versions of Microsoft Windows XP SP3, Windows Vista SP2, Windows 7 SP1, and Windows 8.

MicroSurvey CAD 2014 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, aside from a compatible video card for the 3D Rendering engine. Please refer to this online article for a list of compatible video cards.

Windows Vista, Windows 7 & Windows 8 Notes

Run as Administrator

If installing on Windows Vista/7/8 you must run the program at least once elevated with "Run as admininstrator" access, even if you are already logged in with an "Administrator" account on the computer.

After this is done, it can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MicroSurvey CAD 2014 icon.
  2. Choose "Run as administrator".
  3. Select "Yes" on the "User Account Control" dialog when prompted to allow the program to make changes to your computer.

What's This? Help

If you wish to use the What's This? Help feature under Windows Vista/7/8, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


Online Resources

Release Notes

For a current version of this document, please visit the MicroSurvey CAD 2014 Release Notes topic in our online helpdesk.

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MicroSurvey CAD 2014 Frequently Asked Questions topic in our online helpdesk.

Upgrade Notes

For a list of questions and answers on upgrading from a previous version, please visit the MicroSurvey CAD 2014 Upgrade Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MicroSurvey CAD 2014 Known Issues topic in our online helpdesk.

Training Movies

For over 16 hours of training movies that you can watch online or download for offline viewing, please visit the Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at http://helpdesk.microsurvey.com/ where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are not answered in your Help file and Manuals.

For technical support, please visit our helpdesk at http://helpdesk.microsurvey.com/ to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Maintenance Subscription Support Plan (MSSP).

To purchase or renew your MSSP, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000, phone your local MicroSurvey dealer, or visit our online store at http://store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to comment and vote on other users' feature requests, please visit our Feature Request Forum at http://feedback.microsurvey.com.

User Forum

To discuss your MicroSurvey product with other users, please visit our User Forum at www.microsurvey.com/forum.


MicroSurvey CAD 2014 (v14.0.2.13) Notes

New Features

Geospatial Data and Imagery (Beta Feature)
Enhance your drawing with geospatial data and imagery, loaded from local files or streamed from online sources.
Powered by Blue Marble Geographics' Global Mapper SDK v15.
Over 150 supported file formats including Raster Images, Shapefiles, LiDAR, GeoPDF, GeoTIFF, Microstation DGN, ASCII Coordinates, ESRI, ERDAS, Garmin, KML, COLLADA, Sketchup, and many many many more...
Stream online imagery from any WMS (Web Map Service), WCS (Web Coverage Service), OSM (OpenStreetMap Tiles), Google Maps Tiles, TMS (Tile Map Service), WFS (Web Feature Services), or WMTS (tiled WMS) source.
Select MsTools > Global Mapper from the menus, or type GLOBAL_MAPPER at the command line. (Available in Premium, Ultimate and Studio versions only.)
Please refer to the Global Mapper topic in the help file for special instructions; you must load an additional program file into MicroSurvey CAD before this command can be run.
2D Draw Mode
A new "2D Draw Mode" System Toggle (in MsTools > MicroSurvey System Toggles, CAD Drawing Controls tab) is now available which causes all points to be drawn at z=0 while maintaining their true elevation in the coordinate database.
Switching this toggle On/Off will update existing points in the drawing as appropriate, causing them to be redrawn at the appropriate elevation.
The OSNAPZ system variable is also automatically turned On/Off with this mode so that new CAD entities will be drawn in 2D when snapping to 3D entities.
Database auditing tools will recognize when this option is enabled and will not attempt to fix the vertical descrepencies between the drawing and database.
MsTools > MicroSurvey System Toggles from the menus, or type CNF_EDIT_TOGGLES at the command line.
Settings Migration Wizard
Easily backup and restore all program settings into a single file, for transferring to another workstation or for disaster recovery.
Backup and restore IntelliCAD settings including your IntelliCAD profile, template drawings, color books, print styles, printers, custom spelling dictionaries, linetypes, fonts, hatch patterns.
Backup and restore MicroSurvey settings including your configuration options, description translation file, AutoMap library files, AutoMap blocks, title blocks, house library, coordinate systems, surface modeling configuration files, and symbol library.
Select MsTools > Migration Wizard from the menus, or type MIGRATION_WIZARD at the command line.
Drawing Recovery Wizard
When opening a drawing where the expected .msz database file is not opened, the program will alert you and provide several options.
A common scenario is if the program crashes, when you reopen the drawing it would always open with the orphaned .msj database folder which may be out of sync with the drawing (the .dwg and .msz files contain everything as of the last save, but the .msj database folder contains everything as of the crash).
Select a recovery option to reopen the last saved .dwg drawing and .msz database files, the last saved .dwg drawing file with the orphaned .msj database folder (as before), the backup .bak drawing and .mbz database files, the autosave .sv$ drawing and .mz$ database files, and more.
Archive all drawing and database files in their current state, so you don't have to worry about making the wrong choice and losing any data.
There is no command to run; the Recovery Wizard will appear automatically if the program detects that an unexpected database file (not the .msz file) is being opened.
Updated Coordinate System Engine
The CS-Map coordinate system engine was updated to provide 100% cross-compatibility between MicroSurvey CAD and MicroSurvey FieldGenius.
Hundreds of new coordinate systems and geoids (previously available only for MicroSurvey FieldGenius) are available for download in the MicroSurvey Helpdesk.
Select a vertical system (ellipsoid or geoid) and perform vertical datum transformations.
Vertical Transformations
All commands that previously allowed a horizontal coordinate system transformation now also support vertical transformations.
To transform individual coordinates, select MsPoints > Geodetic > Manual Coordinate Conversion from the menus, or type LL_TRANSFORM_COORDINATES at the command line.
To transform your coordinate database, select MsPoints > Geodetic > Transform Database from the menus, or type TRANSFORM_COORDINATES at the command line.
To transform coordinates during ASCII Import, select MsPoints > Import ASCII or Lat/Long File from the menus, or type ASCII_IN at the command line.
To transform coordinates during ASCII Export, select MsPoints > Export ASCII or Lat/Long File from the menus, or type ASCII_OUT at the command line.
Store & Edit Geodetic Position
Store & Edit the geodetic position of grid points using a new dialog with the same look-and-feel as the standard Store & Edit Points command.
Edit the Latitude, Longitude, Elevation, Description, Note, etc for each point.
View the Northing and Easting for each point (read-only).
View the Combined Scale Factor for each point (read-only).
View the Convergence Angle for each point (read-only).
Use the new "Use Single Point Editor: Geodetic" System Toggle (in MsTools > MicroSurvey System Toggles) to use this dialog by default when clicking on a point in the drawing to edit it.
Select MsPoints > Store & Edit Geodetic Position in the menus, or type EDITPG at the command line.
Identify Geodetic Position
Identify the geodetic position (including the Latitude, Longitude, Combined Scale Factor, and Convergence Angle) of grid points by clicking in your drawing.
Select MsPoints > ID Lat/Long of Point in the menus, or type IDG at the command line.
Label Geodetic Position
Label the geodetic position (including the Latitude, Longitude, Combined Scale Factor, and Convergence Angle) of grid points in your drawing, with customizable format and precision options.
Select MsAnnotate > Add Lat/Long Label for a Point in the menus, or type LABLPNTG at the command line.
Coordinate System Search
Search for appropriate coordinate systems, based on a specified latitude/longitude position.
Select your appropriate system from the search results, and instantly set it as your drawing's Coordinate System.
Select MsPoints > Geodetic > Coordinate System Search, or type CSSEARCH at the command line.
Active Coordinate Editor: Select Points by Description
You can now select points by description in the Active Coordinate Editor.
Includes options for case-sensitivity and matching the entire description.
Go to Select > Select By Description, within the Active Coordinate Editor window.
Active Coordinate Editor: Coordinate Systems
You can now view columns showing the Combined Scale Factor for each coordinate.
You can now view columns showing the Convergence Angle for each coordinate.
You can now view columns showing the Elevation for each transformed coordinate.
The Coordinate Systems dialog has been reworked to make it more intuitive and easier to use.
Go to Tools > Coordinate Systems, within the Active Coordinate Editor window.
Point Cloud Export
Export the point cloud as a .PTS file which is compatible with many third-party point cloud applications.
Export the point cloud as a .PCI file which is compatible with many MicroSurvey and Leica point cloud applications.
Export the entire point cloud, or constrain it within a cutting cube or profile slice.
Select the new "Export Points" button on the Point Cloud Line Work window. (Available in Ultimate and Studio versions only.)
Pentax Import
Import Pentax DC1 Polar, Pentax DC1 Rectangular, Pentax CSV, or Pentax AUX format data files from a Pentax total station.
The Pentax DC1 Polar format contains raw measurement data.
The Pentax DC1 Rectangular format contain point coordinates only.
The Pentax CSV format contain point coordinates only.
The Pentax AUX format contains raw measurement data.
Select MsTraverse > Read Collector Files In > Pentax DC1/CSV from the menus, or type PENTAX at the command line.
Scale Text Values
Scale text entity values (standard text, distance labels, or elevation labels) for conversion between different units or with a specified scale factor.
Format the result using only the new value, both the old and new values, or stack the old and new values as separate text entities, using fully customizable prefix/suffix and seperator options.
Select MsAnnotate > Modify Text > Scale Text Values or type SCALEVAL at the command line.
Labeling Defaults: Width
Define text widths for all of the text styles in the MicroSurvey Labeling Defaults.
Select MsAnnotate > Labeling Defaults from the menus, or type CNF_EDIT_BEARINGS at the command line.

Important Fixes

  • [D6529] ASCII Import - importing a space-delimited file with a blank line at the end of the file will zero the last read point.
  • [D6409] 3-Point Inverse - Results of the MS_SHOW_ANGLE command are now displayed to the command line, in addition to the existing popup message.
  • [D2959] Clusters - the Report, Groups, and Both option was being ignored and always used Both.
  • [D2303] Coordinate Database - storing point IDs with leading zeroes (like "001") caused various problems.
  • [D4148] Coordinate Database - converting legacy .msd databases with improper data could cause the program to stop responding.
  • [D4721] Coordinate Database - converting legacy .msd databases with improper data could cause the program to stop responding.
  • [D4299] Coordinate Systems - "Other North American Systems" coordinate system group displays garbled characters.
  • [D6217] Coordinate Transformations - in the case of invalid input data, an illegible error message was displayed.
  • [D2238] Entity Properties - changing the layer of a line/arc will remove it from the database.
  • [D6119] Entity Properties - changing non-geometric properties of a line/arc will remove it from the database.
  • [T1615] Error Log - Problems that occur during use of the program are now logged to a file which can be used by MicroSurvey staff to debug problems.
  • [D4151] Graphic Coordinate Editor - Undo could cause the program to crash.
  • [D4986] Graphic Coordinate Editor - entities could not be removed from groups.
  • [D6120] Graphic Coordinate Editor - adding a large group of points could cause the program to crash.
  • [D3934] Help - Help button in the Active Coordinate Editor's Coordinate Systems dialog did not work.
  • [D2673] Independent Point Numbers - IPN colors cannot be set to Black on a White background.
  • [D5957] Independent Point Numbers - IPN colors did not display correctly on a White background.
  • [D4358] LandXML Import - Surface models were not loaded directly into the QuickSurf surface modelling engine.
  • [D6364] Lat/Long ASCII Export - Export dialog was mislabelled as "Import File".
  • [D6201] Leica DBX Import - When importing a DBX database from a network location using the UNC path instead of a mapped drive letter may cause an error message "No service capable of opening the requested data set could be found."
  • [D6387] Leica DBX Import - Setup records not used for any point measurements were not imported into the traverse database.
  • [D6302] Leica DBX Import - Resection records were imported with the Instrument Height from the previous setup.
  • [D6516] New Drawing - the NEWWIZ command can cause the program to stop responding if Degrees-minutes-seconds unit option is selected.
  • [D6379] Point Cloud Linework - The "Grid Cell Count" grid setting was mislabelled as "Arc Segments."
  • [D6398] Point Cloud Linework - When opening .PCI files, the points may not be displayed until pressing the Force Point Reload button.
  • [D6309] Point Cloud Linework - When opening .PTS files, the program may crash.
  • [D6187] Point Cloud Linework - When opening .LAS or .PTS files, the point intensities may not be read.
  • [D6391] Point Cloud Linework - Adjusting the grid manipulators may cause the view to rotate.
  • [D6365] Point Cloud Linework - The Grid Search routine could run extremely slowly, taking hours instead of seconds to complete.
  • [D2294] Printing - when printing a Clusters report or Cut Sheet report, only the first page was printed.
  • [D2737] Printing - when printing from an Active Drawing Technology window, the Print Selection option was always disabled.
  • [D2279] Printing - when doing a Print Preview from an Active Drawing Technology window, the Previous Page and Zoom Out buttons do not work.
  • [D3223] Printing - when doing a Print Preview from an Active Drawing Technology window, clicking the middle-mouse button enters auto-scroll mode which cannot be exited.
  • [D6375] Render/Materials - Materials that could not be found could cause the program to stop responding.
  • [D6376] Render/Materials - Browsing to select a texture file may not start in the default textures folder.
  • [D6377] Render/Materials - Materials placed on some entities were not used in the rendered view.
  • [D5948] Repeat Last Command - Various messages sent by the program to the commandline (including LBD, UPDATEACE, etc) would interfere with the ability to repeat the last command.
  • [D6436] Save As - overwriting an existing drawing would not overwrite the existing database file.
  • [D3586] Surface Modeling - Contour interval color options may not always work as expected.
  • [D6420] Surface Modeling - Drawing cross-sections can produce a message "WARNINg_ Could not get osmode".
  • [D6612] Surface Modeling - Extracting breaklines from a large selection set may cause a crash.
  • [D6488] Stake Out Report - Pressing Enter to repeat the Stake Out Points command would cause the program to crash.
  • [D6039] System Toggles - New options added into the program that are not present in your saved config file may not default to the intended value.
  • [D2001] Transfer Points between Jobs - repeating a point range gives an illegible error message.
  • [D5595] Undo - Undo did not work well under Windows XP because it would undo each command in several steps instead of undoing the entire command in one step.
  • [D5977] Undo - focus can jump to another program after the "MicroSurvey database update report" dialog appears.
  • [D4929] Undo/Redo - Redo was not reliable, it would generate a message that it must immediately follow an UNDO.

MicroSurvey CAD 2014 SP1 (v14.1.0.14) Notes

New Features

Geospatial Data and Imagery
Enhance your drawing with geospatial data and imagery, loaded from local files or streamed from online sources.
Powered by Blue Marble Geographics' Global Mapper SDK v15.
Over 150 supported file formats including Raster Images, Shapefiles, LiDAR, GeoPDF, GeoTIFF, Microstation DGN, ASCII Coordinates, ESRI, ERDAS, Garmin, KML, COLLADA, Sketchup, and many many many more...
Stream online imagery from any WMS (Web Map Service), WCS (Web Coverage Service), OSM (OpenStreetMap Tiles), Google Maps Tiles, TMS (Tile Map Service), WFS (Web Feature Services), or WMTS (tiled WMS) source.
Select MsTools > Global Mapper from the menus, or type GLOBAL_MAPPER at the command line. (Available in Premium, Ultimate and Studio versions only.)

Important Fixes

  • [T1675] Coordinate Systems - A link to open the Mapping folder has been added in the Info dialog located beside the Vertical Coordinate System option on the General Configuration Options dialog.
  • [D6672] Coordinate Transformations - Coordinates outside the extents of the US VERTCON grid shift files could not be transformed from UTM-NAD83 to UTM-NAD27, even when not using the NADCON grid shift files for the transformation.
  • [D6622] Coordinate Transformations - Custom column settings in the Active Coordinate Editor were incorrectly migrated from previous versions which could result in a unit scaling problem.
  • [D6678] Drawing Recovery Wizard - When opening a drawing that is in-use or read-only, the Recovery Wizard should not take any action.
  • [D6517] FieldGenius Import - The Default Folder and Last Used Folder settings were not being saved and restored correctly.
  • [D6633] Global Mapper - Items in the imagery data list may become duplicated.
  • [D6634] Global Mapper - Error dialogs cannot be dismissed by pressing OK, effectively hanging the program.
  • [D6635] Global Mapper - The program may crash during Exit after running the Global Mapper command.
  • [D6637] Global Mapper - The program may frequently stop responding when adding an online data source.
  • [D6639] Global Mapper - Deleting an item from the imagery data list sometimes does not work.
  • [D6640] Global Mapper - The icad.exe process may not terminate when exiting the program after running the Global Mapper command.
  • [D6641] Global Mapper - An "Unknown command's exception" error message may occur.
  • [D6642] Global Mapper - A manual REGEN is sometimes required to make the imagery display.
  • [D6645] Global Mapper - Various custom data files were created in the wrong folder.
  • [D6653] Global Mapper - The program may stop responding when running CAD commands after running the Global Mapper command.
  • [D6710] Global Mapper - A regen may occasionally cause the imagery to disappear.
  • [D6712] Global Mapper - The background color can now be controlled, so black lines in a shapefile are not invisible against the default black background.
  • [T1648] Global Mapper - The Global Mapper command is now automatically loaded into the program.
  • [D6647] Menus - The prompt to reset your menus when upgrading from a previous version contained a warning message about the Context menus that is no longer applicable.
  • [D6704] Pentax Import - Pressing OK without selecting a valid data file to import can cause the program to crash.
  • [D6689] Scale Text Values - Hovering mouse over the Input Scale Factor and Output Scale Factor options could partially obscure their corresponding values.

MicroSurvey CAD 2014 SP2 (v14.3.1.307) Notes

New Features

Powered by IntelliCAD 7.2d
MicroSurvey CAD 2014 SP2 is built on the latest IntelliCAD engine, IntelliCAD 7.2d. It includes performance enhancements and improvements to the user interface, printing, text, dimensions, entity snapping and tracking, and more. See below for more details.

Important Fixes

  • [D6580] Active Coordinate Editor - Sorting the points by Point ID does not sort the points numerically.
  • [D3944] Active Coordinate Editor - Auto-Adding Points to Point Nodes did not update the coordinate editor to show the new points.
  • [D6399] Areas - For some geometry, the Fast Area command may either fail without calculating the Area or cause the program to crash.
  • [D6601] ASCII Export - Writing out a Lat/Long Column Specific file writes the latitude and longitude values into the opposite column.
  • [D6751] ASCII Export - Writing out a Lat/Long file exports all points with 0 elevation.
  • [D6785] ASCII Export - Points with very large point IDs are exported multiple times.
  • [D6748] ASCII Import - Reading a Lat/Long file ignores all point elevations.
  • [D6784] COGO - Inversing points with very large point IDs does not draw the corresponding line.
  • [D6632] Coordinate Systems - When switching drawings from one with a coordinate system to one without a coordinate system, the coordinate system can be set to that of the previous drawing.
  • [D6733] Coordinate Systems - The "Clear" button on the General Configuration Options dialog did not work.
  • [D6753] Coordinate Systems - Creating a user defined coordinate system can cause an error message "Invalid ellipsoid name specification detected".
  • [D6810] Coordinate Transformations - Transform Database command converts all coordinates to meters.
  • [D6792] Delete Project Database - Attempting to delete the current project's database file produced a warning message that was partially cut off.
  • [D5494] Dimensions - Erasing a dimension that was drawn by snapping to a survey line may cause the line to be removed from the database.
  • [D6761] Drawing Recovery Wizard - Empty .msj database folders are no longer offered as a recovery option.
  • [D6770] Drawing Recovery Wizard - 0-byte .msz database files are no longer offered as a recovery option.
  • [D5882] Edit Point - The point node and labels were not highlighted while editing a point.
  • [D5959] Edit Point - The display did not immediately update after storing or editing a point.
  • [D6736] Global Mapper - When using an unsupported coordinate system, an error message now appears indicating the problem.
  • [D6744] Global Mapper - The imagery does not display in some situations.
  • [D6745] Global Mapper - The imagery is now automatically drawn at Back so it will not obscure the drawing.
  • [D6746] Global Mapper - Listing the imagery did not show any information.
  • [D6023] Independent Point Numbers - IPN labels need to be updated when resizing the drawing window.
  • [D6079] Lot Closure - Input Scale Factor was not applied to Arc Radius values.
  • [D6759] Point Blocks - Scanning for Point Blocks with Attributes can cause the mscad.dll to perform an illegal operation.
  • [D6638] Point Cloud Linework - Drawing a curvy polyline arc on a vertical reference plane can cause the program to crash.
  • [D6532] Project Manager - Creating a new drawing with a semicolon in the filename can cause the program to crash.
  • [D6263] Surface Modeling - A crash may occur when creating a new design surface in AutoRoute.
  • [D6545] Surface Modeling - A crash may occur when drawing contour labels.
  • [D2991] Undo - After copying database points, an Undo may remove the original points from the database.
  • [D5850] Undo - After copy/paste of database points, an Undo may delete the original points.

Important Fixes in IntelliCAD 7.2d

The following list details some of the new 300+ fixes that were implemented since the 7.2c release.

Working with drawing files
Improved file conversion process for 2013 .dwg file versions.
Fixed issue with SAVEAS command on Windows 7 x64 operating systems.
Several improvements to PDF export.
File security improved.
Performance improvements
Selection performance improved in large drawings, including those with many groups or hyperlinks.
Dragging performance improved, including extents drawn when using COPY and COPYCLIP.
Improved speed performance when printing 3D visual styles in viewports.
Printing
Issue fixed when printing gradients.
Fixed issues when printing and previewing drawings with rotated views.
Improvements to printing in color.
Fixed reported issues when printing MTEXT.
Selecting and viewing
Fixed display issues in read-only drawings.
Fixed reported display issues when zooming.
Fixed display issues that previously required REGEN.
Fixed REGEN issues.
Snapping and tracking
Entity snapping fixed when osmode = 0.
Fixes for snap accuracy.
Fixes for reported issues with Perpendicular Snap and Parallel Snap.
Text
Negative oblique angle fixed when using DDEDIT.
Fixed usage of current text style for multiline text.
Fixed Text Fit option.
Background color can now be turned off in the Multiline Text dialog box.
Properties
Image Scale value fixed.
Fixed text direction.
More fixes
Fixed localized versions that were not accepting some command options.
Fix for moving rotated dimensions.
Fixed issue when using Dim Continue on Dim Ordinate with a different UCS.
Fixed PLINE ARC drawn with negative angles in clockwise direction.
Added Bind option to Explorer > External References.
System variables fixed to be read-only: LOCALROOTPREFIX, MYDOCUMENTSPREFIX, and ROAMABLEROOTPREFIX.
Explode command fixed for 3D faces.
EXPLAYOUTS fixed for importing and exporting layouts to/from drawing templates.
Grid density improvements.
Fix for attribute selection order.
Fixes for extruding polylines and regions.
Fixes for stretching dimension text.
Hatch area calculations improved.
Fixed issue during layout viewing/switching when LAYOUTREGENCTL = 1.
New system variables
AUTOCONVERT, FASTIMAGEDRAW, FINDOPTIONS, NETFLOATLICENSE, PRINTIMAGEQUALITY, SPACEASENTER.
(4 vote(s))
Helpful
Not helpful

Comments (0)