Knowledgebase
MicroSurvey embeddedCAD 2014 Release Notes
Posted by Brian Sloman on 18 December 2013 10:22 AM

Release History

MicroSurvey embeddedCAD 2012 (v12.0.0) - May 27, 2011

MicroSurvey embeddedCAD 2012 SP1 (v12.1.0) - July 29, 2011

MicroSurvey embeddedCAD 2013 (v13.0.0) - September 28, 2012

MicroSurvey embeddedCAD 2013 SP1 (v13.0.1) - October 5, 2012

MicroSurvey embeddedCAD 2014 (v14.0.0) - March 7, 2014


Important Notes

Activating or Updating your USB License Key

If you are licensing MicroSurvey embeddedCAD for the first time, or if you are upgrading from MicroSurvey CAD or inCAD, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from a 2008 or newer MicroSurvey product, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from a previous version of MicroSurvey embeddedCAD 2013, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MicroSurvey embeddedCAD, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MicroSurvey embeddedCAD service pack updates. For a detailed explanation of MicroSurvey's Maintenance Subscription Support Plan (MSSP) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your Maintenance Subscription has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the MSSP by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date.

If your MSSP has expired, you can phone us at 1-800-668-3312 to renew it. Without a current maintenance subscription plan, you will not be able to update your key to work with the new version.

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users need to install the MicroSurvey Transfer program to simplify the process of transferring FieldGenius projects between your data collector and MicroSurvey embeddedCAD.

If you have a copy of MicroSurvey Transfer already installed from use with a previous version of MicroSurvey CAD/inCAD/embeddedCAD, you will need to update it to recognize MicroSurvey embeddedCAD 2014. Previous versions of MicroSurvey Transfer will NOT show MicroSurvey embeddedCAD 2014 as a sync option in the Options screen.

MicroSurvey Transfer can be downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

The MicroSurvey Network License Server program has not changed significantly since MicroSurvey CAD 2008. This is only necessary for users who are setting up a MicroSurvey CAD 2008 or newer network license for the first time.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey embeddedCAD 2014 is compatible with 32-bit and 64-bit versions of Microsoft Windows XP SP3(32bit)/SP2(64bit), Windows 7 SP1, and Windows 8.

Further AutoCAD system requirement details are available here: http://knowledge.autodesk.com/support/autocad/troubleshooting/caas/sfdcarticles/sfdcarticles/System-requirements-for-AutoCAD.html.

Windows 7 & Windows 8 Notes

Run as Administrator

If installing on Windows 7 or 8 you must run the program at least once elevated with "Run as admininstrator" access, even if you are already logged in with an "Administrator" account on the computer.

After this is done, it can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on one of the MicroSurvey embeddedCAD 2014 icons.
  2. Select "Run as administrator"
  3. Select "Yes" on the "User Account Control" dialog when prompted to allow the program to make changes to your computer.

What's This? Help

If you wish to use the "What's This? Help" feature under Windows 7 or 8, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


Online Resources

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MicroSurvey embeddedCAD 2014 Frequently Asked Questions topic in our online helpdesk.

Upgrade Notes

For information on upgrading from a previous version, please visit the MicroSurvey embeddedCAD 2014 Upgrade Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MicroSurvey embeddedCAD 2014 Known Issues topic in our online helpdesk.

Training Movies

For over 16 hours of training movies that you can watch online or download for offline viewing, please visit the Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at http://helpdesk.microsurvey.com/ where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are now answered in your Help file and Manuals.

For technical support, please visit our helpdesk at http://helpdesk.microsurvey.com/ to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Maintenance Subscription Support Plan (MSSP).

To purchase or renew your MSSP, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000 or visit our online store at store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to vote on other users' feature requests, please visit our Feedback Forum at feedback.microsurvey.com.

User Forum

To discuss your MicroSurvey product with other users, please visit our User Forum at http://www.microsurvey.com/forum/forum.htm.


MicroSurvey embeddedCAD 2014 (v14.0.0) Notes

New Features

Latest Autodesk® engine - AutoCAD® OEM 2014
MicroSurvey embeddedCAD is powered by Autodesk Technology™.
Autodesk AutoCAD OEM 2014 engine provides maximum compatibility with AutoCAD software and DWG™ files.
Includes Autodesk AutoCAD OEM 2014 Service Pack 1.
2D Draw Mode
A new "2D Draw Mode" System Toggle (in MsTools > MicroSurvey System Toggles, CAD Drawing Controls tab) is now available which causes all points to be drawn at z=0 while maintaining their true elevation in the coordinate database.
Switching this toggle On/Off will update existing points in the drawing as appropriate, causing them to be redrawn at the appropriate elevation.
The OSNAPZ system variable is also automatically turned On/Off with this mode so that new CAD entities will be drawn in 2D when snapping to 3D entities.
Database auditing tools will recognize when this option is enabled and will not attempt to fix the vertical descrepencies between the drawing and database.
Select MsTools > MicroSurvey System Toggles from the menus, or type CNF_EDIT_TOGGLES at the command line.
Settings Migration Wizard
Easily backup and restore all program settings into a single file, for transferring to another workstation or for disaster recovery.
Backup and restore AutoCAD settings including your entire AutoCAD profile and fonts folder.
Backup and restore MicroSurvey settings including your configuration options, description translation file, AutoMap library files, AutoMap blocks, title blocks, house library, coordinate systems, surface modeling configuration files, and symbol library.
Select MsTools > Migration Wizard from the menus, or type MIGRATION_WIZARD at the command line.
Drawing Recovery Wizard
When opening a drawing where the expected .msz database file is not opened, the program will alert you and provide several options.
A common scenario is if the program crashes, when you reopen the drawing it would always open with the orphaned .msj database folder which may be out of sync with the drawing (the .dwg and .msz files contain everything as of the last save, but the .msj database folder contains everything as of the crash).
Select a recovery option to reopen the last saved .dwg drawing and .msz database files, the last saved .dwg drawing file with the orphaned .msj database folder (as before), the backup .bak drawing and .mbz database files, the autosave .sv$ drawing and .mz$ database files, and more.
Archive all drawing and database files in their current state, so you don't have to worry about making the wrong choice and losing any data.
There is no command to run; the Recovery Wizard will appear automatically if the program detects that an unexpected database file (not the .msz file) is being opened.
Store & Edit Geodetic Position
Store & Edit the geodetic position of grid points using a new dialog with the same look-and-feel as the standard Store & Edit Points command.
Edit the Latitude, Longitude, Elevation, Description, Note, etc for each point.
View the Northing and Easting for each point (read-only).
View the Combined Scale Factor for each point (read-only).
View the Convergence Angle for each point (read-only).
Use the new "Use Single Point Editor: Geodetic" System Toggle (in MsTools > MicroSurvey System Toggles) to use this dialog by default when clicking on a point in the drawing to edit it.
Select MsPoints > Store & Edit Geodetic Position in the menus, or type EDITPG at the command line.
Identify Geodetic Position
Identify the geodetic position (including the Latitude, Longitude, Combined Scale Factor, and Convergence Angle) of grid points by clicking in your drawing.
Select MsPoints > ID Lat/Long of Point in the menus, or type IDG at the command line.
Label Geodetic Position
Label the geodetic position (including the Latitude, Longitude, Combined Scale Factor, and Convergence Angle) of grid points in your drawing, with customizable format and precision options.
Select MsAnnotate > Add Lat/Long Label for a Point in the menus, or type LABLPNTG at the command line.
Coordinate System Search
Search for appropriate coordinate systems, based on a specified latitude/longitude position.
Select your appropriate system from the search results, and instantly set it as your drawing's Coordinate System.
Select MsPoints > Geodetic > Coordinate System Search, or type CSSEARCH at the command line.
Vertical Transformations
All commands that previously allowed a horizontal coordinate system transformation now also support vertical transformations.
To transform individual coordinates, select MsPoints > Geodetic > Manual Coordinate Conversion from the menus, or type LL_TRANSFORM_COORDINATES at the command line.
To transform your coordinate database, select MsPoints > Geodetic > Transform Database from the menus, or type TRANSFORM_COORDINATES at the command line.
To transform coordinates during ASCII Import, select MsPoints > Import ASCII or Lat/Long File from the menus, or type ASCII_IN at the command line.
To transform coordinates during ASCII Export, select MsPoints > Export ASCII or Lat/Long File from the menus, or type ASCII_OUT at the command line.
Rescale Drawing Wizard
Easily rescale drawings from one base unit to another.
It is typical for architectural drawings to be in either inches or millimeters, and these drawings need to be rescaled to feet or meters.
Select MsTools > Rescale Drawing Wizard from the menus, or type DWG_RESCALE at the command line.
Scale Text Values
Scale text entity values (standard text, distance labels, or elevation labels) for conversion between different units or with a specified scale factor.
Format the result using only the new value, both the old and new values, or stack the old and new values as separate text entities, using fully customizable prefix/suffix and seperator options.
Select MsAnnotate > Modify Text > Scale Text Values or type SCALEVAL at the command line.
Lot Table
Draw a table detailing the lines, arcs and points that define a lot, along with its area and perimeter.
Select MsAnnotate > Add Tables > Add Lot Table from the menus, or type LOT_TABLE at the command line.
Align Between Drawings
A new Align Between Drawings command is now available for copying and aligning entities between two open drawings.
Select Modify > Align Between Drawings from the menus, or type MSALIGN at the command line.
Leica iCON Export
A new Export Leica iCON command is available to export points and linework for use in a Leica iCON project.
Select MsTraverse > Write Collector Files Out > Leica iCON from the menus, or type EXPORT_ICON at the command line.
Leica Nova MS50 MultiStation Support (Leica DBX Import)
MicroSurvey embeddedCAD now supports importing Leica DBX projects surveyed with the new Leica Nova MS50 MultiStation, including its images.
To import a Leica DBX database: select MsTraverse > Read Collector Files In > Leica DBX > Read DBX Database from the menus, or type DBXIN at the command line.
To manage all imported databases: select MsTraverse > Read Collector Files In > Leica DBX > Manage Imported Databases from the menus, or type DBXMANAGE at the command line.
To view images taken from a specific station: press the Image buttons in the Active Coordinate Editor or the Single Point Editor.
To view all imported images: select MsTraverse > Read Collector Files In > Leica DBX > View Imported Images from the menus, or type DBXIMAGES at the command line.
Leica Nova MS50 MultiStation Support (FieldGenius SyncWizard Import)
MicroSurvey embeddedCAD now supports importing MicroSurvey FieldGenius projects surveyed with the new Leica Nova MS50 MultiStation, including its images.
To import a FieldGenius project: select MsTraverse > FieldGenius SyncWizard from the menus, or type SYNCWIZARD at the command line.
To manage all imported databases: select MsTraverse > Read Collector Files In > Leica DBX > Manage Imported Databases from the menus, or type DBXMANAGE at the command line.
To view images taken from a specific station: press the Image buttons in the Active Coordinate Editor or the Single Point Editor.
To view all imported images: select MsTraverse > Read Collector Files In > Leica DBX > View Imported Images from the menus, or type DBXIMAGES at the command line.
Pentax Import
Import Pentax DC1 Polar, Pentax DC1 Rectangular, Pentax CSV, or Pentax AUX format data files from a Pentax total station.
The Pentax DC1 Polar format contains raw measurement data.
The Pentax DC1 Rectangular format contain point coordinates only.
The Pentax CSV format contain point coordinates only.
The Pentax AUX format contains raw measurement data.
Select MsTraverse > Read Collector Files In > Pentax DC1/CSV from the menus, or type PENTAX at the command line.

Improved Features

Job Defaults dialog
The General Configuration Options dialog that appears when opening a new or existing drawing has been improved with options to select the drawing's AutoMAP Library file, Feature List File (for GIS data), and Coordinate System.
The obsolete MicroSurvey 10/11/12 database field has been removed from this dialog and moved to a new command (MsPoints > Other Program Ties > MicroSurvey 10/11/12 > Set MS10/11/12 Database).
Select MsTools > MicroSurvey Job Defaults from the menus, or type CNF_EDIT_GENERAL at the command line.
AutoSave with Survey Database
AutoCAD's AutoSave feature now also saves a copy of the current MicroSurvey database.
The AutoSave folder is your system Temp folder by default, and can be defined in the OPTIONS command.
The AutoSave drawing file extension is .SV$ by default and can be customized in the OPTIONS command.
The AutoSave database file extension is .MZ$ and cannot be customized.
To recover an AutoSave drawing, you must rename the .SV$ and .MZ$ file extensions to .DWG and .MSZ respectively.
Select Tools > Options from the menus, or type OPTIONS at the command line.
Auto-Add Points to Objects: Blocks and Text Support
The Auto-Add Points to Objects command now supports Blocks, and will store a point at the Insertion Point of any selected Block entities.
The Auto-Add Points to Objects command now supports Text, and will store a point at the Insertion Point of any selected Text entities.
Select MsPoints > Auto-Add Points to Objects from the menus, or type AUTOP at the command line.
Auto-Add Points to Objects: Graphical Interface
Set the starting point ID and description to use for storing the new points.
Set the point description based on the selected entity's layer name or block name.
Set the selection filter to use only the desired entity types, from: Points, Lines, Arcs, Circles, Polylines, Blocks, and Text.
If any of the layers being drawn to are turned off or frozen, you will be prompted to turn them on and thaw them.
Select MsPoints > Auto-Add Points from Objects from the menus, or type AUTOP at the command line.
Active Coordinate Editor: Select Points by Description
You can now select points by description in the Active Coordinate Editor.
Includes options for case-sensitivity and matching the entire description.
Go to Select > Select By Description, within the Active Coordinate Editor window.
Active Coordinate Editor: Coordinate Systems
You can now view columns showing the Combined Scale Factor for each coordinate.
You can now view columns showing the Convergence Angle for each coordinate.
You can now view columns showing the Elevation for each transformed coordinate.
The Coordinate Systems dialog has been reworked to make it more intuitive and easier to use.
Go to Tools > Coordinate Systems, within the Active Coordinate Editor window.
Coordinate Grid Lines: Named Grid Lines
When coordinating grid lines, assign names to each grid line like A,B,C,D,... and 1,2,3,4,... and automatically set the ID or Description of the resulting grid points using the grid line names like A-1,A-2,B-1,B-2,...
Select MsTools > Coordinate Grid Lines from the menus, or type COORDINATE_GRID_LINES at the command line.
Labeling Defaults: Width Factors
Define text widths for all of the text styles in the MicroSurvey Labeling Defaults.
Select MsAnnotate > Labeling Defaults from the menus, or type CNF_EDIT_BEARINGS at the command line.
FieldGenius SyncWizard: Default Folder
The default FieldGenius SyncWizard Import/Export folders have been moved to make them more easily accessible.
Old location, Windows XP and earlier: C:\Documents and Settings\All Users\Application Data\MicroSurvey\embeddedCAD\2013\SyncWizard\Downloads, Uploads
Old location, Windows Vista and newer: C:\ProgramData\MicroSurvey\embeddedCAD\2013\SyncWizard\Downloads (or Uploads)
New location: My Documents\MicroSurvey\SyncWizard\Uploads, Downloads
Note, the SyncWizard Import/Export commands will default to the new location only if the old location is empty. If any projects are found in the old location, it will still be used as the default until you remove them.
You will need to install MicroSurvey Transfer v12.7.9.0 or newer for it to automatically use the new default folders.
Updated Coordinate System Engine
The CS-Map coordinate system engine was updated to provide 100% cross-compatibility between MicroSurvey embeddedCAD and MicroSurvey FieldGenius.
Hundreds of new coordinate systems and geoids (previously available only for MicroSurvey FieldGenius) are available for download in the MicroSurvey Helpdesk.

Important Fixes

  • [D6195] 3D Offset - Negative vertical offset (down) values could not be specified.
  • [D6409] 3-Point Inverse - Results of the MS_SHOW_ANGLE command are now displayed to the command line, in addition to the existing popup message.
  • [D5540] Active Coordinate Editor - A crash may occur when Rotating, Scaling, or Shifting a large number of points.
  • [D5564] Active Coordinate Editor – Remove Selection from DTM can cause a crash if all points are removed from the surface.
  • [D6337] Active Coordinate Editor - Switching drawings in the CAD window may not reliably switch the Coordinate Editor view to match the current drawing.
  • [D5598] Alphanumeric Points - Dashes in alphanumeric point IDs can cause the program to stop responding when iterating through the database in some situations.
  • [D4206] Alphanumeric Points - Incrementing alphanumeric point IDs had some inconsistent behaviour. For example, the Next point after "a" may be either "a0" or "a1" depending on the command.
  • [D6743] Arc on Two Tangents - After specifying the radius, the program may generate a Codebase Error and a Fatal Application Exit.
  • [D0000] Areas - FASTAREA (Area by Selecting Objects) command could calculate incorrect area if the boundary contains arc segments.
  • [D5910] Areas - FASTAREA (Area by Selecting Objects) command could become unstable and crash if a Spline is selected as a bounding entity.
  • [D5638] ASCII Export - a crash can occur when exiting the Export ASCII command by pressing <Enter> instead of <Esc> at the Enter Point or Range prompt.
  • [D6364] ASCII Export - Export Lat/Long File dialog was mislabelled as "Import File".
  • [D6529] ASCII Import – importing a space-delimited file with a blank line at the end of the file will zero the last read point.
  • [D5649] Assistant - MicroSurvey Assistant dialog can disappear behind the main window.
  • [D5812] AutoMap Library - A crash can occur when processing large projects (ie, more than 4000 points).
  • [D5935] AutoMap Library - Switching drawings did not force the AutoMAP library to switch.
  • [D6121] AutoMap Library - An AutoMap Library located outside of the default folder could not be automatically opened, so the mscad.csv library would load instead.
  • [D6390] AutoMap Library - Switching drawings in the CAD window could cause the program to stop responding if the drawing's AutoMap Library references a block that cannot be found.
  • [D5976] AutoMap Library - Insertion of blocks with unexpected INSUNITS and INSBASE variables could cause the symbols to be drawn at an inappropriate position.
  • [D5660] Batch COGO - When processing a Batch COGO file, the program can stop responding at the "Pick the side you want the bearing placed/Above/Below" prompt.
  • [D6054] Check For Updates - The online updater command did not check to confirm that your USB license key has already been activated for the update available for download.
  • [D2959] Clusters – the Report, Groups, and Both option was being ignored and always used Both.
  • [D2303] Coordinate Database – storing point IDs with leading zeroes (like "001") caused various problems.
  • [D4148] Coordinate Database – converting legacy .msd databases with improper data could cause the program to stop responding.
  • [D4721] Coordinate Database – converting legacy .msd databases with improper data could cause the program to stop responding.
  • [D4299] Coordinate Systems - "Other North American Systems" coordinate system group displays garbled characters.
  • [D6217] Coordinate Transformations - in the case of invalid input data, an illegible error message was displayed.
  • [D6303] Drawing Cleanup Wizard - The "Bind External References (Xrefs) as Blocks" option did not work because of the new Xref Manager dialog.
  • [D5646] Draworder Wizard - An automatic Regen was added to cleanup display artifacts from wipeouts.
  • [D2238] Entity Properties – changing the layer of a line/arc will remove it from the database.
  • [D6119] Entity Properties – changing non-geometric properties of a line/arc will remove it from the database.
  • [D2251] Entity Snaps - Running entity snaps are no longer turned off during the Fence Line, Tree Line, Text Line, Parking Stall Layout, Auto Site Design, and Water Mains commands.
  • [D5984] Erase Layer - points and/or figures that are erased were not automatically removed from the database.
  • [T1615] Error Log - Problems that occur during use of the program are now logged to a file which can be used by MicroSurvey staff to debug problems.
  • [D6274] Existing Point Traverse - The unadjusted traverse length and closure error were not displayed to the command history until after the traverse is adjusted.
  • [D5618] FieldGenius Export - The FG_MAKE_PROJ command can produce an "Error PA2T4S" while building the DXF file if it includes any curve-fitted polylines, spline-fitted polylines, splines, or hatches.
  • [F1954] FieldGenius Export – Added a "Use R12 DXF Format" option to control whether DXF is written as R12 format.
  • [D5956] FieldGenius Export – Exporting a FieldGenius XG2 project can cause a crash if overwriting a project that is currently open or in use.
  • [D2352] FieldGenius Export – After exporting a FieldGenius 2004+ project you cannot open the generated .DXF file until the program is restarted.
  • [D6011] FieldGenius Export - When exporting a FieldGenius XG2 project, the "Include Text" option is now hidden because it is not applicable.
  • [D6000] FieldGenius Export - Blocks containing non-constant attribute definitions would cause an error message "Error PA2-W5S, Unable to create entity (INSERT) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6351] FieldGenius Export - Proxy Entities would cause an error message "Error PA2-W5S, Unable to create entity (ACAD_PROXY_ENTITY) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6352] FieldGenius Export - Arc Dimensions would cause an error message "Error PA2-W5S, Unable to create entity (ARC_DIMENSION) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6357] FieldGenius Export - Multi-Leaders would cause an error message "Error PA2-W5S, Unable to create entity (MLEADER) in block (DO_NOT_USE_FG_EXPORT)".
  • [D5596] FieldGenius Import - The SYNCWIZARD command did not detect if the FieldGenius project units did not match the drawing units, this has been fixed and you are again prompted to change the drawing settings when they do not match.
  • [D5746] FieldGenius Import - The SYNCWIZARD command may not interpret the version number correctly from comment records like "--FieldGenius v 6.0.0.4 (2012-03-29)"
  • [D6203] FieldGenius Import - The SyncWizard Import command did start in the correct default folder.
  • [D6367] FieldGenius Import - Lines and Arcs in the FieldGenius project were not automatically added into the figures database and associated with the appropriate points.
  • [D6362] FieldGenius Import - The "Archive project upon import" option did not default on/off as appropriate like in previous versions.
  • [D6323] FieldGenius Import - An "Error, attempting to create directory" message could occur on startup if the program was installed by a different user account.
  • [D4151] Graphic Coordinate Editor – Undo could cause the program to crash.
  • [D4986] Graphic Coordinate Editor – entities could not be removed from groups.
  • [D6120] Graphic Coordinate Editor – adding a large group of points could cause the program to crash.
  • [D4974] Graphic Coordinate Editor - Point groups could not be created in inCAD or embeddedCAD, making the entire command unusable.
  • [D5915] Helmerts Transformation - transformation parameters (.HE2 files) were incompatible between 32-bit and 64-bit versions.
  • [D3934] Help - Help button in the Active Coordinate Editor's Coordinate Systems dialog did not work.
  • [D5629] Hot Toggles - Closing a drawing did not immediately update Hot Toggles with the settings in the new current drawing.
  • [D5842] Independent Point Numbers - IPN labels are displayed in the wrong position after a zoom extents.
  • [D5909] Independent Point Numbers - IPN labels are displayed in the wrong position when in a UCS. As a temporary partial fix, IPNs are now disabled when in a UCS until this can be fixed.
  • [D5991] Independent Point Numbers - IPN labels are not immediately updated when opening/switching a drawing.
  • [D5992] Independent Point Numbers - IPN labels are not immediately updated when storing new points in a drawing.
  • [D4167] Independent Point Numbers - Closing a drawing did not immediately update IPNs with the points in the new current drawing.
  • [D2673] Independent Point Numbers – IPN colors cannot be set to Black on a White background.
  • [D5957] Independent Point Numbers – IPN colors did not display correctly on a White background.
  • [D3037] Labeling Defaults - Truetype fonts located in your system Fonts folder (for example, Arial.ttf) could not be specified in the Labeling Defaults dialog.
  • [D5666] Labeling Defaults - Truetype fonts located in your system Fonts folder (for example, Arial.ttf) could cause "Font not found" error messages when drawing text.
  • [D6060] LandXML Export - A linearUnit="USSurveyFoot" setting was never written, only linearUnit="foot" or linearUnit="meter".
  • [D4313] LandXML Export - The required pressureUnit, temperatureUnit, volumeUnit, and areaUnit attributes were missing, which could cause a failure to import into some third-party applications.
  • [D5594] LandXML Import - After import, the drawing is now automatically zoomed to its extents to ensure that the imported elements are visible.
  • [D6061] LandXML Import - A linearUnit="foot" or linearUnit="USSurveyFoot" setting was not differentiated when compared against the drawing's unit setting.
  • [D6050] LandXML Import - A linearUnit setting that does not match the drawing's unit setting causes a somewhat ambiguous warning message about the unit mismatch, this has been clarified.
  • [D6049] LandXML Import - Surface models cause a somewhat confusing prompt to draw the TIN as either 3dfaces or as a polyface mesh, this has been clarified.
  • [D4358] LandXML Import - Surface models were not loaded directly into the QuickSurf surface modelling engine.
  • [D5622] Layer States - The LAYERSTATE command did not work, this has been fixed.
  • [D6210] Legal Description Writer - An "Unhandled Exception Error" may occur after responding to the "Clockwise (CW) or counter Clockwise (CCW)" prompt.
  • [D5624] Leica DBX Import - An incorrect HI value can be reported in cases where a spur point is set off of a traverse point from the main traverse line, then topo measurements are taken from that spur point, and another spur point is set for taking additional topo measurements.
  • [D6066] Leica DBX Import - If multiple DBX databases are imported into a drawing, only images referenced in last imported database were accessible. All images imported from multiple Leica DBX databases and MicroSurvey FieldGenius projects are now accessible.
  • [D6157] Leica DBX Import - Figures are now imported as 3D by default instead of 2D.
  • [D6168] Leica DBX Import - A new option was added to process linework using either the figure code (as previous) or the point code from the first point on the figure.
  • [D6201] Leica DBX Import - When importing a DBX database from a network location using the UNC path instead of a mapped drive letter may cause an error message "No service capable of opening the requested data set could be found."
  • [D6387] Leica DBX Import - Setup records not used for any point measurements were not imported into the traverse database.
  • [D6302] Leica DBX Import - Resection records were imported with the Instrument Height from the previous setup.
  • [D6041] Licensing - Network License was not immediately released on exiting from the program, until timing out 180 seconds later.
  • [D6116] Lineweight Units - The LWUNITS system variable is now automatically set to Inches or Millimeters as appropriate depending on whether the drawing is set to Feet or Meters.
  • [D6341] Lineweight Units - A new System Toggle has been added so that the automatic setting of the LWUNITS system variable can be enabled or disabled.
  • [D5603] Linework - When erasing entities in a drawing that have unexpected EED, a crash could occur.
  • [D5625] Linework - The PASTEORIG (Paste to Original Coordinates) command did not remove EED from the entities being copied, so further edits could inappropriately update the database.
  • [D5718] Linework - Trimming a survey line removes the line from the database and erases its Bearing/Distance labels.
  • [D5766] Linework - Deleting a layer via EXPLAYERS (Layers Explorer) that has points on it does not delete the points from the database.
  • [D5494] Linework - Erasing a DIM can cause lines to be removed from the database.
  • [D5997] Linework - Editing the length of a survey line via LEN command did not remove the line from the database.
  • [D5998] Linework - Moving a line by dragging it did not remove the line from the database.
  • [D6007] Linework - Moving a survey arc can cause the arc to be erased from the drawing if the "Draw lines/arcs" hot toggle is off.
  • [D5826] Linework - Upconversion of drawing files from MSCAD 2002-2005 could cause the MicroSurvey editor reactor to stop, causing linework and points to not update when edited.
  • [D4765] Log File - Writing to the .rtf log file can cause a crash and persistent "Error opening log file?" messages.
  • [D5406] Lot Closure - Tab order in the Lot Closure dialog was not logical.
  • [D5911] Lot Closure - Lot Closures (.LC files) were incompatible between 32-bit and 64-bit versions.
  • [D4907] New Drawing - The General Configuration Options dialog would appear twice when creating a new drawing with a .dwt template file via the Project Manager.
  • [D5690] Pad Builder - The BUILD_PAD command can produce odd warning messages about having an invalid number of decimal places while you are inputting an angle.
  • [D5701] Pad Builder - The BUILD_PAD command can produce a crash if the "Reset start point and direction" button is pressed.
  • [D6706] Pad Builder - The BUILD_PAD command was not functional in inCAD or embeddedCAD.
  • [D6667] Point Groups - Point Groups (.GRP files) were incompatible between 32-bit and 64-bit versions.
  • [D2294] Printing – when printing a Clusters report or Cut Sheet report, only the first page was printed.
  • [D2737] Printing – when printing from an Active Drawing Technology window, the Print Selection option was always disabled.
  • [D2279] Printing – when doing a Print Preview from an Active Drawing Technology window, the Previous Page and Zoom Out buttons do not work.
  • [D3223] Printing – when doing a Print Preview from an Active Drawing Technology window, clicking the middle-mouse button enters auto-scroll mode which cannot be exited.
  • [D5948] Repeat Last Command - Various messages sent by the program to the commandline (including LBD, UPDATEACE, etc) would interfere with the ability to repeat the last command.
  • [D5657] Roading - When editing the Vertical Curve Length in a Vertical Alignment, the curve is redrawn properly but its extended entity data is not updated, so the previous Curve Length value may continue to be used.
  • [D5814] Rotate Text - the MS_ROTEXT command (Rotate Text 180 degrees) would cause the ANGBASE and ANGDIR variables to change.
  • [D2048] Save - SAVEAS did not immediately create the new filename’s .msj database folder until a database-accessing command would run.
  • [D5929] Save - SAVEAS to a new filename also saves the original filename’s .msz database file, which may cause the drawing and database to get out of sync.
  • [D3425] Save - SAVE to a new filename also saves the original filename’s .msz database file, which may cause the drawing and database to get out of sync.
  • [D5980] Save - SAVEALL saves all open drawings with the current drawing’s .msz database file. As a preventative measure we have temporarily removed the SAVEALL command until this can be fixed.
  • [D6018] Save - SAVEAS to the same filename of another currently open file could cause an error message and crash.
  • [D6052] Save - SAVEAS to the same filename with a different extension could cause an error message and crash.
  • [D6436] Save - SAVEAS overwriting an existing drawing would not overwrite the existing database file.
  • [D5871] Save - SAVEAS to 2010 format could cause smart arcs to double up.
  • [D5983] Save - The drawing and database can get out of sync by using the SAVE command.
  • [D5694] Scale Factors - Scaling an input distance at the command line with the "s" suffix (like 100s) may result in a "Not a valid distance" error message.
  • [D5960] Scale Factors - Scaling an input distance at the command line with feet/inches entry (like 10'6") does not work, result is in inches instead of feet.
  • [D5863] Scale Factors - Existing Point Traverse (Old) command can write garbled "Direction of error" result if an Output Scale Factor is used.
  • [D5901] Scale Viewport - The SCALE_VPORT (Scale Layout Viewport) command did not work with non-rectangular viewports. It now also supports polygonal, circular, elliptical, and splined viewports.
  • [D5606] Snapping - Enabling Polar Snapping or Entity Snap Tracking modes may not work reliably because the AUTOSNAP system variable would not accept any value greater than 39.
  • [D6488] Stake Out Report - Pressing Enter to repeat the Stake Out Points command would cause the program to crash.
  • [D5653] Surface Modeling - The SVOL (Surface Volume) command's Volumes and Average Values report may generate incorrect Plan Area and Average Thickness values.
  • [D5722] Surface Modeling - The CELEV (Change Elevation) command can produce an error message "Select is not an available tear-off menu name" immediately upon starting the command.
  • [D5740] Surface Modeling - The SPLAN (Surface Plan View) command generates an error "Unable to recognize command ._PLANVIEW"
  • [D6129] Surface Modeling - In the Surface Color Options dialog, selecting Surface Color Method = None does not work.
  • [D6123] Surface Modeling - In the Surface Color Options dialog, when "Drawing Legend" is enabled it may not drawn onto the same layer as the surface.
  • [D3586] Surface Modeling - Contour interval color options may not always work as expected.
  • [D6420] Surface Modeling - Drawing cross-sections can produce a message "WARNINg_ Could not get osmode".
  • [D6612] Surface Modeling - Extracting breaklines from a large selection set may cause a crash.
  • [D6039] System Toggles - New options added into the program that are not present in your saved config file may not default to the intended value.
  • [D5792] TDS RAW/RW5 Import - The last data line in the file may be skipped if the file does not end with a blank line.
  • [D2001] Transfer Points between Jobs – repeating a point range gives an illegible error message.
  • [D6686] Transfer Points between Jobs - When browsing for the .msz file the default starting folder is not appropriate.
  • [D5595] Undo - Undo did not work well under Windows XP because it would undo each command in several steps instead of undoing the entire command in one step.
  • [D5977] Undo – focus can jump to another program after the "MicroSurvey database update report" dialog appears.
  • [D4929] Undo/Redo - Redo was not reliable, it would generate a message that it must immediately follow an UNDO.
  • [D5916] Undo - Undoing the "notification_new_or_open" command that occurs during the startup sequence can result in a crash.
(1 vote(s))
Helpful
Not helpful

Comments (0)