Knowledgebase
MicroSurvey CAD 2005 SP1 Release Notes
Posted by Jason Poitras on 01 December 2006 09:09 AM

Using the PEDIT command can cause some of your polylines to disappear when you finish the command.   The work around for now is to make sure you have the PLINETYPE variable set to zero before using the PEDIT command.

Print Dialog: A crash can occur when pressing the Cancel button on the print dialog. This has been reported but is not easily reproducible.   If you experience this problem, several users have reported that if they press the Apply button after making changes in the dialog, that the crash goes away.   We are working hard to try and isolate the problem.

Hatching:   If you create hatches with the retain boundary option turned on, you need to be aware of one bug.   If you erase the hatch by running the erase or delete command and picking on it if you do then the boundary is erased as well. There are two work arounds to this problem:

  • Pick the hatch pattern with the mouse with no command running, then right click and pick delete from the menu. The hatch is erased but the boundary remains.  
  • Pick on the hatch and then hit the delete key on your keyboard and the hatch will be erased but the boundary will remain.

Cad Specific Fixes / Updates

The IntelliCAD Explorer now works correctly when deleting  dimension styles or text styles.

Grip selected entities can now be unselected by using the shift key (shift-pick, shift-window, shift-crossing).

Fixed problem with relative coordinates not working when snaps are enabled.

Corrected problems that could cause drawing layouts to disappear if the drawing originated in AutoCAD.

Fixed problems with some blocks in Model Space vanishing when the drawing is saved.

Fixed crashing problem that could occur when layer colors were changed in IntelliCAD Explorer.

Crash importing multiple linetypes at the same time has been fixed.

Freezing viewports was hiding entire viewport and has now been fixed.

Several Complex Linetype issues are now resolved.

New formatting features are available when you enter text using Multiline Text. You can specify text color, first line indents, paragraph indents, right indents, and tabs.

FelixCAD Blocks inserted in the drawing could cause a crash when the drawing was saved. (This was our #1 reason for technical support calls)

Draw order was not being displayed correctly in Paper Space views.

Extended intersection snap now works properly.

IntelliCAD snaps are no longer stuck on a single location and they no longer require that the snap be reset.

The text height for multiline text is saved correctly now when exiting the MTEXT command dialog box.

The formatting for the MTEXT command (Bold, Italic, and Underline) now works correctly.

You can now use both begin and end curly braces with the MTEXT command.

MTEXT entities can now be used as a cutting edge with the TRIM command.

Hatch entities work better with the CHANGE and ENTPROP commands.

Enhanced performance when working with dense hatch patterns, including patterns that are too dense to display.

Dynamic dragging is approximately five times faster when dragging inserted blocks that contain hatch entities.

Block definitions are added to the block table when a block insert is cancelled.

XCLIP boundaries are no longer deleted when saving drawings.

Performing certain operations on selected WIPEOUT entities now works correctly.

Extrude works properly on entities created with the RETANGLE command.

SOLID entities now properly honor entity color when DXF files are imported into IntelliCAD.

The Load/Unload status (DXF group code 280) of image definitions is now saved properly.

IntelliCAD includes improved handling of the sortents table when it contains references to deleted entities.

Exploded blocks with a negative scale factor in one axis no longer rotate ellipse entities incorrectly.

Zoom Window gets stuck and will no longer zoom in.   You may have seen a message "reached limits of zooming".   This has been corrected.

In a rotated UCS : Window selection would not always select everything expected by the user.

The performance of command bar line scrolling has been greatly improved.

The command bar no longer randomly displays duplicate entries.

The command bar stores its size correctly if you vertically resize it.

Zoom Extents calculates the view correctly when entities are extended outside of the current view.

You can view changes made with DVIEW without an additional REGEN.

OLE objects remain visible even when links are broken.

Dynamic mouse wheel zoom centers the zoom properly on the cursor location when using multiple monitors.

All nested MINSERT entities now display properly.

VPLAYER freeze now works properly for entities in paper space.

Constant, invisible attributes now display properly when ATTDISP is ON.

IntelliCAD consistently displays lineweights in model space viewports.

Previously, if IntelliCAD could not properly display a single entity within a block, it would not display any of the remaining entities within the block definition. Remaining block entities now display when a single block entity cannot properly be displayed (for example, if a HATCH entity was too dense to display).

The ENTPROP command allows you to change the width of a polyline correctly.

Relative paths now work properly for entity hyperlinks.

The MATCHPROP command copies the polyline width if all segments of the source polyline are the same width.

User-defined print style tables are now saved in C:\Documents and Settings\user-name\My Documents\Print Styles per Microsoft® Windows® logo requirements.

The Print Style file name dialog box now disallows invalid file names.

Long file names are now visible in the Print Style Table Editor dialog box.

The options on the Printing tab found in Tools > Options are now unavailable when no drawings are open.

IntelliCAD now works properly when print style settings cannot be detected.

When moving hatches, any associated boundaries move with the hatch.

The ARRAY, ARRAY3D, MIRROR, and MIRROR3D commands now work with hatch entities.

Hatch scale is saved correctly.

Solid hatches utilize all spline knot boundaries correctly. This also fixed minor problems with the display of Kanji characters.

If a hatch entity has the same name as a hatch pattern in the ICAD.PAT file but contains a different definition; that entity hatch definition is no longer redefined on save.

New system variables include: AUDIOICON, AUDIOICONCOLOR, and AUDIOICONSCALE.

You can now snap to the middle points and end points of hatch pattern lines.

You can now snap to the nearest point and perpendicular point on a hatch pattern line.

You can now snap to any intersection point or apparent intersection point where the pattern line intersects with other entities that are supported by entity snaps.

IntelliCAD provides the unique ability to record audio notes, which are sound clips attached to entities and available for playback at any time. For example, audio notes in a factory floor plan can describe maintenance activities for specific areas of the factory and employees can play the audio notes to hear instructions.

The AREA command correctly reports the perimeter (not the circumference) of spline entities.

MicroSurvey Fixes | Updates

General Configuration using the set default toggle was not saving the setting for the direction. If it was set to azimuth it would always default to bearings when a new project was created.   This is now fixed.

Added Match Properties command to Modify pull down menu.

A grips on or off button was added to the IPN and MS Main toolbars.

Since it is very handy to use the copy command to copy objects between drawings, we created a "special" version called MSCOPY.   You will find it in the Modify menu and should find that it works exactly the same as the copy command.   However our version of the copy command does some extra work to make certain the database and drawings are kept synchronized properly.

Fixed the export toolbars function so a user can export their toolbars.   Previously, the same bitmap would be exported for each button custom MicroSurvey item.

Licensing fixes for network license files.   Decreased initial log on time by 50%.

Network license logon will now warn the user if the license file is currently locked by another user trying to logon at the same time.   The message will ask them to try again in a few of seconds.

SyncWizard / AutoMap changes - there is now a Show Options Dialog option that allows the user to specify what MSCAD 2005 should do if there is no AutoMap linework definition for a particular figure.   In other words, if one of the figures is named EP:1 and there is no EP description in the AutoMap library, MSCAD will now default to the settings specified in the Options dialog.

FieldGenius Processing - A great deal of work has gone into making sure figures imported from FieldGenius are processed exactly as they were drawn in the field. One thing that is new is that MSCAD 2005 now supports complex figures. A complex figure is one that has straight segments, arcs, or splines. These can all be in the same figure!

You can now import your FieldGenius linework directly from the figure database. The command is called proc_figure. This is very handy for if you've adjusted all your points and you want the linework to match. All you need to do is import the figure file and let MSCAD process it.

Active Traverse Editor Updated - added the FG/TDS option in the format menu.   By default when a FieldGenius or TDS raw file is read in, we copy some of the information into a generic format that we use for all traverse files.   The generic format will display instrument setups, sideshots and notes.   TDS and FieldGenius raw files contain a lot of extra information that is not displayed in the generic format, so we give you the option of displaying these records.   In the format menu you can open the Show FG/TDS Record Options Dialog.   This allows you to choose what you wish to display.   Refer to the online help for more detailed information.

Fixed a bug that would output face 2 horizontal angles as being 180° when the Starnet export routine was used.

Fixed a bug that would cause entities in the drawing to be unselectable.   This would occur if you had grips off, and tried to select a line while holding down the shift key.

Fixed the copy and mscopy command so they properly strip the extended entity data from the custom mspoints.   You will now see that if you copy mspoints to another drawing, you will see the familiar XX####XX added to the point numbers.

Fixed a crashing bug that could occur when multiple jobs are opened at the same time, and you tried to copy mspoints in the drawing from one drawing to another.

If you use the copy command to copy from one drawing to another, the general configuration settings were being changed and would end up copying the settings from the first drawing.   This is now fixed.

IntelliCAD allows the user to start a command in one drawing and finish it in another.   We strongly recommend that you do not do this because of problems that can occur by switching to a different drawing.   We added some tests into MSCAD, so if you use a command such as copy or move, you will see a warning message asking you not to do this.

Connect_Points - This wasnt working correctly when you typed a single point number at the command line.   If you pick points off the screen then it worked correctly.   This is now fixed.

ASCII In - the dialog asking for the file to import would not allow you to cancel.   Now fixed.

AutoRoute - Edit horizontal alignment. Adding a Spiral Curve Spiral to an alignment would sometimes do nothing but pop up a previous prompt again.   This has been corrected.

Added Model and Layout Tabs item to the View Menu.

Changed Transfer License to Permanently Transfer License in the Help Menu.

LSA - If there are notes at the beginning of the traverse file it might crash the program when a least squares adjustment was done.   This is now fixed.

  Updated Insym to use the insert block command when inserting symbols from the library.

GeoConverter Datum Editor (_call_geoconverter) was not looking for the correct directory.   This has been resolved and will now look in C:\program files\microsurvey\mscad2005\mscad\mapping\data

Importing a FG project, if the files were read-only then the program would crash. This has been updated so it will warn the user that the files are read only and will ask them if they want MSCAD to change the attributes so they can be imported.

SMI import of raw files, all sideshots are being flagged as TR shots in the Traverse Editor, and they should be SS.   This is now fixed.

Updated the traverse closure routine so it will warn the user if they measured an angles only observation to the backsight from their first setup in the raw file.

Removed from menus:   MsTools > Streets & Intersections > Open Streets Toolbox   and   MsTools > Subdivision/House Design > Open Subdivision Toolbox

Help button on the Build/Edit Cul-de-Sacs window was not working.

If you had the scale input toggle on and start entering in a traverse (using the Dialog box entry method), the HT and HI are also scaled by the input scale factor when they really should not be.   If you enter them in via the spreadsheet method or the command line method, then they are fine.   This is now fixed.

Copy/Paste was not working as expected in the Active Traverse Editor. It pasted everything in as a SS, and give several errors.   This has been corrected.

Least Squares clicking on Inst Defaults displayes a message about a missing inst.dir file from the common folder.   This file has been added to the main install files.

Voice Notes not being imported into MSCAD 2005, this is now fixed.

FieldGenius 2006 will allow the user to delete points and will have an associated record in the raw file call a DP Delete Point record.   MSCAD 2005 will recognize these types of records upon import and will warn the user.   Also in the traverse file, they will appear highlighted in red.

Fixed a bug that corrects a problem with inversing Pt..Pt..Pt with the Output scale toggle turned on, it now displays the scaled distances at the command line.   Updated it so a message is displayed in the results dialog or at the command line to notify the user that the output scale is being applied.

Fixed a bug to correct a problem that could occur during import of TDS raw files where the instrument heights for some of the setups in our traverse file could be set incorrectly.   This would only happen if the raw file contained multiple consecutive setup (OC) records in the raw file that had the same OC and BS points but have no shots in between.   This situation is rare.

 

(372 vote(s))
Helpful
Not helpful

Comments (0)