Knowledgebase
MicroSurvey Data Exchange 2014 Release Notes
Posted by Brian Sloman on 15 May 2014 03:41 PM

Release History

MicroSurvey Data Exchange 2012 (v12.0.0) - March 16, 2012

MicroSurvey Data Exchange 2014 (v14.0.0) - May 16, 2014


Important Notes

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users can use the installed MicroSurvey Transfer program to simplify the process of transferring FieldGenius projects between your data collector and your PC.

If you have a copy of MicroSurvey Transfer already installed from use with another MicroSurvey product, it may not recognize MSDX 2014. Previous versions of MicroSurvey Transfer may not show MicroSurvey Data Exchange 2014 as a sync option in the Options screen.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

System Requirements

MSDX 2014 is compatible with 32-bit and 64-bit versions of Microsoft Windows Vista SP2, Windows 7 SP1, and Windows 8. It does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows.

Windows XP Notes

Windows XP End of Support

Microsoft has announced that support for Windows XP will end on April 8, 2014. According to Microsoft, "After April 8, 2014, there will be no new security updates, non-security hotfixes, free or paid assisted support options or online technical content updates. Running Windows XP SP3 ... in your environment after their end of support dates may expose your company to potential risks" as detailed on their website here and here.

Until April 8, 2014, MicroSurvey Software Inc. will continue to develop, test, and support all of our products for Windows XP, providing that all third-party components still support Windows XP.

After April 8, 2014, MicroSurvey Software Inc. will no longer use the Windows XP operating system for any development, testing, or technical support. After this date, Windows XP will be completely unsupported. While our products may or may not continue to operate without issue beyond this date, using an unsupported operating system is not recommended and any issues that are specific to an unsupported operating system will not be addressed.

Windows Vista, Windows 7 & Windows 8 Notes

What's This? Help

If you wish to use the What's This? Help feature under Windows Vista/7/8, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


MicroSurvey Data Exchange 2012 (v12.0.0)

New Features

Initial product release
MicroSurvey Data Exchange 2012 is a free desktop application designed to perfectly complement your FieldGenius software. Quickly transform a drawing file into a FieldGenius project and upload it to your data collector, and download FieldGenius projects to your computer to review your field measurements and create an annotated drawing.
Powered by IntelliCAD 7.1a
MSDX 2012 is built on the latest IntelliCAD engine, IntelliCAD 7.1a.

MicroSurvey Data Exchange 2014 (v14.0.0)

New Features

Powered by IntelliCAD 7.2d
MSDX 2014 is built on the latest IntelliCAD engine, IntelliCAD 7.2d.
AutoCAD® 2013 .dwg/.dxf File Support
MSDX 2014 can now automatically convert and open AutoCAD 2013 .dwg/.dxf files, then Save them as R12-2010 .dwg/.dxf format.
Or, use the standalone IntelliConvert conversion utility to manually convert R12-2013 .dwg/.dxf files.
Rescale Drawing Wizard
Easily rescale drawings from one base unit to another.
It is typical for architectural drawings to be in either inches or millimeters, and these drawings need to be rescaled to feet or meters.
Select Points > Rescale Drawing Wizard from the menus, or type DWG_RESCALE at the command line.
Copy Between Drawings
A new Copy Between Drawings command is now available for copying entities between two open drawings.
Select Edit > Copy Between Drawings from the menus, or type MSCOPY at the command line.
Drawing Recovery Wizard
When opening a drawing where the expected .msz database file is not opened, the program will alert you and provide several options.
A common scenario is if the program crashes, when you reopen the drawing it would always open with the orphaned .msj database folder which may be out of sync with the drawing (the .dwg and .msz files contain everything as of the last save, but the .msj database folder contains everything as of the crash).
Select a recovery option to reopen the last saved .dwg drawing and .msz database files, the last saved .dwg drawing file with the orphaned .msj database folder (as before), the backup .bak drawing and .mbz database files, the autosave .sv$ drawing and .mz$ database files, and more.
Archive all drawing and database files in their current state, so you don't have to worry about making the wrong choice and losing any data.
There is no command to run; the Recovery Wizard will appear automatically if the program detects that an unexpected database file (not the .msz file) is being opened.
Coordinate System Search
Search for appropriate coordinate systems, based on a specified latitude/longitude position.
Select your appropriate system from the search results, and instantly set it as your drawing's Coordinate System.
Select Geodetic > Coordinate System Search, or type CSSEARCH at the command line.
Pentax Import
Import Pentax DC1 Polar, Pentax DC1 Rectangular, Pentax CSV, or Pentax AUX format data files from a Pentax total station.
The Pentax DC1 Polar format contains raw measurement data.
The Pentax DC1 Rectangular format contain point coordinates only.
The Pentax CSV format contain point coordinates only.
The Pentax AUX format contains raw measurement data.
Select Import/Export > Import Pentax DC1/CSV/AUX from the menus, or type PENTAX at the command line.

Improved Features

Auto-Add Points to Objects: Blocks & Text
The Auto-Add Points to Objects command now supports Blocks, and will store a point at the Insertion Point of any selected Block entities.
The Auto-Add Points to Objects command now supports Text, and will store a point at the Insertion Point of any selected Text entities.
Select Points > Draw Points > Add Points to CAD Objects from the menus, or type AUTOP at the command line.
Auto-Add Points to Objects: Graphical Interface
Set the starting point ID and description to use for storing the new points.
Set the point description based on the selected entity's layer name or block name.
Set the selection filter to use only the desired entity types, from: Points, Lines, Arcs, Circles, Polylines, Blocks, and Text.
If any of the layers being drawn to are turned off or frozen, you will be prompted to turn them on and thaw them.
Select Points > Draw Points > Add Points to CAD Objects from the menus, or type AUTOP at the command line.
Coordinate Grid Lines: Named Grid Lines
When coordinating grid lines, assign names to each grid line like A,B,C,D,... and 1,2,3,4,... and automatically set the ID or Description of the resulting grid points using the grid line names like A-1,A-2,B-1,B-2,...
Select Points > Draw Points > Add Points to CAD Intersections from the menus, or type COORDINATE_GRID_LINES at the command line.
Job Defaults dialog
The General Configuration Options dialog that appears when opening a new or existing drawing has been improved with options to select the drawing's AutoMAP Library file, Feature List File (for GIS data), and Coordinate System.
Select Settings > Units... from the menus, or type CNF_EDIT_GENERAL at the command line.
FieldGenius SyncWizard Default Folder
The default FieldGenius SyncWizard Import/Export folders have been moved to make them more easily accessible.
Old location, Windows XP and earlier: C:\Documents and Settings\All Users\Application Data\MicroSurvey\MSDX\2012\SyncWizard\Downloads, Uploads
Old location, Windows Vista and newer: C:\ProgramData\MicroSurvey\MSDX\2012\SyncWizard\Downloads, Uploads
New location: My Documents\MicroSurvey\SyncWizard\Downloads, Uploads
Labeling Defaults: Width Factors
Define text widths for all of the text styles in the MicroSurvey Labeling Defaults.
Select Settings > Labels... from the menus, or type CNF_EDIT_BEARINGS at the command line.
Points Database: Select Points by Description
You can now select points by description in the Active Coordinate Editor.
Includes options for case-sensitivity and matching the entire description.
Go to Select > Select By Description, within the Points Database window.
Points Database: Coordinate Systems
You can now view columns showing the Combined Scale Factor for each coordinate.
You can now view columns showing the Convergence Angle for each coordinate.
You can now view columns showing the Elevation for each transformed coordinate.
The Coordinate Systems dialog has been reworked to make it more intuitive and easier to use.
Go to Tools > Coordinate Systems, within the Points Database window.
Updated Coordinate System Engine
The CS-Map coordinate system engine was updated to provide 100% cross-compatibility between MicroSurvey Data Exchange and MicroSurvey FieldGenius.
Hundreds of new coordinate systems and geoids (previously available only for MicroSurvey FieldGenius) are available for download in the MicroSurvey Helpdesk.
Select a vertical system (ellipsoid or geoid) and perform vertical datum transformations.

Important Fixes

  • [D6337] Active Coordinate Editor - switching drawings in the CAD window may not reliably switch the Coordinate Editor view to match the current drawing.
  • [D6580] Active Coordinate Editor - Sorting the points by Point ID does not sort the points numerically.
  • [D3944] Active Coordinate Editor - Auto-Adding Points to Point Nodes did not update the coordinate editor to show the new points.
  • [D5598] Alphanumeric Points - Dashes in alphanumeric point IDs can cause the program to stop responding when iterating through the database in some situations.
  • [D4206] Alphanumeric Points - Incrementing alphanumeric point IDs had some inconsistent behaviour. For example, the Next point after "a" may be either "a0" or "a1" depending on the command.
  • [D6399] Areas - For some geometry, the FASTAREA (Area by Selecting Objects) command may either fail without calculating the Area or cause the program to crash.
  • [D5812] AutoMap Library - A crash can occur when processing large projects (ie, more than 4000 points).
  • [D5935] AutoMap Library - Switching drawings did not force the AutoMAP library to switch.
  • [D6121] AutoMap Library - An AutoMap Library located outside of the default folder could not be automatically opened, so the mscad.csv library would load instead.
  • [D6390] AutoMap Library - Switching drawings in the CAD window could cause the program to stop responding if the drawing's AutoMap Library references a block that cannot be found.
  • [D2303] Coordinate Database – storing point IDs with leading zeroes (like "001") caused various problems.
  • [D4299] Coordinate Systems - "Other North American Systems" coordinate system group displays garbled characters.
  • [D6217] Coordinate Transformations - in the case of invalid input data, an illegible error message was displayed.
  • [D5882] Edit Point - The point node and labels were not highlighted while editing a point.
  • [D5959] Edit Point - The display did not immediately update after storing or editing a point.
  • [D2238] Entity Properties – changing the layer of a line/arc will remove it from the database.
  • [D6119] Entity Properties – changing non-geometric properties of a line/arc will remove it from the database.
  • [D5984] Erase Layer - points and/or figures that are erased were not automatically removed from the database.
  • [T1615] Error Log - Problems that occur during use of the program are now logged to a file which can be used by MicroSurvey staff to debug problems.
  • [D5638] Export ASCII - a crash can occur when exiting the Export ASCII command by pressing <Enter> instead of <Esc> at the Enter Point or Range prompt.
  • [D6785] Export ASCII - Points with very large point IDs are exported multiple times.
  • [D2352] Export Layout/FieldGenius – After exporting a FieldGenius 2004+ project you cannot open the generated .DXF file until the program is restarted.
  • [D6000] Export Layout/FieldGenius - Blocks containing non-constant attribute definitions would cause an error message "Error PA2-W5S, Unable to create entity (INSERT) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6351] Export Layout/FieldGenius - Proxy Entities would cause an error message "Error PA2-W5S, Unable to create entity (ACAD_PROXY_ENTITY) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6352] Export Layout/FieldGenius - Arc Dimensions would cause an error message "Error PA2-W5S, Unable to create entity (ARC_DIMENSION) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6357] Export Layout/FieldGenius - Multi-Leaders would cause an error message "Error PA2-W5S, Unable to create entity (MLEADER) in block (DO_NOT_USE_FG_EXPORT)".
  • [D3934] Help - Help button in the Active Coordinate Editor's Coordinate Systems dialog did not work.
  • [D5629] Hot Toggles - Closing a drawing did not immediately update Hot Toggles with the settings in the new current drawing.
  • [D6529] Import ASCII – importing a space-delimited file with a blank line at the end of the file will zero the last read point.
  • [D5596] Import Layout/FieldGenius - The SYNCWIZARD command did not detect if the FieldGenius project units did not match the drawing units, this has been fixed and you are again prompted to change the drawing settings when they do not match.
  • [D5746] Import Layout/FieldGenius - The SYNCWIZARD command may not interpret the version number correctly from comment records like "--FieldGenius v 6.0.0.4 (2012-03-29)"
  • [D6203] Import Layout/FieldGenius - The SyncWizard Import command did start in the correct default folder.
  • [D6362] Import Layout/FieldGenius - The "Archive project upon import" option did not default on/off as appropriate.
  • [D6323] Import Layout/FieldGenius - An "Error, attempting to create directory" message could occur on startup if the program was installed by a different user account.
  • [D6517] Import Layout/FieldGenius - The Default Folder and Last Used Folder settings were not being saved and restored correctly.
  • [D3037] Labeling Defaults - Truetype fonts located in your system Fonts folder (for example, Arial.ttf) could not be specified in the Labeling Defaults dialog.
  • [D5666] Labeling Defaults - Truetype fonts located in your system Fonts folder (for example, Arial.ttf) could cause "Font not found" error messages when drawing text.
  • [D5603] Linework - When erasing entities in a drawing that have unexpected EED, a crash could occur.
  • [D5625] Linework - The PASTEORIG (Paste to Original Coordinates) command did not remove EED from the entities being copied, so further edits could inappropriately update the database.
  • [D5766] Linework - Deleting a layer via EXPLAYERS (Layers Explorer) that has points on it does not delete the points from the database.
  • [D5494] Linework - Erasing a DIM can cause lines to be removed from the database.
  • [D5997] Linework - Editing the length of a survey line via LEN command did not remove the line from the database.
  • [D5998] Linework - Moving a line by dragging it did not remove the line from the database.
  • [D6007] Linework - Moving a survey arc can cause the arc to be erased from the drawing if the "Draw lines/arcs" hot toggle is off.
  • [D4765] Log File - Writing to the .rtf log file can cause a crash and persistent "Error opening log file?" messages.
  • [D2294] Printing – when printing a Clusters report or Cut Sheet report, only the first page was printed.
  • [D2737] Printing – when printing from an Active Drawing Technology window, the Print Selection option was always disabled.
  • [D2279] Printing – when doing a Print Preview from an Active Drawing Technology window, the Previous Page and Zoom Out buttons do not work.
  • [D3223] Printing – when doing a Print Preview from an Active Drawing Technology window, clicking the middle-mouse button enters auto-scroll mode which cannot be exited.
  • [D6532] Project Manager - Creating a new drawing with a semicolon in the filename can cause the program to crash.
  • [D5948] Repeat Last Command - Various messages sent by the program to the commandline (including LBD, UPDATEACE, etc) would interfere with the ability to repeat the last command.
  • [D2048] Save - SAVEAS did not immediately create the new filename’s .msj database folder until a database-accessing command would run.
  • [D5929] Save - SAVEAS to a new filename also saves the original filename’s .msz database file, which may cause the drawing and database to get out of sync.
  • [D3425] Save - SAVE to a new filename also saves the original filename’s .msz database file, which may cause the drawing and database to get out of sync.
  • [D5980] Save - SAVEALL saves all open drawings with the current drawing’s .msz database file. As a preventative measure we have temporarily removed the SAVEALL command until this can be fixed.
  • [D6018] Save - SAVEAS to the same filename of another currently open file could cause an error message and crash.
  • [D6052] Save - SAVEAS to the same filename with a different extension could cause an error message and crash.
  • [D6436] Save As - overwriting an existing drawing would not overwrite the existing database file.
  • [D6488] Stake Out Report - Pressing Enter to repeat the Stake Out Points command would cause the program to crash.
  • [D5595] Undo - Undo did not work well under Windows XP because it would undo each command in several steps instead of undoing the entire command in one step.
  • [D5977] Undo – focus can jump to another program after the "MicroSurvey database update report" dialog appears.
  • [D4929] Undo - Redo was not reliable, it would generate a message that it must immediately follow an UNDO.
  • [D2991] Undo - After copying database points, an Undo may remove the original points from the database.
  • [D5850] Undo - After copy/paste of database points, an Undo may delete the original points.

New Features in IntelliCAD 7.2

Performance Enhancements
Graphics device performance improved using OpenGL for graphics cards that support it properly. This greatly improves dynamic pan, zoom, redraw, and rotation, especially for large files.
File size and print time reduced for PDF printing.
Grip handling, trimming, and extending improved for splines and polylines with very large segment counts (5,000+) due to improved geometric functions for complex curves.
Divide command performance improved.
Dynamic display performance improved in large drawing files using new ZOOMDETAIL and DRAGDETAIL system variables.
Snapping for large drawing files improved.
Dynamic dragging improved during entity creation and modification in large drawing files.
Memory consumption reduced for raster images.
Entity Snaps
Use entity snap tracking.
Use new entity snaps: Parallel Snap, From Point, Temporary Tracking Point, and Midpoint Between 2 Points.
Snap to the center of a polygon (closed polyline).
Working with Other Files
Import .dgn files.
Export Collada format files (.dae files).
Insert underlays from .pdf, .dgn, and .dwf files.
Attach MrSID format files (.sid files).
Specify files and paths for working with IntelliCAD using the new Paths/Files tab interface in the Options dialog box.
Layouts
Clip layout viewports.
Right-click a Layout tab includes From Template.
APIs
IntelliCAD 7.2 uses Teigha for .dwg files version 3.5.1 from the Open Design Alliance.
New (starttransaction) and (endtransaction) LISP functions.
New SDS functions for working with graphics planes: sds_getviewplanedc, sds_releaseviewplanedc, and sds_cleanplane.
More New Features
Purge unused drawing elements using the new Purge dialog box.
Find and replace text.
Use the Notification Manager located in the lower right of the IntelliCAD window to view messages and alerts about drawings and running IntelliCAD.
Use updated selection filters to better select entities by property, type, proxy, and more.
Manage layers using utilities at the command line: LAYCUR, LAYDEL, LAYFRZ, LAYISO, LAYLCK, LAYMCH, LAYMCUR, LAYOFF, LAYON, LAYTHW, LAYULCK, LAYUNISO.
New System Variables
Added BALLOONTIMEOUT, DRAGDETAIL, GRAVITYSNAP, GRIDCOLOR, GRIDPOINSMAX, NOTIFYMANAGER, REGENMODEGLOBAL, REGENONZOOMFACTOR, REGENTOOLTIP, and ZOOMDETAIL.

Important Fixes in IntelliCAD 7.2

The following list details some of the 600+ fixes that were implemented since the 7.1 release.

Open and save files
Fixed .dwg files saved in 2004/2002 format.
Fixed QSAVE operation after SAVEAS.
Fixed QSAVE operation with .dxf files.
Improvements made to drawing recover after a crash.
Display
Zooming fixed for close-up work with point entities.
Autoregen fixed for zooming on large coordinates.
Render issues fixed when copying entities.
Render command fixed for open polylines.
Render issue fixed for hatches and images.
Render command fixed for entities with thickness.
Selection and entity editing
ORTHO fixed for inserting blocks and stretching with grips.
Fillet command improved when working with large coordinates.
Array command fixed when working with a rotated UCS.
Tangent and perpendicular snap order fixed when working with other snaps.
Polar tracking fixed with intersection snap.
Extension snap for arcs fixed to use arc path.
Offset command fixed for complex polylines and closed polylines.
Divide command speed improved for splines and polylines.
Stretch command improved when working with dimensions.
Hatches
Fixed issues where hatches were saved incorrectly.
Fixed application of ICADISO hatch patterns.
Improved copying of hatch properties.
Hatch associativity fixed for polylines.
Dimensions
Improved dimensions when the text gap is large.
Fixed the landing with leader when dimtad=1.
Radius and Diametric dimensions improvements when dimtix=1.
Dimension Update improvements for display.
Dimension command fixed for blocks.
Leader text fixed to display correctly in other dimension text.
-DIMSTYLE Restore fixed.
Text and multiline text
Text and multiline text improved printing results.
Text fill fixed for printing of TTF fonts.
Fixed issues with multiline text and background masks.
Fixed display in Multiline Text Editor for reported fonts.
Printing
Improved size of print job files.
Fixed delay when changing paper size.
Previous plot option available for page setups in Print dialog box.
Fixed "Print without print styles and lineweights."
Various fixes for the print mask.
Images
Improved memory usage for images.
Fixed loading issue when image is missing from specified path.
Fixed detachment issue for deleted images.
More fixes
Fixed various crash scenarios.
Polygonal viewports fixed when visualized using file "Graphic.cfg".
Fixed problem detaching erased xrefs.
Fix for GRIDCOLOR.
Fix for BLIPMODE and working with points.
Fixed problem when inserting shapes using default parameters.
CHSPACE command improvements.
Fixed issue with editing a block inside a block.
ATTEDIT command displays the names of attributes correctly now.
OLE fixed to paste images correctly and to open a new drawing when double-clicking paste-clipped entities.
Copying and pasting proxies fixed.
HPGAPTOL fixed.
The linetype definition is not full if create a new linetype based on the current one.
Linetype definition improvements.
PEDIT command fixed to convert line and arc entities to polylines with correct layers.
Fixed issue with deleting the last layout of a drawing.
Fixed Undo option for the Polyline command when Orthomode is turned on.

Important Fixes in IntelliCAD 7.2a

The following list details some of the new 700+ fixes that were implemented since the initial 7.2 release.

Performance enhancements
Improved performance for drawings with underlays, including snap, pan, zoom, and entity creation.
Improved regeneration when working with linetypes.
Printing
Several fixes for print preview.
Fixed some cases where the print area was cropped improperly.
Improved pen widths.
Fixed printing of OLE objects.
Dimensions
Fixed lineweight of diameter and radius dimensions.
Fixed editing of dimension text when using STRETCH.
Snapping and tracking
Fixed issue with intersection snapping when drawing entities.
Guidelines improved for polar and entity tracking and all entity snaps are turned on.
Fixed entity snaps when using STRETCH.
Fixed snapping to grip points during grip editing.
Fixed nearest snap after changing the viewpoint.
Fixed entity snaps when using Polyface Mesh command.
Blocks
Fixed cases where text inside blocks was not positioned properly.
Multiple fixes for exploding blocks.
Fixed insertion point of blocks with dimensions.
Fixed regenerating raster images in blocks.
Text
Multiple fixes for SPELL.
Fixed text height issue when working with annotative text.
MTEXT dialog oblique display improved.
Hatches
Fixed -HATCH with HPNAME set to a new pattern.
Improved handling of hatch display when pattern is to dense to display.
Fixed issue with custom hatch patterns.
Fixed issue when moving associative hatches.
Raster images
Fixed issue with negative viewing and printing of some raster images.
Image selection fixed when working with grids.
Transparent ZOOM fixed when working with the IMAGECLIP command.
Fixed the ATTACH command for raster images.
Image printing fixed when fading is set to 0.
Fixed use of positioning files for images.
Fixed "keep aspect ratio" option for raster images.
Clipping fixed for images with rotated UCS.
More fixes
Issues fixed for opening drawings with AEC objects.
Fixed loading of linetypes from icad.lin in reported cases.
Several fixes when using grips, including entity display, z-coordinate issues, and image frame display.
Cross polygon selection fixed for reported zoom levels.
Fixed DIVIDE when working with blocks.
Fixed OFFSET for ellipses.
Fixed selection of hidden shapes.
Fixed issues with CHSPACE command.
Fixed TRIM command when working with infinite lines.
Multiple fixes for rotation.
Multiple display fixes, including for ACIS objects, viewing multiple viewports, ZOOM+E, HIDE command, and grips.
Fixed issues with DVIEW command.
Fixed WP selection for non-world view.
Fixed cursor position during tablet use.
Fixed z-coordinate issue for Box command options.
Export to PDF improved.
Options > Paths/Files tab improved.
New system variables
AECOBJECTS, AUTOCOMPLETEMODE, DEFSAVEASTYPEINDEX, ETRACKDELAY, EXPXREFVISIBILITY, FINDTEXTINT, GRIDDISPLAY, GRIDMAJOR, GRIDSTYLE, GRIPBYKEYBOARD, LTYPEGEN, MTEXTOBLIQUECOLOR, MTEXTSTACKEDCOLOR, PRINTAUTOROTATE, WNDSHOWPROP.

Important Fixes in IntelliCAD 7.2b

The following list details some of the new 450+ fixes that were implemented since the 7.2a release.

Working with drawing files
Fixed crash resulting from auditing files in some cases.
Improvements to auto-saving.
Printing
Fixed reported cases where printing or print preview caused a crash.
Fixed Display Print Styles to update display properly.
Fixed printing on large custom paper sizes.
Dimensions
DIMARC added to the Dimensions menu and toolbar.
Update added to the Dimensions menu and toolbar.
Fixes for DIMRADIUS and DIMCENTER for blocks.
Snapping and tracking
Fixed ORTHO priority when ETRACK is enabled.
Fixed issue with OFFSET while also entity snapping.
Fixed Parallel snap when working with both Parallel and Extension snaps enabled.
Improvements to activating multiple snaps from the command line.
Quadrant snap and entity tracking issues fixed when working in UCS.
Entity snapping fixed for entities in paperspace.
Fixed POLAR for a rotated UCS.
Entity snaps fixed for plane surfaces.
Blocks
Fixed rotation issues during block insertion.
Fixed issue when inserting uniform-scale blocks.
Text
Multiline text improvements: Select All, right-click to paste without formatting, clear all formatting.
Multiline text justification improvements.
Fixes where formatting differed in editor and drawing (mtext).
Hatches
Fixed case where hatch disappeared after copying or moving it.
Fixed using the Stretch command with hatches.
Improvements to hatches that displayed with low density.
Improvements to hatch prompts.
More fixes
Crashes fixed during Layout switching in some cases.
Loading a .mnu file from a path with a dot symbol.
Double-click enabled for moving to paperspace while other entities are selected.
Fixed several issues when working with grips.
Improvements for working with OLE objects.
Fix for arc entities, including the Follow option.
Default toolbar layout improved in main window.
New toolbars: Zoom and Draworder. Some commands moved from the View toolbar to the Zoom toolbar.
Fixed display of Drawing Settings dialog box in non-English languages.
Zoom Object command added.
Fixed Zoom Dynamic for NWUCS.
Color selection fixed for cases where a crash was caused.
Multiple issues with wipeouts fixed.
Added recent command list to the context menu for right-clicking in a drawing.
Fixed issues handling large number of groups in IntelliCAD Explorer.
PURGE command now works with unnamed groups.
Fixed EXTRUDE for entities with large coordinates and for extruding regions on a closed polyline.
Fixed issue when drawing boxes with negative Z value.
Hyperlink icon display improved.
Fixes for the Stretch command.
Fix for entity display when layer color changes.
Fixes for Zoom Dynamic.
New system variables
ASYNCINIT, GROUPMAX, HIGHLIGHTLIMIT, HYPERLINKICON, HYPERLINKICONCOLOR, HYPERLINKICONSCALE, OLEBKGCOLOR, PRINTTEXTOUT, RTDISPLAY, and USEOLEBKGCOLOR.

Important Fixes in IntelliCAD 7.2c

The following list details some of the new 200+ fixes that were implemented since the 7.2b release.

Working with drawing files
Fixed conversion for files on read-only network drives.
Export PDF includes U.S./Imperial units support.
Performance for SAVEAS doubled.
Printing
Fixed printing when using the Window option.
Print Preview fixed to display polylines in some cases where they were not visible.
Fixed printing for entities with thickness different from "0".
Printing with a header or footer (Tools > Options > Printing) uses "," character to separate left, middle, and right aligned text.
Snapping and tracking
Center snap fixed when snapping to arc segment of closed polyline.
Nearest snap fixed when using grid and Ortho.
Snapping fixed to work with circles of small radiuses.
Extension snap fixed in UCS for linear entities.
Parallel snapping fixed for external references.
Polar tracking fixed in NWUCS.
Snap INT fixed for multi-line entities.
Entity snap markers visible when they display for entity of same color using the OSNAPXORDRAW system variable.
Text
MTEXT entity display accuracy improved in reported cases.
Text position fixed when changing text.
Alternate fonts fixed to be used for missing TrueType fonts.
Direct entry of Unicode codes is now supported in the Multiline Text dialog box.
More fixes
Association fixed for aligned dimensions.
Selection corrected for 3D line grips.
Draworder fixed for exploded blocks.
Improved context menu when right-clicking drawing window, including the addition of recently used commands.
Fixed SPLINEDIT layer issue.
Clicking and holding down the middle mouse button now activates the Pan command.
Fix for -IMAGE command when detaching.
Modified the order of entities in the selection set to be more consistent.
Performance improvement for DRAWORDER.
Fixed data issues when creating ATTDEF entities.
Added context menu when right-clicking user paths in Tools > Options > Paths/Files.
Fixed wipeout creation using entmake.
IntelliCAD Explorer now works with additional image file formats.
Fixed hatch creation in active viewports.
Fixed the Flatten command when working with leaders.
Enhanced performance of RTPAN.
New system variable
OSNAPXORDRAW.

Important Fixes in IntelliCAD 7.2d

The following list details some of the new 300+ fixes that were implemented since the 7.2c release.

Working with drawing files
Improved file conversion process for 2013 .dwg file versions.
Fixed issue with SAVEAS command on Windows 7 x64 operating systems.
Several improvements to PDF export.
File security improved.
Performance improvements
Selection performance improved in large drawings, including those with many groups or hyperlinks.
Dragging performance improved, including extents drawn when using COPY and COPYCLIP.
Improved speed performance when printing 3D visual styles in viewports.
Printing
Issue fixed when printing gradients.
Fixed issues when printing and previewing drawings with rotated views.
Improvements to printing in color.
Fixed reported issues when printing MTEXT.
Selecting and viewing
Fixed display issues in read-only drawings.
Fixed reported display issues when zooming.
Fixed display issues that previously required REGEN.
Fixed REGEN issues.
Snapping and tracking
Entity snapping fixed when osmode = 0.
Fixes for snap accuracy.
Fixes for reported issues with Perpendicular Snap and Parallel Snap.
Text
Negative oblique angle fixed when using DDEDIT.
Fixed usage of current text style for multiline text.
Fixed Text Fit option.
Background color can now be turned off in the Multiline Text dialog box.
Properties
Image Scale value fixed.
Fixed text direction.
More fixes
Fixed localized versions that were not accepting some command options.
Fix for moving rotated dimensions.
Fixed issue when using Dim Continue on Dim Ordinate with a different UCS.
Fixed PLINE ARC drawn with negative angles in clockwise direction.
Added Bind option to Explorer > External References.
System variables fixed to be read-only: LOCALROOTPREFIX, MYDOCUMENTSPREFIX, and ROAMABLEROOTPREFIX.
Explode command fixed for 3D faces.
EXPLAYOUTS fixed for importing and exporting layouts to/from drawing templates.
Grid density improvements.
Fix for attribute selection order.
Fixes for extruding polylines and regions.
Fixes for stretching dimension text.
Hatch area calculations improved.
Fixed issue during layout viewing/switching when LAYOUTREGENCTL = 1.
New system variables
AUTOCONVERT, FASTIMAGEDRAW, FINDOPTIONS, NETFLOATLICENSE, PRINTIMAGEQUALITY, SPACEASENTER.
(0 vote(s))
Helpful
Not helpful

Comments (0)