Knowledgebase
MicroSurvey Point Prep 2014 Release Notes
Posted by Brian Sloman on 20 May 2014 08:11 AM

Release History

MicroSurvey Point Prep 2013 (v13.0.0) - October 19, 2012

MicroSurvey Point Prep 2014 (v14.0.0) - May 23, 2014


Important Notes

Activating or Updating your USB License Key

If you are licensing MicroSurvey Point Prep for the first time you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey Point Prep 2013, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MicroSurvey Point Prep, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MicroSurvey Point Prep service pack updates. For a detailed explanation of MicroSurvey's Maintenance Subscription Support Plan (MSSP) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your Maintenance Subscription has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the MSSP by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date.

If your MSSP has expired, you can phone us at 1-800-668-3312 or 1-250-707-0000 to renew it. Without a current maintenance subscription plan, you will not be able to update your key to work with the new version.

MicroSurvey Transfer Program for Layout Users

MicroSurvey Layout and users can use the installed MicroSurvey Transfer program to simplify the process of transferring Layout projects between your data collector and your PC.

If you have a copy of MicroSurvey Transfer already installed from use with another MicroSurvey product, it may not recognize Point Prep 2014. Previous versions of MicroSurvey Transfer will not show MicroSurvey Point Prep 2014 as a sync option in the Options screen.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

Installing the MicroSurvey Network License Server is only necessary for users who are setting up a MicroSurvey network license for the first time.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey Point Prep 2014 is compatible with 32-bit and 64-bit versions of Microsoft Windows Vista SP2, Windows 7 SP1, and Windows 8.

MicroSurvey Point Prep 2014 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, except for a compatible video card for the 3D Rendering engine. Please refer to this online article for a list of compatible video cards.

Windows XP Notes

Windows XP End of Support

Microsoft has announced that support for Windows XP will end on April 8, 2014. According to Microsoft, "After April 8, 2014, there will be no new security updates, non-security hotfixes, free or paid assisted support options or online technical content updates. Running Windows XP SP3 ... in your environment after their end of support dates may expose your company to potential risks" as detailed on their website here and here.

Until April 8, 2014, MicroSurvey Software Inc. will continue to develop, test, and support all of our products for Windows XP, providing that all third-party components still support Windows XP.

After April 8, 2014, MicroSurvey Software Inc. will no longer use the Windows XP operating system for any development, testing, or technical support. After this date, Windows XP will be completely unsupported. While our products may or may not continue to operate without issue beyond this date, using an unsupported operating system is not recommended and any issues that are specific to an unsupported operating system will not be addressed.

Windows Vista, Windows 7 & Windows 8 Notes

Run as Administrator

If installing on Windows Vistaor newer you must run the program at least once elevated with "Run as admininstrator" priviledges, even if you are already logged in with an "Administrator" account on the computer.

After this is done, it can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MicroSurvey Point Prep 2014 icon.
  2. Choose "Run as administrator".
  3. Select "Yes" on the "User Account Control" dialog when prompted to allow the program to make changes to your computer.

What's This? Help

If you wish to use the What's This? Help feature under Windows Vista or newer, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


Online Resources

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MicroSurvey Point Prep 2014 Frequently Asked Questions topic in our online helpdesk.

Upgrade Notes

For a list of questions and answers on upgrading from a previous version, please visit the MicroSurvey Point Prep 2014 Upgrade Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MicroSurvey Point Prep 2014 Known Issues topic in our online helpdesk.

Training Movies

For over 16 hours of training movies that you can watch online or download for offline viewing, please visit the Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at http://helpdesk.microsurvey.com/ where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are now answered in your Help file and Manuals.

For technical support, please visit our helpdesk at http://helpdesk.microsurvey.com/ to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Maintenance Subscription Support Plan (MSSP).

To purchase or renew your MSSP, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000 or visit our online store at store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to vote on other users' feature requests, please visit our Feedback Forum at http://feedback.microsurvey.com.

User Forum

To discuss your MicroSurvey product with other users, please visit our User Forum at http://www.microsurvey.com/forum/forum.htm.


MicroSurvey Point Prep 2013 (v13.0.0) Notes

New Features

Initial product release
MicroSurvey Point Prep 2013 is a desktop application designed to perfectly complement your MicroSurvey Layout or Leica iCON data collection software. Quickly transform a drawing file into a MicroSurvey Layout or Leica iCON project, upload and download between Point Prep on your desktop computer and Layout on your data collector, and import Layout projects into an annotated Point Prep drawing to review your field measurements.
Powered by IntelliCAD 7.2
MicroSurvey Point Prep 2013 is built on the latest IntelliCAD engine, IntelliCAD 7.2.

MicroSurvey Point Prep 2014 (v14.0.0) Notes

New Features

Powered by IntelliCAD 7.2d
Point Prep 2014 is built on the latest IntelliCAD engine, IntelliCAD 7.2d. See below for a summary of what's new.
AutoCAD® 2013 .dwg/.dxf File Support
Point Prep 2014 can now automatically convert and open AutoCAD 2013 .dwg/.dxf files, then Save them as R12-R2010 .dwg/.dxf format.
Or, use the standalone IntelliConvert conversion utility to manually convert R12-2013 .dwg/.dxf files.
LandXML .xml File Support
Point Prep 2014 can now import and export LandXML .xml files for easy data transfer with many third-party applications.
Import CGPoints, PlanFeatures, Surfaces, Alignments and Parcels from a LandXML file into your current drawing.
Export CGPoints, PlanFeatures and Surfaces from your current drawing into a LandXML file.
Select Import/Export > LandXML > LandXML Import from the menus, or type LANDXML_IN at the command line.
Select Import/Export > LandXML > LandXML Export from the menus, or type LANDXML_OUT at the command line.
Select Import/Export > LandXML > LandXML Export Range from the menus, or type LANDXML_EXPORT_RANGE at the command line.
3D Rendering
Advanced 3D Rendering capabilities have been added to MicroSurvey Point Prep, allowing you to view your drawing and surface models in an interactive and fluid 3D viewer.
Use the RENDER command (View > Rendering > Render) to open an interactive 3D viewer window of your current drawing.
Use the MATERIALS command (View > Rendering > Materials) to add texture images, transparency, and other effects onto surfaces displayed in the Render window.
Use the INSERTCAM command (View > Rendering > Insert Camera) to insert camera/target pairs into the drawing, which can be jumped to in the Render window.
Use the EDITCAM command (View > Rendering > Edit Cameras) to insert and edit camera/target pairs in the drawing.
Use the FIXCAMERAS command (View > Rendering > Fix Cameras) to update the internal camera definitions if you edit the camera or target entities via other manual methods.
Drawing Recovery Wizard
When opening a drawing where the expected .msz database file is not opened, the program will alert you and provide several options.
A common scenario is if the program crashes, when you reopen the drawing it would always open with the orphaned .msj database folder which may be out of sync with the drawing (the .dwg and .msz files contain everything as of the last save, but the .msj database folder contains everything as of the crash).
Select a recovery option to reopen the last saved .dwg drawing and .msz database files, the last saved .dwg drawing file with the orphaned .msj database folder (as before), the backup .bak drawing and .mbz database files, the autosave .sv$ drawing and .mz$ database files, and more.
Archive all drawing and database files in their current state, so you don't have to worry about making the wrong choice and losing any data.
There is no command to run; the Recovery Wizard will appear automatically if the program detects that an unexpected database file (not the .msz file) is being opened.
Coordinate System Search
Search for appropriate coordinate systems, based on a specified latitude/longitude position.
Select your appropriate system from the search results, and instantly set it as your drawing's Coordinate System.
Select Geodetic > Coordinate System Search, or type CSSEARCH at the command line.

Improved Features

Add Points to CAD Objects
Set the starting point ID and description to use for storing the new points.
Set the point description based on the selected entity's layer name or block name.
Set the selection filter to use only the desired entity types, from: Points, Lines, Arcs, Circles, Polylines, Blocks, and Text.
If any of the layers being drawn to are turned off or frozen, you will be prompted to turn them on and thaw them.
Select Points > Draw Points > Add Points to CAD Objects from the menus, or type AUTOP at the command line.
Add Points to CAD Intersections
When coordinating grid lines, assign names to each grid line like A,B,C,D,... and 1,2,3,4,... and automatically set the ID or Description of the resulting grid points using the grid line names like A-1,A-2,B-1,B-2,...
Select Points > Draw Points > Add Points to CAD Intersections from the menus, or type COORDINATE_GRID_LINES at the command line.
AutoSave with Survey Database
The IntelliCAD AutoSave feature now also saves a copy of the current database.
The AutoSave folder is your system Temp folder by default, and can be defined in the OPTIONS command.
The AutoSave drawing file extension is .SV$ by default and can be customized in the OPTIONS command.
The AutoSave database file extension is .MZ$ and cannot be customized.
To recover an AutoSave drawing, you must rename the .SV$ and .MZ$ file extensions to .DWG and .MSZ respectively.
Select Settings > Options from the menus, or type OPTIONS at the command line.
Labeling Defaults: Width Factors
Define text widths for all of the text styles in the MicroSurvey Labeling Defaults.
Select Settings > Labels... from the menus, or type CNF_EDIT_BEARINGS at the command line.
Points Database: Select Points by Description
You can now select points by description in the Active Coordinate Editor.
Includes options for case-sensitivity and matching the entire description.
Go to Select > Select By Description, within the Points Database window.
Points Database: Coordinate Systems
You can now view columns showing the Combined Scale Factor for each coordinate.
You can now view columns showing the Convergence Angle for each coordinate.
You can now view columns showing the Elevation for each transformed coordinate.
The Coordinate Systems dialog has been reworked to make it more intuitive and easier to use.
Go to Tools > Coordinate Systems, within the Points Database window.
Updated Coordinate System Engine
The CS-Map coordinate system engine was updated to provide 100% cross-compatibility between MicroSurvey Point Prep and MicroSurvey Layout.
Hundreds of new coordinate systems and geoids (previously available only for MicroSurvey Layout) are available for download in the MicroSurvey Helpdesk.
Select a vertical system (ellipsoid or geoid) and perform vertical datum transformations.

Important Fixes

  • [D6195] 3D Offset - Negative vertical offset (down) values could not be specified.
  • [D6409] 3-Point Inverse - Results of the MS_SHOW_ANGLE command are now displayed to the command line, in addition to the existing popup message.
  • [D5540] Active Coordinate Editor - A crash may occur when Shifting a large number of points.
  • [D5564] Active Coordinate Editor – Remove Selection from DTM can cause a crash if all points are removed from the surface.
  • [D6337] Active Coordinate Editor - switching drawings in the CAD window may not reliably switch the Coordinate Editor view to match the current drawing.
  • [D6580] Active Coordinate Editor - Sorting the points by Point ID does not sort the points numerically.
  • [D3944] Active Coordinate Editor - Auto-Adding Points to Point Nodes did not update the coordinate editor to show the new points.
  • [D5598] Alphanumeric Points - Dashes in alphanumeric point IDs can cause the program to stop responding when iterating through the database in some situations.
  • [D4206] Alphanumeric Points - Incrementing alphanumeric point IDs had some inconsistent behaviour. For example, the Next point after "a" may be either "a0" or "a1" depending on the command.
  • [D5910] Areas - FASTAREA (Area by Selecting Objects) command could become unstable and crash if a Spline is selected as a bounding entity.
  • [D6399] Areas - For some geometry, the FASTAREA (Area by Selecting Objects) command may either fail without calculating the Area or cause the program to crash.
  • [D5812] AutoMap Library - A crash can occur when processing large projects (ie, more than 4000 points).
  • [D5935] AutoMap Library - Switching drawings did not force the AutoMAP library to switch.
  • [D6121] AutoMap Library - An AutoMap Library located outside of the default folder could not be automatically opened, so the mscad.csv library would load instead.
  • [D6390] AutoMap Library - Switching drawings in the CAD window could cause the program to stop responding if the drawing's AutoMap Library references a block that cannot be found.
  • [D5684] AutoSave - A crash can occur if an AutoSave occurs while editing Text via the Entity Properties panel.
  • [D5955] AutoSave - AutoSave can occur in the middle of some commands, which can cause error messages and/or a crash.
  • [D2303] Coordinate Database – storing point IDs with leading zeroes (like "001") caused various problems.
  • [D4299] Coordinate Systems - "Other North American Systems" coordinate system group displays garbled characters.
  • [D6217] Coordinate Transformations - in the case of invalid input data, an illegible error message was displayed.
  • [D6303] Drawing Cleanup Wizard - The "Bind External References (Xrefs) as Blocks" option did not work because of the new Xref Manager dialog.
  • [D5882] Edit Point - The point node and labels were not highlighted while editing a point.
  • [D5959] Edit Point - The display did not immediately update after storing or editing a point.
  • [D2238] Entity Properties – changing the layer of a line/arc will remove it from the database.
  • [D6119] Entity Properties – changing non-geometric properties of a line/arc will remove it from the database.
  • [D5984] Erase Layer - points and/or figures that are erased were not automatically removed from the database.
  • [T1615] Error Log - Problems that occur during use of the program are now logged to a file which can be used by MicroSurvey staff to debug problems.
  • [D5638] Export ASCII - a crash can occur when exiting the Export ASCII command by pressing <Enter> instead of <Esc> at the Enter Point or Range prompt.
  • [D6785] Export ASCII - Points with very large point IDs are exported multiple times.
  • [D2352] Export Layout/FieldGenius – After exporting a FieldGenius 2004+ project you cannot open the generated .DXF file until the program is restarted.
  • [D6000] Export Layout/FieldGenius - Blocks containing non-constant attribute definitions would cause an error message "Error PA2-W5S, Unable to create entity (INSERT) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6351] Export Layout/FieldGenius - Proxy Entities would cause an error message "Error PA2-W5S, Unable to create entity (ACAD_PROXY_ENTITY) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6352] Export Layout/FieldGenius - Arc Dimensions would cause an error message "Error PA2-W5S, Unable to create entity (ARC_DIMENSION) in block (DO_NOT_USE_FG_EXPORT)".
  • [D6357] Export Layout/FieldGenius - Multi-Leaders would cause an error message "Error PA2-W5S, Unable to create entity (MLEADER) in block (DO_NOT_USE_FG_EXPORT)".
  • [D3934] Help - Help button in the Active Coordinate Editor's Coordinate Systems dialog did not work.
  • [D5629] Hot Toggles - Closing a drawing did not immediately update Hot Toggles with the settings in the new current drawing.
  • [D6529] Import ASCII – importing a space-delimited file with a blank line at the end of the file will zero the last read point.
  • [D5596] Import Layout/FieldGenius - The SYNCWIZARD command did not detect if the FieldGenius project units did not match the drawing units, this has been fixed and you are again prompted to change the drawing settings when they do not match.
  • [D5746] Import Layout/FieldGenius - The SYNCWIZARD command may not interpret the version number correctly from comment records like "--FieldGenius v 6.0.0.4 (2012-03-29)"
  • [D6203] Import Layout/FieldGenius - The SyncWizard Import command did start in the correct default folder.
  • [D6362] Import Layout/FieldGenius - The "Archive project upon import" option did not default on/off as appropriate.
  • [D6323] Import Layout/FieldGenius - An "Error, attempting to create directory" message could occur on startup if the program was installed by a different user account.
  • [D6517] Import Layout/FieldGenius - The Default Folder and Last Used Folder settings were not being saved and restored correctly.
  • [D3037] Labeling Defaults - Truetype fonts located in your system Fonts folder (for example, Arial.ttf) could not be specified in the Labeling Defaults dialog.
  • [D5666] Labeling Defaults - Truetype fonts located in your system Fonts folder (for example, Arial.ttf) could cause "Font not found" error messages when drawing text.
  • [D6041] Licensing - Network License was not immediately released on exiting from the program, until timing out 180 seconds later.
  • [D5603] Linework - When erasing entities in a drawing that have unexpected EED, a crash could occur.
  • [D5625] Linework - The PASTEORIG (Paste to Original Coordinates) command did not remove EED from the entities being copied, so further edits could inappropriately update the database.
  • [D5718] Linework - Trimming a survey line removes the line from the database and erases its Bearing/Distance labels.
  • [D5766] Linework - Deleting a layer via EXPLAYERS (Layers Explorer) that has points on it does not delete the points from the database.
  • [D5494] Linework - Erasing a DIM can cause lines to be removed from the database.
  • [D5997] Linework - Editing the length of a survey line via LEN command did not remove the line from the database.
  • [D5998] Linework - Moving a line by dragging it did not remove the line from the database.
  • [D6007] Linework - Moving a survey arc can cause the arc to be erased from the drawing if the "Draw lines/arcs" hot toggle is off.
  • [D4765] Log File - Writing to the .rtf log file can cause a crash and persistent "Error opening log file?" messages.
  • [D6516] New Drawing – the NEWWIZ command can cause the program to stop responding if Degrees-minutes-seconds unit option is selected.
  • [D2294] Printing – when printing a Clusters report or Cut Sheet report, only the first page was printed.
  • [D2737] Printing – when printing from an Active Drawing Technology window, the Print Selection option was always disabled.
  • [D2279] Printing – when doing a Print Preview from an Active Drawing Technology window, the Previous Page and Zoom Out buttons do not work.
  • [D3223] Printing – when doing a Print Preview from an Active Drawing Technology window, clicking the middle-mouse button enters auto-scroll mode which cannot be exited.
  • [D6532] Project Manager - Creating a new drawing with a semicolon in the filename can cause the program to crash.
  • [T1532] Regen Notifications - REGENTOOLTIP system variable is now set to Off by default. This causes the program to automatically regenerate your drawing instead of displaying the popup notification that a regen is required.
  • [D5948] Repeat Last Command - Various messages sent by the program to the commandline (including LBD, UPDATEACE, etc) would interfere with the ability to repeat the last command.
  • [D2048] Save - SAVEAS did not immediately create the new filename’s .msj database folder until a database-accessing command would run.
  • [D5929] Save - SAVEAS to a new filename also saves the original filename’s .msz database file, which may cause the drawing and database to get out of sync.
  • [D3425] Save - SAVE to a new filename also saves the original filename’s .msz database file, which may cause the drawing and database to get out of sync.
  • [D5980] Save - SAVEALL saves all open drawings with the current drawing’s .msz database file. As a preventative measure we have temporarily removed the SAVEALL command until this can be fixed.
  • [D6018] Save - SAVEAS to the same filename of another currently open file could cause an error message and crash.
  • [D6052] Save - SAVEAS to the same filename with a different extension could cause an error message and crash.
  • [D6436] Save As - overwriting an existing drawing would not overwrite the existing database file.
  • [D6488] Stake Out Report - Pressing Enter to repeat the Stake Out Points command would cause the program to crash.
  • [D5653] Surface Modeling - The SVOL (Surface Volume) command's Volumes and Average Values report may generate incorrect Plan Area and Average Thickness values.
  • [D6129] Surface Modeling - In the Surface Color Options dialog, selecting Surface Color Method = None does not work.
  • [D6123] Surface Modeling - In the Surface Color Options dialog, when "Drawing Legend" is enabled it may not drawn onto the same layer as the surface.
  • [D3586] Surface Modeling - Contour interval color options may not always work as expected.
  • [D6420] Surface Modeling - Drawing cross-sections can produce a message "WARNINg_ Could not get osmode".
  • [D6612] Surface Modeling - Extracting breaklines from a large selection set may cause a crash.
  • [D6545] Surface Modeling - A crash may occur when drawing contour labels.
  • [D5595] Undo - Undo did not work well under Windows XP because it would undo each command in several steps instead of undoing the entire command in one step.
  • [D5977] Undo – focus can jump to another program after the "MicroSurvey database update report" dialog appears.
  • [D4929] Undo - Redo was not reliable, it would generate a message that it must immediately follow an UNDO.
  • [D2991] Undo - After copying database points, an Undo may remove the original points from the database.
  • [D5850] Undo - After copy/paste of database points, an Undo may delete the original points.

Important Fixes in IntelliCAD 7.2a

The following list details some of the new 700+ fixes that were implemented since the initial 7.2 release.

Performance enhancements
Improved performance for drawings with underlays, including snap, pan, zoom, and entity creation.
Improved regeneration when working with linetypes.
Printing
Several fixes for print preview.
Fixed some cases where the print area was cropped improperly.
Improved pen widths.
Fixed printing of OLE objects.
Dimensions
Fixed lineweight of diameter and radius dimensions.
Fixed editing of dimension text when using STRETCH.
Snapping and tracking
Fixed issue with intersection snapping when drawing entities.
Guidelines improved for polar and entity tracking and all entity snaps are turned on.
Fixed entity snaps when using STRETCH.
Fixed snapping to grip points during grip editing.
Fixed nearest snap after changing the viewpoint.
Fixed entity snaps when using Polyface Mesh command.
Blocks
Fixed cases where text inside blocks was not positioned properly.
Multiple fixes for exploding blocks.
Fixed insertion point of blocks with dimensions.
Fixed regenerating raster images in blocks.
Text
Multiple fixes for SPELL.
Fixed text height issue when working with annotative text.
MTEXT dialog oblique display improved.
Hatches
Fixed -HATCH with HPNAME set to a new pattern.
Improved handling of hatch display when pattern is to dense to display.
Fixed issue with custom hatch patterns.
Fixed issue when moving associative hatches.
Raster images
Fixed issue with negative viewing and printing of some raster images.
Image selection fixed when working with grids.
Transparent ZOOM fixed when working with the IMAGECLIP command.
Fixed the ATTACH command for raster images.
Image printing fixed when fading is set to 0.
Fixed use of positioning files for images.
Fixed "keep aspect ratio" option for raster images.
Clipping fixed for images with rotated UCS.
More fixes
Issues fixed for opening drawings with AEC objects.
Fixed loading of linetypes from icad.lin in reported cases.
Several fixes when using grips, including entity display, z-coordinate issues, and image frame display.
Cross polygon selection fixed for reported zoom levels.
Fixed DIVIDE when working with blocks.
Fixed OFFSET for ellipses.
Fixed selection of hidden shapes.
Fixed issues with CHSPACE command.
Fixed TRIM command when working with infinite lines.
Multiple fixes for rotation.
Multiple display fixes, including for ACIS objects, viewing multiple viewports, ZOOM+E, HIDE command, and grips.
Fixed issues with DVIEW command.
Fixed WP selection for non-world view.
Fixed cursor position during tablet use.
Fixed z-coordinate issue for Box command options.
Export to PDF improved.
Options > Paths/Files tab improved.
New system variables
AECOBJECTS, AUTOCOMPLETEMODE, DEFSAVEASTYPEINDEX, ETRACKDELAY, EXPXREFVISIBILITY, FINDTEXTINT, GRIDDISPLAY, GRIDMAJOR, GRIDSTYLE, GRIPBYKEYBOARD, LTYPEGEN, MTEXTOBLIQUECOLOR, MTEXTSTACKEDCOLOR, PRINTAUTOROTATE, WNDSHOWPROP.

Important Fixes in IntelliCAD 7.2b

The following list details some of the new 450+ fixes that were implemented since the 7.2a release.

Working with drawing files
Fixed crash resulting from auditing files in some cases.
Improvements to auto-saving.
Printing
Fixed reported cases where printing or print preview caused a crash.
Fixed Display Print Styles to update display properly.
Fixed printing on large custom paper sizes.
Dimensions
DIMARC added to the Dimensions menu and toolbar.
Update added to the Dimensions menu and toolbar.
Fixes for DIMRADIUS and DIMCENTER for blocks.
Snapping and tracking
Fixed ORTHO priority when ETRACK is enabled.
Fixed issue with OFFSET while also entity snapping.
Fixed Parallel snap when working with both Parallel and Extension snaps enabled.
Improvements to activating multiple snaps from the command line.
Quadrant snap and entity tracking issues fixed when working in UCS.
Entity snapping fixed for entities in paperspace.
Fixed POLAR for a rotated UCS.
Entity snaps fixed for plane surfaces.
Blocks
Fixed rotation issues during block insertion.
Fixed issue when inserting uniform-scale blocks.
Text
Multiline text improvements: Select All, right-click to paste without formatting, clear all formatting.
Multiline text justification improvements.
Fixes where formatting differed in editor and drawing (mtext).
Hatches
Fixed case where hatch disappeared after copying or moving it.
Fixed using the Stretch command with hatches.
Improvements to hatches that displayed with low density.
Improvements to hatch prompts.
More fixes
Crashes fixed during Layout switching in some cases.
Loading a .mnu file from a path with a dot symbol.
Double-click enabled for moving to paperspace while other entities are selected.
Fixed several issues when working with grips.
Improvements for working with OLE objects.
Fix for arc entities, including the Follow option.
Default toolbar layout improved in main window.
New toolbars: Zoom and Draworder. Some commands moved from the View toolbar to the Zoom toolbar.
Fixed display of Drawing Settings dialog box in non-English languages.
Zoom Object command added.
Fixed Zoom Dynamic for NWUCS.
Color selection fixed for cases where a crash was caused.
Multiple issues with wipeouts fixed.
Added recent command list to the context menu for right-clicking in a drawing.
Fixed issues handling large number of groups in IntelliCAD Explorer.
PURGE command now works with unnamed groups.
Fixed EXTRUDE for entities with large coordinates and for extruding regions on a closed polyline.
Fixed issue when drawing boxes with negative Z value.
Hyperlink icon display improved.
Fixes for the Stretch command.
Fix for entity display when layer color changes.
Fixes for Zoom Dynamic.
New system variables
ASYNCINIT, GROUPMAX, HIGHLIGHTLIMIT, HYPERLINKICON, HYPERLINKICONCOLOR, HYPERLINKICONSCALE, OLEBKGCOLOR, PRINTTEXTOUT, RTDISPLAY, and USEOLEBKGCOLOR.

Important Fixes in IntelliCAD 7.2c

The following list details some of the new 200+ fixes that were implemented since the 7.2b release.

Working with drawing files
Fixed conversion for files on read-only network drives.
Export PDF includes U.S./Imperial units support.
Performance for SAVEAS doubled.
Printing
Fixed printing when using the Window option.
Print Preview fixed to display polylines in some cases where they were not visible.
Fixed printing for entities with thickness different from "0".
Printing with a header or footer (Tools > Options > Printing) uses "," character to separate left, middle, and right aligned text.
Snapping and tracking
Center snap fixed when snapping to arc segment of closed polyline.
Nearest snap fixed when using grid and Ortho.
Snapping fixed to work with circles of small radiuses.
Extension snap fixed in UCS for linear entities.
Parallel snapping fixed for external references.
Polar tracking fixed in NWUCS.
Snap INT fixed for multi-line entities.
Entity snap markers visible when they display for entity of same color using the OSNAPXORDRAW system variable.
Text
MTEXT entity display accuracy improved in reported cases.
Text position fixed when changing text.
Alternate fonts fixed to be used for missing TrueType fonts.
Direct entry of Unicode codes is now supported in the Multiline Text dialog box.
More fixes
Association fixed for aligned dimensions.
Selection corrected for 3D line grips.
Draworder fixed for exploded blocks.
Improved context menu when right-clicking drawing window, including the addition of recently used commands.
Fixed SPLINEDIT layer issue.
Clicking and holding down the middle mouse button now activates the Pan command.
Fix for -IMAGE command when detaching.
Modified the order of entities in the selection set to be more consistent.
Performance improvement for DRAWORDER.
Fixed data issues when creating ATTDEF entities.
Added context menu when right-clicking user paths in Tools > Options > Paths/Files.
Fixed wipeout creation using entmake.
IntelliCAD Explorer now works with additional image file formats.
Fixed hatch creation in active viewports.
Fixed the Flatten command when working with leaders.
Enhanced performance of RTPAN.
New system variable
OSNAPXORDRAW.

Important Fixes in IntelliCAD 7.2d

The following list details some of the new 300+ fixes that were implemented since the 7.2c release.

Working with drawing files
Improved file conversion process for 2013 .dwg file versions.
Fixed issue with SAVEAS command on Windows 7 x64 operating systems.
Several improvements to PDF export.
File security improved.
Performance improvements
Selection performance improved in large drawings, including those with many groups or hyperlinks.
Dragging performance improved, including extents drawn when using COPY and COPYCLIP.
Improved speed performance when printing 3D visual styles in viewports.
Printing
Issue fixed when printing gradients.
Fixed issues when printing and previewing drawings with rotated views.
Improvements to printing in color.
Fixed reported issues when printing MTEXT.
Selecting and viewing
Fixed display issues in read-only drawings.
Fixed reported display issues when zooming.
Fixed display issues that previously required REGEN.
Fixed REGEN issues.
Snapping and tracking
Entity snapping fixed when osmode = 0.
Fixes for snap accuracy.
Fixes for reported issues with Perpendicular Snap and Parallel Snap.
Text
Negative oblique angle fixed when using DDEDIT.
Fixed usage of current text style for multiline text.
Fixed Text Fit option.
Background color can now be turned off in the Multiline Text dialog box.
Properties
Image Scale value fixed.
Fixed text direction.
More fixes
Fixed localized versions that were not accepting some command options.
Fix for moving rotated dimensions.
Fixed issue when using Dim Continue on Dim Ordinate with a different UCS.
Fixed PLINE ARC drawn with negative angles in clockwise direction.
Added Bind option to Explorer > External References.
System variables fixed to be read-only: LOCALROOTPREFIX, MYDOCUMENTSPREFIX, and ROAMABLEROOTPREFIX.
Explode command fixed for 3D faces.
EXPLAYOUTS fixed for importing and exporting layouts to/from drawing templates.
Grid density improvements.
Fix for attribute selection order.
Fixes for extruding polylines and regions.
Fixes for stretching dimension text.
Hatch area calculations improved.
Fixed issue during layout viewing/switching when LAYOUTREGENCTL = 1.
New system variables
AUTOCONVERT, FASTIMAGEDRAW, FINDOPTIONS, NETFLOATLICENSE, PRINTIMAGEQUALITY, SPACEASENTER.
(0 vote(s))
Helpful
Not helpful

Comments (0)