Knowledgebase
MicroSurvey CAD 2015 Release Notes
Posted by Brian Sloman on 25 November 2014 04:40 PM

MicroSurvey CAD 2015 Release Notes


Release History

MicroSurvey CAD 2015 (v15.0.3.1574) - December 12, 2014


Important Notes

Activating or Updating your USB License Key

If you are licensing MicroSurvey CAD for the first time you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2014/2013/2010/2009/2008, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2005 or previous, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MicroSurvey CAD, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MicroSurvey CAD service pack updates. For a detailed explanation of MicroSurvey's Maintenance Subscription Support Plan (MSSP) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your Maintenance Subscription has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the MSSP by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date.

If your MSSP has expired, you can phone us at 1-800-668-3312 or 1-250-707-0000 to renew it. Without a current maintenance subscription plan, you may not be able to update your key to work with the new version.

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users need to download a copy of the MicroSurvey Transfer program to simplify the process of transferring FieldGenius projects between your data collector and MicroSurvey CAD.

If you have a copy of MicroSurvey Transfer already installed from use with MicroSurvey CAD 2010 or previous, you will need to update it to recognize MicroSurvey CAD 2013 or newer. Previous versions of MicroSurvey Transfer will not show MicroSurvey CAD 2015 as a sync option in the Options screen.

The MicroSurvey Transfer program has not changed since the release of MicroSurvey CAD 2013. This is only necessary for users who are setting up communications between FieldGenius (any version) and MicroSurvey CAD (2013 or newer) for the first time.

MicroSurvey Transfer can be downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

The MicroSurvey Network License Server program has not changed significantly since the release of MicroSurvey CAD 2008. This is only necessary for users who are setting up a MicroSurvey CAD 2008 or newer network license for the first time.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey CAD 2015 is compatible with 32-bit and 64-bit versions of Microsoft Windows Vista SP2, Windows 7 SP1, and Windows 8.1.

MicroSurvey CAD 2015 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, aside from a compatible video card for the 3D Rendering engine.

Please refer to this online article for a list of compatible video cards.

Windows XP Notes

Windows XP End of Support

Microsoft has announced that support for Windows XP will end on April 8, 2014. According to Microsoft, "After April 8, 2014, there will be no new security updates, non-security hotfixes, free or paid assisted support options or online technical content updates. Running Windows XP SP3 ... in your environment after their end of support dates may expose your company to potential risks" as detailed on their website here and here.

Until April 8, 2014, MicroSurvey Software Inc. will continue to develop, test, and support all of our products for Windows XP, providing that all third-party components still support Windows XP.

After April 8, 2014, MicroSurvey Software Inc. will no longer use the Windows XP operating system for any development, testing, or technical support. After this date, Windows XP will be completely unsupported. While our products may or may not continue to operate without issue beyond this date, using an unsupported operating system is not recommended and any issues that are specific to an unsupported operating system will not be addressed.

Windows Vista, Windows 7 & Windows 8 Notes

Run as Administrator

If installing on Windows Vista/7/8 you must run the program at least once elevated with "Run as admininstrator" access, even if you are already logged in with an "Administrator" account on the computer.

After this is done, it can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MicroSurvey CAD 2015 icon.
  2. Choose "Run as administrator".
  3. Select "Yes" on the "User Account Control" dialog when prompted to allow the program to make changes to your computer.

What's This? Help

If you wish to use the "What's This? Help" feature under Windows Vista/7/8, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


Online Resources

Release Notes

For a current version of this document, please visit the MicroSurvey CAD 2015 Release Notes topic in our online helpdesk.

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MicroSurvey CAD 2015 Frequently Asked Questions topic in our online helpdesk.

Upgrade Notes

For a list of questions and answers on upgrading from a previous version, please visit the MicroSurvey CAD 2015 Upgrade Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MicroSurvey CAD 2015 Known Issues topic in our online helpdesk.

Training Movies

For over 16 hours of training movies that you can watch online or download for offline viewing, please visit the Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at http://helpdesk.microsurvey.com/ where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are not answered in your Help file and Manuals.

For technical support, please visit our helpdesk at http://helpdesk.microsurvey.com/ to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Maintenance Subscription Support Plan (MSSP).

To purchase or renew your MSSP, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000, phone your local MicroSurvey dealer, or visit our online store at http://store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to comment and vote on other users' feature requests, please visit our Feature Request Forum at http://feedback.microsurvey.com.

User Forum

To discuss your MicroSurvey product with other users, please visit our User Forum at www.microsurvey.com/forum.

 


MicroSurvey CAD 2015

New Features

Powered by IntelliCAD 8
MicroSurvey CAD 2015 is built on the latest IntelliCAD engine, IntelliCAD 8.0a. IntelliCAD 8 is a major release and includes 2014 .dwg file format support for both 32-bit and native 64-bit platforms. New features include layer states, layer filters with search, quick select, 3D orbit, additional grid capabilities, Collada (.dae) file import, MrSID MG4 compressed raster image support, and more.
More than 1200 issues have been resolved since the IntelliCAD 7.2d release. These include performance enhancements and improvements to the user interface, printing, text, dimensions, entity snapping and tracking, and more.
See below for additional details about what's new in IntelliCAD 8.
Dynamic Licensing
MicroSurvey CAD 2015 is now installed as one single installation containing all five different product levels: Basic, Standard, Premium, Ultimate, and Studio.
All product levels are pre-loaded and available in every MicroSurvey CAD 2015 install, and are activated dynamically by your USB license key. Use any valid key with any installation - no more reinstalling to change product levels!

Enhanced Features

AutoMAP Plotted Descriptions
ASCII Export:
A new "Use Plotted Description" option has been added to the Export ASCII commands which will write out the AutoMAP Plotted Descriptions in place of the Descriptions.
Type ASCII_OUT at the command line, or in the menus select MsPoints > Export ASCII Points or Lat Long File.
Active Coordinate Editor:
An optional "Plotted Description" column can now be enabled in the Active Coordinate Editor.
Type COORDEDIT at the command line, or in the menus select MsPoints > Active Coordinate Editor.
Single Point Editor:
A new "Plotted Description" field has been added to the Single Point Editor dialogs.
Type EDITP at the command line, or in the menus select MsPoints > Store & Edit Points, or with your grips off click on a point node or label.
Geodetic Single Point Editor:
A new "Plotted Description" field has been added to the Single Point Editor dialogs.
Type EDITPG at the command line, or in the menus select MsPoints > Store & Edit Geodetic Position.
AutoMAP Substitution Codes
Access field-coded parameters directly from your point descriptions and use them to control the Layer, Symbol, and other fields. (Previously available only in the Plotted Description field.)
Substitution codes use the same syntax as introduced in MicroSurvey CAD 2013 for the Plotted Description field, and include $0 to substitute the code, $1-$9 to substitute the first through ninth space-delimited parameter following the code, $+ to substitute all parameters following the code, $* to substitute the entire description including the code plus all parameters, and $$ to substitute a literal "$" character.
For example, specify a Layer name like $1 and a block name like TREE_$1.DWG in AutoMap to dynamically place TREE points like TREE OAK and TREE ELM on OAK and ELM layers with TREE_OAK.DWG and TREE_ELM.DWG symbols.
Type AUTOMAP_EDITOR at the command line, or in the menus select MsTraverse > AutoMAP System > AutoMAP Library.
Google Earth KML Export
Additional details are available in the Point and Line/Curve details, including point coordinates and line and curve information.
New style options are available for specifying the point icon, icon size, and label size.
Type WRITEKML at the command line, or in the menus select MsPoints > Other Program Ties > Leica DBX > Import Leica DBX.
Leica DBX Import
Import Leica Codelists, and add its contents to your AutoMAP library.
Import "Ghost Point" setups, where the project starts with a setup that was established in a different project.
Type DBXIN at the command line, or in the menus select MsTraverse > Read Collector Files In > Leica DBX > Import Leica DBX.
Line/Curve/Tie Tables
Use point IDs to specify which lines, curves, and ties you want to added to Line Table, Curve Table or Multi-Tie Table.
Type LINE_TABLE at the command line, or in the menus select MsAnnotate > Add Tables > Add Lines to Table.
Type CURVE_TABLE at the command line, or in the menus select MsAnnotate > Add Tables > Add Curves to Table.
Type MULTITIES at the command line, or in the menus select MsAnnotate > Add Tables > Add Ties to Table.
Line Labels
A new option has been added into the Bearing Labeling Defaults to specify the number of spaces between the Degrees, Minutes, and Seconds values in a Bearing label like N 30° 12' 34" E.
Type CNF_BEARINGS at the command line, or in the menus select MsAnnotate > Labeling Defaults > Bearings.
COGO Bearing Rotation
A "Rotated Bearing/Azimuth" field has been added onto the CAD Lines and CAD Curves dialogs, to show both the original and rotated bearing/azimuth per the specified COGO Bearing Rotation angle.
A "Rotated Chord Bearing/Azimuth" field has been added onto the CAD Lines and CAD Curves dialogs, to to show both the original and rotated chord bearing per the specified COGO Bearing Rotation angle.
To access the System Toggles, type CNF_EDIT_TOGGLES at the command line, or in the menus select MsTools > MicroSurvey System Toggles.
To access the CAD Lines or CAD Curves dialogs, make sure your GRIPS are turned off then click on the desired line or arc.
Clusters
Draw the error vectors of each cluster as polar or orthogonal lines, with an exaggeration factor and customizable color and layer properties depending on the pass/fail condition.
Type CLUSTERS at the command line, or in the menus select MsPoints > Clusters.
Point Cloud Conversion
Conversion of XYZ files is more flexible, allowing conversion of "X Y Z", "X Y Z R G B", "X Y Z I", and "X Y Z I R G B" data.
Type PCICU at the command line, or in the menus select MsAdvanced > PCI Conversion Utility.

Important Fixes

  • [D6374] Active Coordinate Editor - When switching drawings in CAD, the Active Coordinate Editor may not switch to that of the current drawing.
  • [D6773] Active Coordinate Editor - When saving a drawing as a new name, the Active Coordinate Editor may not switch to that of the new drawing.
  • [D6726] Animation - When using the Record Movie button, the Browse dialog's title bar text text is not displayed correctly.
  • [D6852] Best Fit Line/Curve - The Updatedb, Move option does not work with alphanumeric point IDs.
  • [D6963] CAD Lines Dialog - Clicking on a line while viewing a drawing from along the X or Y axis can cause the program to crash.
  • [D7139] CAD Lines Dialog - The Angle field has been relabeled as Azimuth or Bearing depending on your unit settings.
  • [D6832] COGO Bearing Rotation - The Apply Bearing Rotation option is ignored when entering a chord bearing via the CB option.
  • [D6690] Coordinate Transformations - transformations between Canadian Systems on the NAD27 and NAD83(CSRS) datums (ie: UTM-NAD27-xx to UTM-NAD83(CSRS)-xx, and vice-versa) do not work. The NTv2 grid shift file(s) specified via Nad27toCSRS.gdc were applied incorrectly, resulting in coordinate errors of about 0.3m (but this may vary).
  • [D6789] Coordinate Transformations - transformations between Canadian Systems on the NAD83(Original) and NAD83(CSRS) datums (ie: MTM-NAD83(Original)-xx to MTM-NAD83(CSRS)-xx, and vice-versa) do not work. The NTv2 grid shift file(s) specified via Nad83toCSRS.gdc were applied incorrectly, resulting in coordinate errors of about 0.4m (but this may vary).
  • [D6847] Coordinate Transformations - transformations between Canadian Systems on the NAD27 and NAD83(Original) datums (ie: MTM-NAD27-xx to MTM-NAD83(Original)-xx, and vice-versa) do not work. The NTv2 grid shift file(s) could not be specified via the new Nad27toNad83.gdc, resulting in coordinates that would not change.
  • [D7106] Coordinate Transformations - transformations between US Systems on the NAD83 and HPGN datums do not work (ie: XX83 to XXHP, and vice-versa) do not work. The NADCON HPGN grid shift files specified via Nad83toHARN.gdc were applied incorrectly, resulting in coordinate errors of about 0.8' (but this may vary).
  • [D7106] Coordinate Transformations - transformations between US Systems on the NAD27 and NAD83 datums do not work (ie, NAD27-PR-1 to LL84, and vice-versa) do not work. The NADCON grid shift files specified via NAD27toNAD83.gdc are unable to compute a position, resulting in coordinates at 0,0.
  • [D6826] Database - The .msz database file can be created with an incorrect path offset for the temporary .msj database folder, which can cause various errors when reading data from an .msz file.
  • [D7090] Database - Creating a new drawing, when an .msj folder of the same name already exists, causes the new drawing and database to be out of sync.
  • [D6492] Drawing Refresh - The screen does not always update when using the Zoom buttons on the Single Point Editor, or when drawing lines from the CAD Lines or CAD Curves dialogs.
  • [D6731] Export ASCII Lat/Long - An error message "Pt 0: is not a valid key name." appears for every exported point.
  • [D7092] Export Leica iCON - Large coordinate values may be exported in scientific notation.
  • [D7072] Export STAR*NET - The Help button on the STAR*NET Export command does not work.
  • [D6889] Help Files - The Microsoft Translator widget used in the Help files started generating script errors and has therefore been removed.
  • [D6509] Import Leica DBX - "Ghost Point" setups (where the setup was established in a previous project) are not imported.
  • [D5909] Independent Point Numbers - IPN labels not displayed when in a UCS.
  • [D6230] Point Cloud Conversion - All Supported Types file filter should not include FARO *.fls and *.fws files, unless running the FARO version.
  • [D6843] Point Cloud Conversion - conversion of LAS files containing color values greater than 255 would cause the conversion to fail.
  • [D5522] Polylines - The Delete option in the PEDIT (Edit Polyline) command does not appear at the command line.
  • [D5676] Polylines - Selecting a polyline can cause the program to stop responding.
  • [D6980] Stake Out Points - The "Add Pts" button does not work for selecting points in the drawing.
  • [D6892] Surface Modeling - Drawing a Grid can cause the program to crash.

New Features in IntelliCAD 8.0

Working with Files
Open, save, and work with .dwg files of version 2014.
Import Collada (.dae files).
Improved support for DGN overlays, Civil3D, ADT, and mechanical object enablers.
Attach MrSID MG4 compressed raster images.
Performance Enhancements
IntelliCAD is available in 64-bit in addition to 32-bit.
Increased cursor speed.
Improved PDF export performance and reduced resulting file size.
Improved performance for multiple sessions on multi-core machines.
Improved Print Preview zoom performance.
Viewing Drawings
The grid can be drawn as lines or dots, can display beyond the drawing extents, and can be adaptive, which includes automatic resizing and subdivision based on the zoom level.
The Dynamic Viewpoint command was enhanced to include multiple ways of selecting a point from which to view three-dimensional entities.
The 3D Orbit command allows you to orbit a drawing, that is, rotate the view. Commands includes Constrained Orbit, Free Orbit, Continuous Orbit, Constrained X Orbit, Constrained Y Orbit, and Constrained Z Orbit.
Layers
Manage layers with layer states.
Search for layers by name.
Filter layers.
Layer properties include Transparency and Viewport Freeze.
New Layer Tools menu and toolbar.
Rendering
Rendering interface redesigned and enhanced.
Complete rendering features are now available in MicroSurvey CAD.
APIs
IntelliCAD 8.0 uses Teigha version 3.9.1 from the Open Design Alliance.
More New Features
CUI menu files supported.
Many user interface enhancement features, including more efficient menu and toolbar organization, slimming of toolbars to create more drawing space, and more.
Many improvements to paperspace, such as UCS icon changes, ease in which modelspace viewports are created, and more.
All color assignments for screen items, such as background color, icon color, etc., can now be made by choosing Tools > Options > Display tab, then clicking Color Scheme.
New Quick Select command.
Tip of the Day now displays as an event in the corner of the main window when IntelliCAD starts.
Improved grip editing for dynamic blocks.
Image Attach command supports embedded world file data in MrSID image files.
New PRINTOPTIONS command for easy accessibility to Print Options.
New XOPEN command to allow quick editing of attached xref files.
New Draw Order options to quickly push back or bring forward annotation and hatches.
Enhanced CUSTOMIZE command eases menu and toolbar customization.
System Variables
Added or updated: 3DORBITMODE, CUSTOMICONSPATH, EXPLAYERFIL­TERWIDTH, FACETRES, GRIDCOLORMAJOR, GRIDCOLORMINOR, GRIDDISPLAY, GRIDMAJOR, GRIDMODE, GRIDPOINTSMAX, GRID­STYLE, LAYERINVERTFILTER, LAYOUTCREATEVIEWPORT (which replaced and deprecated PSPACEMVIEW), LISPPATH, ORBITCOLOR, PRINTTILESIZE, PSICONCOLOR, QSELECTLISTVALUES, TEXLIBPATH, TRIMALLMAXNESTEDBLOCKLEVEL, UITHEME.
All color-related system variables were changed to support RGB and index color values: APERTURECOLOR, AUDIOICONCOLOR, AUTOTRACKCOLOR, BKGCOLOR, BLIPCOLOR, COLORX, COLORY, COLORZ, DZOOME­COLOR, DZOOMSCOLOR, DZOOMVCOLOR, HIGHLIGHTCOLOR, HYPERLINKICONCOLOR, MODELTOOLTIPCOLOR, MODELTOOLTIPB­KGCOLOR,OLEBKGCOLOR, PICKBOXCOLOR, PSPACEBCOLOR, PSPACEMCOLOR, PSPACEPCOLOR, SELCROSSINGAREACOLOR, SEL­CROSSINGFRAMECOLOR, SELWINDOWAREACOLOR, SELWINDOWFR­AMECOLOR, SNAPCOLOR, VIEWPORTLOCKBORDERCOLOR.

Important fixes in IntelliCAD 8.0

The following list details some of the 1100+ fixes that were implemented since the 7.2d release.

Open and save files
Audit command fixed for redundant text entities.
Display
Several fixes to prevent leftover screen pixels or empty screen portions during zooming and dragging.
Display of hatches improved.
Several fixes to cursor display in different scenarios.
Several fixes for Zoom Extents.
Several fixes for display issues when zooming in.
Improvements to 3D solids display.
Full Render fixed when using with a UCS different from WCS.
Selection and entity editing
Fixed snapping to 3D solids in blocks.
Fixed node snapping in xref drawings when PDMODE is non-zero.
Fixed grip editing for splines created from polylines.
Polar tracking guides fixed for new drawings.
Hatches
Improved speed and accuracy for hatching while using Select Area.
Fixed calculation of hatch lines enclosed by a circular arc.
Fixes for calculating hatch areas and boundary hatches in different cases.
Fixed hatching of visually closed polylines.
Fixed boundary detection for boundaries off screen.
Text and multiline text
Fixes for multiline text positioning.
Several fixes for the Find command.
Printing
Improvements to TrueType Font selection for printing.
Fixed issue when printed dashed area did not match print preview.
More fixes
Fixed ability to toggle wipeout frames for wipeouts that are part of blocks.
LIST command fixed for vertices of 2D and 3D polylines.
Flatten command fixed for 3D polylines (converting to 2D polylines) and for misplacing entities on the current layer.
Shape names from SHX files are no longer case-sensitive.
RGB colors fixed during PDF Export.
Offsetting fixed for spline entities.
Fillet command fixed for polylines with arc segments.
Fixed MATCHPROP for dimensions and viewports.
Draw order fixed for copied entities.
Fixed lineweight "adjust display scale".
Fixed MIRROR3D when using in NWUCS.
Scale accuracy fixed when inserting an image and using a positioning file.
(1 vote(s))
Helpful
Not helpful

Comments (0)