Knowledgebase: MicroSurvey CAD 2018
MicroSurvey CAD 2018 Release Notes
Posted by Brian Sloman on 25 October 2017 02:37 PM

Release History

MicroSurvey CAD 2018 (18.0.2.6630) - November 3, 2017

MicroSurvey CAD 2018 SP1 (18.1.4.8026) - September 14, 2018


Important Notes

Activating or Updating your USB License Key

If you are licensing MicroSurvey CAD for the first time you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from a previous version of MicroSurvey CAD 2018, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2017 thru 2008, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2005 or previous, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MicroSurvey CAD, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MicroSurvey CAD service pack updates. For a detailed explanation of MicroSurvey's Annual Maintenance Subscription (AMS) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your AMS has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the AMS by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date.

If your AMS has expired, you can phone us at 1-800-668-3312 or 1-250-707-0000 to renew it. Without a current maintenance subscription plan, you may not be able to update your key to work with the new version.

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users need to download a copy of the MicroSurvey Transfer program to simplify the process of transferring FieldGenius projects between your data collector and MicroSurvey CAD.

If you have a copy of MicroSurvey Transfer already installed from use with MicroSurvey CAD 2010 or previous, you will need to update it to recognize MicroSurvey CAD 2013 or newer. Previous versions of MicroSurvey Transfer will not show MicroSurvey CAD 2016 as a sync option in the Options screen.

The MicroSurvey Transfer program has not changed since the release of MicroSurvey CAD 2013. This is only necessary for users who are setting up communications between FieldGenius (any version) and MicroSurvey CAD (2013 or newer) for the first time.

MicroSurvey Transfer can be downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

The MicroSurvey Network License Server program has not changed significantly since the release of MicroSurvey CAD 2008. This is only necessary for users who are setting up a MicroSurvey CAD 2008 or newer network license for the first time.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey CAD 2018 is compatible with 32-bit and 64-bit versions of Microsoft Windows 7, Windows 8/8.1, and Windows 10.

MicroSurvey CAD 2018 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, aside from a compatible video card for the 3D Rendering engine.

Please refer to this online article for a list of compatible video cards.

Software Requirements

MicroSurvey CAD 2018 Ultimate/Studio requires that the following prerequisite software packages be installed to work with point clouds:

  1. Required: Leica Cyclone 9.1.1 or newer
  2. Optional: Leica Client License Manager (CLM) 1.4 or newer
  3. Optional: Leica JetStream 1.0.1 or newer

Please visit www.leica-geosystems.com to download these Leica products. A registered account is required.

Leica Cyclone must be installed, but it does not have to be licensed. MicroSurvey CAD will be fully functional with an unlicensed version of Cyclone.

Leica Cyclone and Leica JetStream are licensed independently from MicroSurvey CAD, by entering an entitlement certificate ID into the Leica CLM application.

Windows XP Notes

Windows XP End of Support

Microsoft has announced that support for Windows XP will end on April 8, 2014. According to Microsoft, "After April 8, 2014, there will be no new security updates, non-security hotfixes, free or paid assisted support options or online technical content updates. Running Windows XP SP3 ... in your environment after their end of support dates may expose your company to potential risks" as detailed on their website here and here.

Until April 8, 2014, MicroSurvey Software Inc. will continue to develop, test, and support all of our products for Windows XP, providing that all third-party components still support Windows XP.

After April 8, 2014, MicroSurvey Software Inc. will no longer use the Windows XP operating system for any development, testing, or technical support. After this date, Windows XP will be completely unsupported. While our products may or may not continue to operate without issue beyond this date, using an unsupported operating system is not recommended and any issues that are specific to an unsupported operating system will not be addressed.

Windows Vista Notes

Windows Vista End of Support

As of January 1, 2016, MicroSurvey Software Inc. will no longer support the installation of new products on Windows Vista or earlier.

Windows Windows 7, Windows 8/8.1 and Windows 10 Notes

Run as Administrator

You must run the program at least once elevated with "Run as admininstrator" access, even if you are already logged in with an "Administrator" account on the computer.

After this is done, it can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MicroSurvey CAD 2018 icon.
  2. Choose "Run as administrator".
  3. Select "Yes" on the "User Account Control" dialog when prompted to allow the program to make changes to your computer.

What's This? Help

If you wish to use the "What's This? Help" feature, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


Online Resources

Release Notes

For a current version of this document, please visit the MicroSurvey CAD 2018 Release Notes topic in our online helpdesk.

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MicroSurvey CAD 2018 Frequently Asked Questions topic in our online helpdesk.

Upgrade Notes

For a list of questions and answers on upgrading from a previous version, please visit the MicroSurvey CAD 2018 Upgrade Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MicroSurvey CAD 2018 Known Issues topic in our online helpdesk.

Training Movies

For over 16 hours of training movies that you can watch online or download for offline viewing, please visit the Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at helpdesk.microsurvey.com where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are not answered in your Help file and Manuals.

For technical support, please visit our helpdesk at helpdesk.microsurvey.com to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Annual Maintenance Subscription (AMS).

To purchase or renew your AMS, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000, phone your local MicroSurvey dealer, or visit our online store at http://store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to comment and vote on other users' feature requests, please visit our Feature Request Forum at http://feedback.microsurvey.com.

User Forum

To discuss your MicroSurvey product with other users, please visit our User Forum at www.microsurvey.com/forum.


MicroSurvey CAD 2018

Release Date: November 3, 2017

Version: 18.0.2.6630

New Features

Powered by IntelliCAD 8.4
MicroSurvey CAD 2018 is built on the latest IntelliCAD engine, IntelliCAD 8.4. (MicroSurvey CAD 2017 was built on IntelliCAD 8.2a.)
A key addition is the support of version 2018 .dwg files. Initial support of the latest .dwg file version 2018 does require conversion in MicroSurvey CAD 2018, and native support is expected soon.
IntelliCAD 8.4 is a major release that includes many new features and improvements. IntelliCAD 8.4 boosts performance during screen redraw and while snapping in files with underlays. Running on 4K monitors and switching between monitors with high resolutions is now supported. Create entities with the new Multileader, Quick Leader, and Break Line commands. Add styles using the new Multileader Styles Manager and Multiline Style commands. Select entities using the new Select Similar and Get Selection commands. Explode entities with more precision according to entity type using the new Explode Text and Explode Attributes commands. Add more formatting to text using the in-place Multiline Editor and line spacing, lists, and paragraph justification. Add automatic numbering to text, multiline text, multileaders, or block attributes using the new Auto Number command. Get more information about your drawings using the new Drawing Properties command. Another new feature is found in the updated Customize command which allows users to customize the user interface with less effort and share custom user interface settings easily between files and computers. You can drag-and-drop settings to customize menus, the ribbon, application button, and quick access toolbar, toolbars, keyboard shortcuts, and aliases.
IntelliCAD 8.3 is a major release that includes new support for the following: packaging drawings and their related files using the eTransmit command, adding gradient patterns to closed entities, improved ease-of-use for hatch patterns, creating filters for selecting entities, searching for files by clicking Tools>Find when using the Open command, easier access to saving workspaces, and more. Updated APIs include Teigha version 4.2.0 from Open Design Alliance and a major LISP upgrade (VL*, VLA*, VLAX* functions).
IntelliCAD 8.3a is a maintenance release that contains close to 300 improvements and fixes since the IntelliCAD 8.3 release. IntelliCAD 8.3a includes performance improvements, printing fixes, editing fixes, and more. Also included are enhancements to the new in-place multiline text editor , including paragraph alignment, symbols, alt-codes, stacked text, numbered lists, and unnumbered lists.
More than 1180+ issues have been resolved during the IntelliCAD 8.3, 8.3a and 8.4 product development cycles.
See below for additional details about what's new and fixed in IntelliCAD 8.3, 8.3a and 8.4
Shapefile Import
Import Esri Shapefile data into your drawing, with optional positional and/or attribute filters to control and limit exactly which features to import from often very large data sets.
Import various GIS data formats including Esri Shapefiles (*.shp and others), GPS Exchange Format (*.gpx), Google Earth KML/KMZ (*.kml,*.kmz) and GeoJSON (*.geojson,*.json).
Remap the attribute names to your own custom names so data sets from multiple independent sources can be correlated and processed together with single queries.
Modify the filters or attribute mappings of any imported data on-the-fly, without having to re-import anything if you want to change the import parameters.
Point features (like control monuments or landmarks) can be drawn as simple CAD nodes or imported into your points database, and the Point ID, Description, and/or elevation can be populated by attribute values.
Polyline features (like roads or rivers) can be drawn as polylines or imported into your polylines database. For example: rivers, roads, or property lines.
Polygon features (like lakes or lots) can be drawn as boundary hatches, with the boundary polyline optionally being imported into your polylines database.
Attributes can be viewed for any imported data, or queries can be run for mining specific attribute data from the Shapefiles.
JobXML Import
Import Trimble® and Spectra Precision® JobXML data files including point coordinates, GPS coordinates, and total station measurements.
3D Point Labels
A new "3D Point Labels" system toggle lets you draw point labels either in 2D at z=0 (default, as previous) or at each point node's 3D elevation.
The previous "2D Draw Mode" system toggle was renamed to "2D Point Nodes" to clarify the difference between these two options.

Enhanced Features

Smart Point Blocks
Leaders now size appropriately based on your Job Defaults (unit and drawing scale).
Labeling Defaults have been added to control the leroy size, layer, color, and dimension style of the leaders.

Important Fixes

  • [D8812] Angles/Bearings - CAD Curves, Delta angle listed does not match input
  • [D8821] Angles/Bearings - MS_ROTATE gives incorrect results when inversing a bearing
  • [D8826] Angles/Bearings - COGO operations with an invalid bearing (>=60 minutes/seconds) does not wrap correctly, bad result
  • [D8827] Angles/Bearings - COGO Bearing-Bearing intersection gives incorrect results
  • [D8858] Angles/Bearings - Decimal places/precision for Bearings
  • [D8867] Angles/Bearings - COGO Bearing-Bearing intersection displays incorrect bearing at command history
  • [D8869] Angles/Bearings - Degree (°) or Grad (g) symbol is now added to azimuth and angle labels, to avoid ambiguity
  • [D8870] Angles/Bearings - AUPREC>4 adds ".0" seconds to the label, still rounded to the whole second
  • [D8871] Angles/Bearings - Seconds Rounding less than 1 causes unexpected results
  • [D8872] Angles/Bearings - Seconds Rounding to 60 does not remove the seconds from the output
  • [D8873] Angles/Bearings - "Reference North" labeling default unexpectedly affects angles displayed in the Active Traverse Editor
  • [D8956] Angles/Bearings - "Reference North" labeling default unexpectedly affects inversed bearings in COGO
  • [D8971] Angles/Bearings - "Reference North" labeling default unexpectedly affects output in the Lot Closure Report
  • [D8930] AutoMAP Library - processing linework may connect the points out of sequence when drawing polylines
  • [D9005] AutoMAP Library - Reprocessing AutoMAP Library while the Active Coordinate Editor causes the grid to reload after each figure is drawn
  • [D8798] CAD Editing - Moving a selection set including "off line" labels does not move the labels
  • [D8799] CAD Editing - Moving a large selection set of objects can have a significant delay
  • [D8815] CAD Editing - Moving points while the Active Coordinate Editor is open can be slow when moving <50 points
  • [D8797] CAD Editing - The Copy Between Drawings command could cause the objects from a previous copy to be copied into the drawing
  • [D8801] CAD Editing - The Copy Between Drawings command could any selected IPN labels to disappear from the source drawing
  • [D8843] CAD Editing - Entities selected for the CAD Lines/Curves dialogs and Single Point Editor were not unselected when the dialog was closed
  • [D8824] Database Access - Opening, Closing, or Switching drawings while the Active Coordinate Editor is open could cause Codebase Error messages
  • [D8749] Leica DBX - Polylines imported from a DBX file Imported polylines are created with color White instead of ByLayer
  • [D8750] Leica DBX - Figures can be drawn with slightly incorrect curve geometry that is more "swoopy" than expected
  • [D8806] Line Labels - Manual Distance Labels update like an Auto Distance, value changes on MS_RESCALE or moving endpoints
  • [D8807] Line Labels - Manual Distance/Bearing labels are not deleted from database when the label is erased
  • [D8805] Line Tables - Line/Multities Tables, labels are positioned using the distance scale factor which can put them far away from the actual line
  • [D8819] Point Blocks - Various problems when using point block labels with leaders
  • [D9012] Point Protection - When storing a point without changing its position, the warning that the point was moved by less than point protection tolerance is no longer displayed.
  • [D8803] Polylines - Changing linetype/layer/linescale from Properties panel removes polylines from the database
  • [D8804] Polylines - MS_SHIFTP can cause polylines to not move with the shifted poings
  • [D8766] Polylines - Issue when joining two Polylines, one with an arc
  • [D8768] Polylines - Codebase errors in 32-bit version when autop two joined Polylines
  • [D8784] Polylines - SDS error in function received after turning lines to polylines, then switching direction format
  • [D8785] Polylines - Converting 3D to 2D breaks smart polylines
  • [D8684] Polylines - Undoing past the StartDatabaseReactors command causes polylines to become disconnected from the database
  • [D8810] Roading / Surface Modeling - Extracting cross sections from an alignment should plot the cross sections for multiple surfaces in the same grid
  • [D8751] Subdivision Design - Auto Lot Design crashes if the specified setback distance is greater than the lot depth
  • [D8811] Subdivision Design - When drawing a Lot Table, selecting a polyline causes the program to get locked into state that cannot be cancelled
  • [D8468] Symbol Librarian - Editing text within a symbol doesn't work correctly

New Features in IntelliCAD 8.3

IntelliCAD 8.3 is a major release that includes new support for the following: packaging drawings and their related files using the eTransmit command, adding gradient patterns to closed entities, improved ease-of-use for hatch patterns, creating filters for selecting entities, searching for files by clicking Tools > Find when using the Open command, easier access to saving workspaces, and more.

Updated APIs include Teigha version 4.2.0 from Open Design Alliance and a major LISP upgrade (VL*, VLA*, VLAX* functions).

Working with files
Search for files when using the Open command by clicking Tools > Find.
Package drawings and supporting files using the eTransmit command.
More options are available for attaching point cloud files using the Point Cloud Underlay command.
For versions of IntelliCAD that support opening and saving .dgn files natively, several new commands are available such as Arc, Redo, Lengthen, Scale, ID, and Fence.
Hatches
Hatch patterns now support gradients.
New dialog box interface for the Boundary Hatch command.
HATCHTOBACK command moves hatches to the back of the draw order.
User interface
Show drawings on individual tabs in the main IntelliCAD window. Use the Options command, click the Display tab, then click MDI Options to specify settings for drawing tabs.
For versions of IntelliCAD with a ribbon, workspaces are now easily accessible on the Quick Access toolbar.
Easily save workspaces by clicking Workspaces in the status bar and choosing Save Current As.
The Drawing Settings command has improved user interface that uses tabs instead of drop-down lists that were used previously.
Added -MENUUNLOAD command line version.
More features
Select entities by creating filters using the Filter command.
When using the Print command, you can now select print transparency.
APIs
IntelliCAD 8.3 uses Teigha version 4.2.0 from Open Design Alliance.
Major LISP upgrade (VL*, VLA*, VLAX* functions).
System variables
Added or updated: DTEXTED, GFANG, GFCLR1, GFCLR2, GFCLRLUM, GFCLRSTATE, GFNAME, GFSHIFT, MDISTYLE, MTEXTED, TEXTED, TEXTEDITMODE, XCLIPFRAME.

New Features in IntelliCAD 8.4

IntelliCAD 8.4 is a major release that includes many new features and improvements.

IntelliCAD 8.4 boosts performance during screen redraw and while snapping in files with underlays. Running IntelliCAD on 4K monitors and switching between monitors with high resolutions is now supported.

New features can be found throughout IntelliCAD 8.4. Create entities with the new Multileader, Quick Leader, and Break Line commands. Add styles using the new Multileader Styles Manager and Multiline Style commands. Select entities using the new Select Similar and Get Selection commands. Explode entities with more precision according to entity type using the new Explode Text and Explode Attributes commands. Add more formatting to text using the in-place Multiline Editor and line spacing, lists, and paragraph justification. Add automatic numbering to text, multiline text, multileaders, or block attributes using the new Auto Number command. Get more information about your drawings using the new Drawing Properties command.

Another new feature is found in the updated Customize command which allows users to customize the user interface with less effort and share custom user interface settings easily between files and computers. You can drag-and-drop settings to customize menus; the ribbon, application button, and quick access toolbar (for IntelliCAD versions that support a ribbon); toolbars; keyboard shortcuts; and aliases.

Performance
Improved entity snap performance in drawings with underlays.
Improved redraw performance when creating and updating entities in a drawing that has a large number of existing entities.
Working with files
Use the new Drawing Properties command to display properties for a drawing, some of which can be modified such as keywords and comments.
User interface
Running IntelliCAD on a 4K monitor and switching between monitors with high resolutions is greatly improved.
A new Customize dialog box allows for easier customization of the user interface. Use it to customize menus; the ribbon, application button, and quick access toolbar (for IntelliCAD versions that support a ribbon); toolbars; keyboard shortcuts; and aliases. You can also easily manage .cui customization files and share settings between files.
Creating entities
Draw a polyline that has a breakline symbol using the new Break Line command.
Draw leaders using the new Quick Leader command, or draw multileaders using the new Multileader command. You can edit, align, and collect multileaders. You can also create and assign styles to multileaders, which help control the layout and appearance of multileaders.
Use the new Multiline Styles command allows you to create and modify multiline styles, which help control the layout and appearance of multilines.
Selecting and modifying entities
Search for entities that match properties of other entities using the new Select Similar command. The entities with properties that match are then added to the selection set.
The new Explode Attributes command ungroups blocks, creating separate entities for each element and converting attributes to text.
The new Get Selection command selects all entities in a drawing that match both the layer of an entity you select and the type of an entity you select.
Text
The in-place Multiline Text editor now supports line spacing, lists, and paragraph justification.
Use the new Explode Text command to break multiline text and single-line text into polylines.
The new Auto Number command adds numbering to text, multiline text, multileaders, or block attributes.
More features
New Filter option for the -LAYER command.
System variables
Added or updated: BLIPSIZE, IFCOSNAP, MLEADERSCALE, SELECTSIMILARMODE, SNAPSIZE, UOSNAP.

Important fixes in IntelliCAD 8.3

The following list details some of the 450+ fixes that were implemented since the IntelliCAD 8.2a release.

Text and multiline text
Several fixes for working with the new multiline text editor.
Fixed specific drag issue for multiline text.
Fixed display of text during insertion when rotation angle is greater than 0.
Fixed issue with annotative text styles.
Several user interface fixes made to the Text dialog box.
Dimensions
Fixed issue with dimension style overrides.
Fixed crash scenario when editing a dimension style in IntelliCAD Explorer.
Printing
Fixed document name to contain layout name when using the Publish command.
Fixed issue with saving print stamp settings.
PDF export
Fixed issue when exporting all layouts to PDF.
Fixed issue with 3D Hidden and Realistic visual styles when exporting to PDF.
Fixed issue when exporting non-ACIS entities to 3D PDF.
More fixes
Many improvements made for running IntelliCAD on 4k displays.
Fixed specific crash when using COPYCLIP and PASTECLIP with some 3D entities.
Several fixes for editing entities with the Fillet command.
Fixed 3DORBIT with set rotation point in UCS.
Fixed .mnu export/import issue for toolbars.
Fixed issue with leader creation.
Fixed LENGTHEN when working with circles.
Several fixes for selecting entities using grips, including displaying grips after editing and memory issues.
Several fixes for perspective mode view.

Important Fixes in IntelliCAD 8.3a

IntelliCAD 8.3a includes performance improvements, printing fixes, editing fixes, and more. Also included are enhancements to the new in-place multiline text editor that was released last year, including paragraph alignment, symbols, alt-codes, stacked text, numbered lists, and unnumbered lists.

The following list details some of the 290+ fixes that were implemented since the IntelliCAD 8.3 release.

Performance
Significant performance improvements for snapping to PDF underlays (complete code refactoring in this area).
Fixed performance issue for window selection.
Fixed performance issue when drawing lines with multi-threaded turned on.
Fixed scenario where performance was degraded during selection and snapping.
Working with files
Exporting to a .pdf file was fixed for exporting drawings that contain extremely large images.
Editing entities
Several fixes for editing entities when using the Properties pane.
Several fixes for editing entities when using grips, including moving grips when ORTHO turned on, for polylines, and for multiline text.
Fixed the ERASE command for blocks on frozen layers and layers that are turned off.
Text
Fixed ability to convert a field to text.
Fixed display of text with UFDOT.SHX font.
Fixed issue when using the STYLE command with incorrect values for vertical text.
Several fixes for working with multiline text, including working with paragraph alignment, symbols, alt-codes, stacked text, numbered lists, and unnumbered lists.
Printing
Fixed printing of certain Chinese text.
Fixed print orientation when printing to HP DesignJet 430.
More resolutions are now available when publishing to Web JPG PC3.
Fixed number of copies setting when using the Publish command.
More fixes
Several fixes for the Pyramid command.
Fixed justification of data extracted using the ATTEXT command.
Reworked dialogs to improve crash handling.
Fixed scenarios where the user interface was not scaling properly according to screen size.
Several fixes for working with hatches in the Hatch dialog box.
Fixed the Render commands when using the 'Maintain Aspect Ratio' option and also fixed rendering materials attached to faces of meshes.

Important fixes in IntelliCAD 8.4

The following list details some of the 440+ fixes that were implemented since the IntelliCAD 8.3a release.

Working with files
Several fixes for opening and saving specific drawing files.
WMFOUT fixed for solid hatches.
Text and multiline text
Several fixes for working with the in-place multiline text editor, including: lost italic setting, underline and overline, SHX fonts, and more.
Fixed issue with text styles that used substituted fonts.
Several fixes for stacked text.
Printing
Fixed print stamp issue when entities are assigned a non-default color.
More fixes
Fixed Increment/Decrement button when defining blocks.
Fixed issue with the OLEHIDE system variable.
Several fixes for working with hatches, including an Add option fix and preserving color when editing.
Several fixes for the Find command.
Snapping while grip editing 3d polylines now respects OSNAPZ.
Fixed crash issue when using CUTCLIP with a rectangle.
Fixed viewport display of entities with transparency.
Fixed issue with joining lines and polylines.
Fixed several issues with trimming and extending lines.
Fixed specific crash issue when working with angular dimensions.
Some entities (3D faces) were not visualized in Artisan Rendering; this is fixed.
Fixed issues related to working with entities in NWUCS.
Regeneration issue with PDF underlays during zoom/pan has been fixed.

MicroSurvey CAD 2018 Service Pack 1

Release Date: September 14, 2018

Version: 18.1.4.8026

New Features

Draw AEC Architectural Objects
Draw Walls, Doors, Windows, Openings, Floor Slabs, and Roof Slabs to model 3D buildings
Convert existing linework to Walls or Floor Slabs
Leica COE (Cyclone Object Exchange)
Import or export Leica COE (Cyclone Object Exchange) files, to transfer drawing objects between the two systems.
Export objects drawn in MicroSurvey CAD and import them into Leica Cyclone.
Export objects drawn in Leica Cyclone and import them into MicroSurvey CAD.

Enhanced Features

Powered by IntelliCAD 8.4a
MicroSurvey CAD 2018 SP1 is built on IntelliCAD 8.4a. (MicroSurvey CAD 2018 was built on IntelliCAD 8.4.)
IntelliCAD 8.4a is a maintenance release that contains 225+ fixes since the IntelliCAD 8.4 release. IntelliCAD 8.4a includes critical fixes for running MicroSurvey CAD on the Fall Creators 2017 Microsoft® Windows® update, significant improvements to editing in-place blocks and external references, selecting entities on locked layers, and editing multiline text.
See below for additional details about what's fixed in IntelliCAD 8.4a
Point Cloud Engine
Updated to Leica EpcA API 3.1.
Support for Leica Geosystems Cyclone 9.2.1. Older versions are also still supported.
Support for Leica Geosystems JetStream 1.4.1. Older versions are also still supported.

Important Fixes

  • [D8976] AutoMAP Library - AutoMAP settings could change unexpectedly following a specific sequence of operations
  • [D8935] AutoMAP Library - Descriptions could be inappropriately labeled as a "[group]" code
  • [D8847] AutoMAP Library - Changing a point description did not apply the new description's layer, color and other settings
  • [D9406] AutoMAP Library - Symbol Insertion did not work for codes with a Z linework prefix
  • [D9085] CAD Tools - Changing the layer, color, or other non-geometric properties of smart lines or line labels removes them from the database
  • [D9067] CAD Tools - The BREAKLINE command displayed an error due to a missing file brkline.dwg
  • [D9654] CAD Tools - The MVIEW command may cause a handled exception error in some cases
  • [D9055] COGO - Bearing-Bearing Intersection gives incorrect results when using Azimuths
  • [D8977] COGO - When entering a curve by chord bearing, the radius prompt does not accept other units
  • [D8897] COGO - IPN (Independent Point Number) labels did not appear after storing a new point until the command ended
  • [D8844] COGO - Entering a bearing by selecting a line displays the reverse bearing
  • [D9105] Database - Closing all drawing tabs causes the database reactors to stop, so subsequently editing points will not update the database
  • [D9050] Database - Opening a drawing with the "Open Drawings Using Recover" option enabled causes the drawing to be opened without its database
  • [D8929] Database - The "Update Database from Drawing" command did not work in certain cases when the point did not contain an entry in the Text database
  • [D8795] Database - Some operations could cause a scary but harmless error message "The process cannot access the file because it is being used by another process"
  • [D9377] Export ASCII Lat/Long File - It is not possible to select the Cartesian coordinate system to transform from
  • [D9070] Import ASCII Lat/Long File - It is not possible to select the Cartesian coordinate system to transform to
  • [D9352] Import MicroStation DGN - Using the Open command to import a .dgn file causes the program to terminate unexpectedly
  • [D8783] Import Leica DBX - The DBXMANAGE command can crash if a DBX project containing pictures has been imported into the drawing
  • [D9274] Import Imagery / Bing Maps - A message was added indicating that Bing Maps is not available in demo mode.
  • [D9080] Import Imagery / Global Mapper - Loading WMS Imagery could timeout and fail due to an incorrect timeout period that has been extended
  • [D9076] Import Imagery / Raster Images - The Attach Raster Image command does not display many of the expected raster formats
  • [D8944] Labeling - Auto House Ties have the Text Style and Layer Name settings reversed
  • [D9297] Labeling - Auto House Ties without Arrows have with the Text Style and Layer Name settings reversed
  • [D9666] Labeling - Polyline Bearing/Distance labels that have been erased cannot be re-added
  • [D9668] Labeling - Polyline Bearing/Distance labels that have been moved off-line can revert to on-line
  • [D9023] Labeling - Changing the drawing scale factor did not cause new labels to be drawn with the new size
  • [D8896] Labeling - Changing the drawing scale factor did not cause new labels to be drawn with the new size
  • [D9058] Lot Closure - Pick Both button does not work if the distance does not include a foot symbol
  • [D9036] Lot Closure - Pick All button for a curve gets the incorrect chord bearing
  • [D9035] Lot Closure - Pick buttons do not work with azimuth/bearing in decimal degrees
  • [D8931] Lot Closure - Pick Both button could fail in certain drawings
  • [D9399] Lot Closure - Pick Both button did not work consistently
  • [D9082] Lot Closure - Radial Bearings are listed incorrectly
  • [D9453] Lot Closure - Pick button to select a Delta angle for a curve does not work correctly
  • [D9585] MicroSurvey Transfer - On a 32-bit system, the Upload/Download to FieldGenius commands may look for settings as if its a 64-bit system
  • [D8999] Multities Table - Creating a Multities Table could cause the program to stop responding
  • [D8939] Multities Table - The CAD Pick function would incorrectly populate the table with a 3D instead of 2D distance
  • [D9066] Performance - A slight delay when clicking on smart objects to open the relevant dialog has been corrected
  • [D9066] Performance - A slight delay when ending CAD commands has been corrected
  • [D9368] Performance - The Licensing Options dialog now appears before the program searches for valid licenses so it does not appear hung during this process
  • [D8742] Point Coordinates - Storing points with the EDITP or CONNECT_POINTS commands in a non-world UCS places them at an unexpected coordinate
  • [D9425] Point Coordinates - Adding points with the AUTOP command) to a 2D polyline creates points at z=0 instead of at the polyline's elevation
  • [D9028] Subdivision Design - The House Placement command does not work reliably when dynamically placing the house with your mouse
  • [D9057] User Interface - The Submit Bug Report command does not work
  • [D9060] User Interface - The Submit Feature Request command does not work
  • [D9596] User Interface - The Thaw Layer command shows incorrect help text on the status bar
  • [D9610] User Interface - In the Legacy workspace, the Point Cloud menu did not appear
  • [D9592] User Interface - In the Legacy workspace, the Help command did not work

Important fixes in IntelliCAD 8.4a

The following list details some of the 225+ fixes that were implemented since the IntelliCAD 8.4 release.

Performance
Critical fixes for running IntelliCAD on the Microsoft® Windows® 10 Fall Creators 2017 update.
Fixed performance issues when copying entities and selecting entities in a drawing with groups.
Working with files
Fixed several issues when exporting to .bmp files.
Editing and selecting entities
New CYCLE command (Ctrl+W) toggles selection cycling on and off. When turned on, left-click overlapping entities to cycle through overlapping entities under the cursor. When turned off, CTRL + left-click cycles the selection.
New PROPS alias added for the ENTPROP command.
Fixed the display of the Properties pane when selecting multiple custom entities.
Text
Improved multiline text, including: vertical spacing, bullet lists, semi-transparency for mtext editor background, and more.
Fixed single-line text when the rotation angle was not correct.
User Interface
Now you can reset to default customization settings or restore settings from a backup using the Customize command. Click >> in the Customization area of the Customize User Interface dialog box.
Using the Customize command, customization is better supported for the Application button, Quick Access toolbar, and Ribbon Tab selectors.
Define the color and linetype of the rubberband. To change the color, use the RUBBERBANDCOLOR system variable, or using the Options command, click the Display tab, click Color Scheme, and for 2D model space, select the Rubberband item. To change the linetype, use the RUBBERBANDLT system variable.
System Variables
LISPAUTOREDRAWFREQ added: Sets the frequency of automatic view update during LISP operations [Hz]. Default value is 0.333. If LISPAUTOREDRAWFREQ is zero, auto update is disabled.
RUBBERBANDCOLOR added: Sets the color of the rubberband. Default color is RGB:248,153,30 (orange).
RUBBERBANDLT added: Sets the linetype of the rubberband. Default linetype name is "Continuous".
WSUPDATEALL added: Set to 1 to update all workspaces with an imported customization (e.g. when using the MENULOAD command); set to 0 to update the active workspace only. Default value is 1.
Fixed SELECTIONANNODISPLAY.
More fixes
Fixed linetype selection in the Multiline Styles Manager.
Fixed issue when using grips to change the scale of a helix.
Fixed several issues for working with the REFEDIT command.
Improvements to the Paste Special command.
Fixed issue when using the ETRANSMIT command.
Fixed specific display issue for image transparency.
Fixed selection of entities on locked layers.
Fixed issue with dimension styles when editing an external reference.
Fixed issues related to the MLEADERCOLLECT command.
Fixed QSELECT issues when specifying by color and Boolean values.
Several issues fixed for working with blocks.
(2 vote(s))
Helpful
Not helpful

Comments (0)