Knowledgebase: MicroSurvey CAD 2018
MicroSurvey CAD 2018 Frequently Asked Questions
Posted by Brian Sloman on 25 October 2017 02:38 PM

Q) What drawing formats does MicroSurvey CAD 2018 support? Can I share drawings with other programs like AutoCAD or Civil 3D?

A) Drawings created by the latest AutoCAD 2018 products can be opened directly in MicroSurvey CAD 2016. By default, new drawings are created in .dwg 2013 format and can be opened with AutoCAD 2013 and newer. You can do a "Save As" down to any older .dwg or .dxf format for compatibility as far back as AutoCAD 2.5 (released in 1986).


Q) I've spent considerable time setting up my display settings to make MicroSurvey CAD 2018 appear just the way I want it, customizing toolbars, aliases, and hotkeys. Can I copy this configuration to another computer without having to set it all up again?

A) Yes! This is easily be done by using the Settings Migration Wizard command to export your current settings, and import it into the other computer.  Go to MsTools > Migration Wizard, then choose the Export or Import option, and specify which options (or all of them!) you want to save/restore.  NOTE: You cannot transfer profiles between different versions of MicroSurvey CAD (for example, from 2015 to 2018).


Q) When I create points, there are two point number labels on the screen - one seems to be normal text, but the other one isn't, and I can't erase it. What's up with that, can I get rid of them?

A) One of the labels is indeed a text entity - so you can change it's layer or color, erase it, move it, etc. The other one is what we call an Independent Point Number label. It is not a CAD entity, so it can't be erased/moved/printed/etc, think of it more as a tooltip for your points, as you zoom in or out the point label will stay a readable size on your screen. To toggle the Independent Point Numbers off, you can do any of the following:

  1. Type the IPN at your command line to toggle them on or off.
  2. Go MsPoints > Independent Point Numbers > Independent Point Numbers (IPN) to toggle them on or off.
  3. Use the MS IPN toolbar, which has three green buttons: one with an N, one with a D, and another with an E. You can easily click the N button to toggle the IPNs on or off. (The D and E buttons work the same but with Descriptions and Elevations).

Q) Can I change the default cursor crosshairs to extend across the full screen?

A) Yes! Go to Tools > Options, then click on the Crosshairs tab. The default cursor size is 5% of your screen, but you can change this to 100% or any other value. You also need to pick on the option "Pointer defaults to crosshairs" to turn this on.


Q) When I run some commands, a pop-up window comes up with different options for the command. Can I get rid of this?

A) Yes! Go to Tools > Options, then click on the Display tab, and uncheck the Display Prompt Boxes option.


Q) When I run some commands, a faint line appears when I move the mouse at 90-degree angles. What the heck is this? And can I turn it off?

A) This is a for Polar Snapping. It lets you snap a second point at pre-set angles from the first point, and by default it is set with 90-degree increments. When you get this Polar Snapping line to appear, you can also type a distance at your command line, and the next point will be selected at that distance along the highlighted Polar Snapping line. You can turn the Polar Snapping on or off, or change the angles it uses, by right-clicking on the word "POLAR" in your status bar then left-clicking On/Off/Settings.


Q) Can I change the background color from Black to White, or any other color?

A) Yes! Go to Tools > Options, then click on the Display tab, and set the "Graphics screen color" option to either White (color 7). Note that if you do this, you'll probably also want to change some of the following additional options, because the default light colors show up really well on the black background but not so well on a white background (especially the yellow items):

  • Independent Point Number labels. Go to MsPoints > Independent Point Numbers > Change IPN Color and set the colors as desired, you may want to use orange (color 40) instead of the default yellow for the point numbers as it will show up better on the white background.
  • Point Elevation Labels. Go to MsAnnotate > Labeling Defaults > Elevations and set the Layer Color as desired, you may want to use orange instead of the default yellow for the point numbers.
  • Snap Markers. Go to Tools > Options, then click on the Snapping tab, and set the Snap Marker color as desired, you may want to use orange instead of the default yellow.
  • Automap Library Colors. If you've configured an Automap Library, you may also want to change some of the settings in it to use darker colors which will show up better on the white background. Go to MsTraverse > AutoMap System > AutoMap Library to edit your library file.

Q) Can I setup MicroSurvey CAD to use Scroll Bars for panning within the drawing?

A) Yes! Go to Tools > Options, and on the Display tab turn on the "Show scroll bars" option.


Q) Can I change the mouse buttons, so that the middle mouse button brings up the list of entity snaps?

A) Yes you can, but we recommend leaving it as is. To change the behaviour of the middle mouse button, type the command MBUTTONPAN and set it to On for panning and zooming or Off for the Entity Snaps popup menu. Note, if you leave this set to Off then it is much easier to pan and zoom in your drawing, and you can still bring up the snaps menu by holding down Shift and Right-Clicking the mouse.


Q) When I print my drawing, all of the dashed/dotted/etc lines all print out as continuous. Can I get them to print out‚ dashed/dotted/etc?

A) Yes! After going to File > Print, click on the Advanced tab, and select a proper Print Style Table. Using the "None (uses Default)" option may not print the linetypes and lineweights. Select "Icad.ctb" for printing in color, or "Monochrome.ctb" for printing in Black & White. Click Yes if you are asked "Assign print style table to all layouts?"


Q) Can I setup my printer/plotter to use different colors in the drawing to control the thickness, printed color, or other properties‚ of the printed lines?

A) Yes! This is controlled through the Print Style Table. Go to File > Print, click on the Advanced tab, and select a Print Style Table to edit. Select "Icad.ctb" for printing in color, or "Monochrome.ctb" for printing in Black & White. Click Yes if you are asked "Assign print style table to all layouts?". Then press the Edit button. The Print Style Table Editor window that opens is split into two main sections - on the left side is a list of colors 0-255 (representing color that can exist in your drawing), and on the right side is the definition for how entities with that color will be printed. Highlight the color you want to change on the left, then specify the printed color, lineweight, and other options on the right. After you have finished configuring it as desired, press the Save As button to assign it a new filename (or press OK to save it without changing the filename). Finally, when you're back on the Print dialog make sure that the "Print lineweights" option on the Advanced tab is turned on.


Q) When I try to scroll back through my command line history, it seems fairly short. Can I increase how much is kept to scroll back through?

A) Yes! Go to Cad Tools | Options, then click on the Display tab and change the "Command lines to track" option as desired. The default value is 256 lines, but you can increase this up to a maximum of 500.

(2 vote(s))
Helpful
Not helpful

Comments (0)