Knowledgebase
MicroSurvey CAD 2020 Release Notes
Posted by Jeran Hopfe on 31 October 2019 08:46 AM

MicroSurvey CAD 2020 Release Notes


Release History

MicroSurvey CAD 2020 (20.0.6.460) - October 31, 2019


Important Notes

Activating or Updating your USB License Key

If you are licensing MicroSurvey CAD for the first time you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2019 thru 2008, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2005 or previous, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MicroSurvey CAD, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MicroSurvey CAD service pack updates. For a detailed explanation of MicroSurvey's Annual Maintenance Subscription (AMS) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your AMS has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the AMS by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date.

If your AMS has expired, you can phone us at 1-800-668-3312 or 1-250-707-0000 to renew it. Without a current maintenance subscription plan, you may not be able to update your key to work with the new version.

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users need to download a copy of the MicroSurvey Transfer program to simplify the process of transferring FieldGenius projects between your data collector and MicroSurvey CAD.

If you have a copy of MicroSurvey Transfer already installed from use with MicroSurvey CAD 2010 or previous, you will need to update it to recognize MicroSurvey CAD 2013 or newer. Previous versions of MicroSurvey Transfer will not show MicroSurvey CAD 2013 or newer as a sync option in the Options screen.

The MicroSurvey Transfer program has not changed since the release of MicroSurvey CAD 2013. This is only necessary for users who are setting up communications between FieldGenius (any version) and MicroSurvey CAD (2013 or newer) for the first time.

MicroSurvey Transfer can be downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft or from the MicroSurvey helpdesk.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

The MicroSurvey Network License Server program has not changed significantly since the release of MicroSurvey CAD 2008. This is only necessary for users who are setting up a MicroSurvey CAD 2008 or newer network license for the first time.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey CAD 2020 is compatible with 64-bit versions of the following operating systems:

  • Windows 7 SP1 (with latest Windows Updates)
    • Please see the article here regarding End of Support for Windows 7
  • Windows 8.1 (with Update 2919355)
  • Windows 10 version 1507 or higher

MicroSurvey CAD 2020 is not compatible with any 32-bit operating system.

A free USB port is required for connecting the USB License Key (to either the local workstation or the license server, as appropriate).

MicroSurvey CAD 2020 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, aside from a compatible video card for the 3D Rendering engine. Please refer to this online article for a list of compatible video cards.

Full Administrator rights are required to install MicroSurvey CAD 2020, but it can be run by limited user accounts.

Important Announcement re. 32-bit MicroSurvey Applications

MicroSurvey has announced that it will no longer produce new 32-bit versions of MicroSurvey CAD and other products, effective November 1, 2018.

Please refer to this online article for additional details.

Software Requirements

MicroSurvey CAD 2020 Ultimate/Studio requires that the following prerequisite software packages be installed to work with certain point cloud formats:

  1. Leica Cyclone 9.1.1 or newer is required (current version is recommended) to import and view Cyclone point clouds
  2. Leica JetStream 1.0.1 or newer is required to import and view JetStream point clouds
  3. Leica Client License Manager (CLM) 1.4 or newer is required to license Cyclone or JetStream

Please visit www.leica-geosystems.com to download these Leica Geosystems products. A registered account is required.

Leica Cyclone and Leica JetStream are licensed independently from MicroSurvey CAD, by entering an entitlement certificate ID into the Leica CLM application.

Leica Cyclone does not have to be licensed. MicroSurvey CAD will be fully functional with an unlicensed version of Cyclone Viewer.

Windows Windows 7, Windows 8.1 and Windows 10 Notes

Run as Administrator

You must run the program at least once elevated with "Run as admininstrator" access, even if you are already logged in with an "Administrator" account on the computer.

After this is done, it can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MicroSurvey CAD 2020 icon.
  2. Choose "Run as administrator".
  3. Select "Yes" on the "User Account Control" dialog when prompted to allow the program to make changes to your computer.

What's This? Help

If you wish to use the "What's This? Help" feature, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note that the main Help files will work without this update.


Online Resources

Release Notes

For a current version of this document, please visit the MicroSurvey CAD 2020 Release Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MicroSurvey CAD 2020 Known Issues topic in our online helpdesk.

Training Movies

For over 16 hours of training movies that you can watch online or download for offline viewing, please visit the Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at helpdesk.microsurvey.com where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are not answered in your Help file and Manuals.

For technical support, please visit our helpdesk at helpdesk.microsurvey.com to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Annual Maintenance Subscription (AMS).

To purchase or renew your AMS, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000, phone your local MicroSurvey dealer, or visit our online store at http://store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to comment and vote on other users' feature requests, please visit our Feature Request Forum at http://feedback.microsurvey.com.


MicroSurvey CAD 2020

Release Date: October 31, 2019

Version: 20.0.6.460

New Features

Powered by IntelliCAD 9.2
MicroSurvey CAD 2020 is powered by the latest IntelliCAD technology, IntelliCAD 9.2.
See below for additional details about what's new and fixed in IntelliCAD 9.1 and 9.2.
Arc Labeling with ArcAlignedText
Arcs can now be labeled with an ArcAlignedText object instead of multiple text objects
The following commands can now create an ArcAlignedText label: Label on Arc, Manual Label on Arc, Text on Arc.
The Labeling Defaults: Curves command has a new option to create ArcAlignedText labels.
ArcAlignedText labels can be edited using the ARCTEXT command.
ArcAlignedText labels can be moved using the Rotate Text and Slide Text commands.
ArcAlignedText labels can be selected in the Lot Closure command.

Enhanced Features

Coordinate System Engine
The CS-Map coordinate system engine has been upgraded and includes over 125 new coordinate systems.
Areas with the most additions include Africa (Namibia and Morocco), Asia (Korea and Malaysia), Australia/New Zealand (GDA2020 systems), Europe (Several zones), and US OCRS systems.
A common package is now shared by MicroSurvey CAD, STAR*NET and FieldGenius so future changes made by MicroSurvey for one product can be efficiently integrated into the other.
Note, certain geoid models and grid shift files must be downloaded separately from the MicroSurvey Helpdesk or applicable government agency.
Point Cloud Engine
Updated to Leica EpcA 3.4.
Supports Leica Cyclone 9.4, Leica JetStream 1.5, and Leica Cyclone REGISTER 360 1.5. Older versions are also still supported.

Important Fixes

  • [D09281] AutoMAP Library - After deleting the last code from the current library the program may terminate unexpectedly or generate an error message.
  • [D10291] AutoMAP Library - After creating a New Library the previously displayed block preview is not cleared.
  • [D08226] Active Traverse Editor - The Adjust Traverse Scans command can cause the point cloud(s) to unexpectedly disappear.
  • [F03968] Assistant - The Assistant is now turned off by default. It can still be accessed via the Assistant command.
  • [D10314] Export ASCII - Exporting an ASCII file with a Coordinate Transformation set can cause incorrect unit scaling.
  • [D10354] Import DBX - Importing a DBX project while the Active Coordinate Editor is open can cause unexpected error messages.
  • [F03924] Interface - Some color and appearance defaults have been changed.
  • [T02361] Installer - The Uninstall Survey questionnaire is now suppressed when installing an upgrade.
  • [D10266] Labeling - The Bearing Seconds Rounding option set to 60 can cause unexpected results, for example 203°59'45" rounds to 203°60' not 204°00'
  • [F00952] Lot Closure - When deleting a lot closure, the corresponding report file "lc_name.txt" is now also deleted.
  • [D10275] Lot Closure - The Lot Closure Report now honors the "List E,N (X,Y) Format" system toggle.

New Features in IntelliCAD 9.1

Performance
The flood fill hatch algorithm was refactored for improved performance.
Improved performance when snapping to .pdf files, blocks with many nested entities, and point clouds.
Opening external reference files is now faster.
Improved performance when selecting by window.
Working with files
Attach digital signatures to .dwg files, and validate attached digital signatures.
Attach version 2019 .rvt/.rfa files and draw more AEC entities such as stairs, railings, and steel.
User interface
In the command bar, click keywords to select options when you run a command. As a result, prompt boxes have been turned off by default. To turn them on, go to Tools > Options > Display.
When you start IntelliCAD, a Start Page displays automatically where you can quickly open files or choose from other common tasks.
Click Toggle Clean Screen On/Off in the status bar to quickly hide most user interface items so that only model and layout tabs, the menu bar and the status bar are displayed on the screen. Click again to reverse the effects.
Add blocks to tool palettes, which is similar to creating a stencil for quickly selecting and adding anything from shapes to complex blocks to your drawings.
To customize the user interface, use the Customize User Interface (CUI) command. The Customize (CUSTOMIZE) command is now used for customizing tool palettes into groups and importing and exporting tool palettes.
Set the transparency of the Properties pane, Tool Palettes pane, and Explorer Palette pane.
Reset the ribbon (for IntelliCAD versions that have a ribbon), menus, toolbars, aliases, keyboard shortcuts, and double-click actions to their original settings using the Reset User Interface (RESETUI) command.
The new Save Workspace (WSSAVE) command is a shortcut for saving a workspace and its settings.
The new File Tab and File Tab Close commands are shortcuts for turning the display of file tabs at the top of the drawing on or off.
The Close All Others (CLOSEALLOTHER) command closes all drawing windows except the current one.
Creating entities
The new Gradient command is a shortcut for using the Hatch and Gradient dialog box to add gradients to entities.
Convert entities to three-dimensional meshes or surfaces using the Convert to Mesh and Convert to Surface commands.
Use the FM3DCONVERT and FMEXTRUDE commands to convert more types of three-dimensional entities to other types of three-dimensional entities.
Selecting and modifying entities
New selection grips allow you to quickly move, scale, and rotate all selected entities. These types of grips can be helpful for schematic drawings where precise scale or sizing is not required.
Viewing entities
Use the new List Viewport Scale command to obtain the scale of a selected viewport on a Layout tab.
Use the new Synchronize Viewport command to synchronize all selected viewports to use the zoom factor of a master viewport that you select.
Change the display of edges of three-dimensional entities using these new commands:
The Edge command controls the visibility of selected edges of 3D faces.
The Show Edges command displays all edges of selected 3D faces, meshes, and polyface meshes.
The Hide Edges command hides all edges of selected 3D faces, meshes, and polyface meshes.
Blocks
Create and edit blocks using the new Block Editor, which allows you to draw and save a block in-place, directly in the drawing area.
Print
Print directly to PDF, including support for many sheet sizes and PDF options.
Publish to PDF, including support for many PDF options.
Select from new sheet sizes included for printing to raster images.
More features
Use the new System Variable Manager to view and edit all system variables and their values.
Choose more formatting styles for lists of multiline text. Just start typing, for example, type (1) to start a numbered list with parentheses.
Open the standard Microsoft® Windows® Notepad application using the Notepad command.
New and changed system variables
New system variables: 3DOSMODE, BKGCOLORBEDITOR, BLOCKEDITOR, COLORXBEDITOR, COLORYBEDITOR, COLORZBEDITOR, DISABLEDIGITALSIG, GRIDCOLORMAJORBEDITOR, GRIDCOLORMINORBEDITOR, LOGFONTSERVICE, PDBOFFSETAUTOUPDATE, SHOWMESHEDGES, SIGWARN, STARTMODE, STEELTABINDEX, SUBDIVIDELEVEL.
Changed system variable: EXPPALETTES (default changed to 1), SHORTCUTMENU (default changed to 3), and SKETCHMODE (new value added, 4).
Removed system variable: LINESTARTPOINT.

New Features in IntelliCAD 9.2

Performance
Improved memory consumption when working with raster images.
Improved memory consumption and speed when using IntelliCAD Explorer for blocks.
User interface
Use the Quick CUI command to display a small version of the Customize User Interface dialog box so you can quickly add commands to the Tool Palettes pane.
On the status bar you can now toggle Cursor Type (regular or gunsight) and XOR Cursor (cursor color is inverted when overlapping an area of the same color).
The Start Page now has drawing previews.
Right-click a drawing tab to see options for the tab.
Creating entities
Draw curtain walls, studs, joists, track, and wood.
Convert entities to walls and slabs.
Create elevation lines and section lines.
The boundary option is now available for -HATCH.
Selecting and modifying entities
Use the Selection Filter command to display the Selection Filter pane, which displays all entities in the drawing and allows you to filter and select entities by layer, color, entity type, and linetype.
Click the Selection Cycling tab in the Options dialog box to specify which method you want to use when selecting entities that overlap.
Use the Overkill command to delete or combine duplicate or overlapping entities in a drawing, reducing the drawing's file size and complexity.
If you choose Undo or Redo from the ribbon toolbar, you can view and also select a range of actions.
Polygons, rectangles, and break lines have additional grips and properties for smart editing.
Text
Work with multiline text using right-to-left fonts.
Create additional types of lists for multiline text.
Print
Publish drawings to DWF and DWFx.
Use the Auto Publish command to automatically create electronic files (.dwf/.pdf) from the current drawing.
New and changed system variables
New system variables: AECAUTOUPDATE, AUTOMATICPUB, AUTOPUBLISHPATH, BLOCKEDITLOCK, CROSSHAIRMODE, OVERKILLMODE, OVERKILLTOLERANCE, OVERKILLTOLARCCHORD, OVERKILLTOLARCENDPOINT, REFPATHTYPE, SELECTIONCYCLING, SJTABTINDEX, TASKBAR, WOODTABINDEX, and XREFNOTIFY.
HPPREVIEW renamed to HPQUICKPREVIEW.
TOOLPALETTESSTATE renamed to TPSTATE.
WSUPDATEALL new valid range 0 to 2.

Important Fixes in IntelliCAD 9.1

The following list details some of the 800+ fixes that were implemented since the 9.0a release.

Working with files
Several fixes for working with point clouds.
Fixed issue when exporting to .bmp files.
Fixed issue when autosaving password-protected drawings.
User interface
Several fixes when using tool palettes.
Fixed issue when importing specific .mnu files.
Toggle Viewport Lock/Unlock added to the status bar for layout viewports.
Editing and selecting entities
Many fixes to working with entity properties.
Several fixes for editing multiline text, including undo/redo results, list indents, and oblique angles.
Fixed issue with JOIN command for lines and arcs.
Fixed issue when using entity snaps, including Nearest Entity Snap, and Endpoint Snap with multilines in external references and blocks.
Fixed issue when temporary ORTHO mode remains active.
Several fixes for entity grips, including when working with dynamic blocks.
Fixes for FILLET and CHAMFER commands.
Fixed selection issues, including previous selection when using pickfirst selection and when using Window or Cross Selection for a block reference on a layer that is turned off.
Several fixes for undoing operations.
Hatches
Fixed issue when hatching an island during hatch creation.
Fixed issue when removing hatch boundaries.
Fixed hatches created while using the REFEDIT command that lost associativity after REFCLOSE.
Fixed issue with "Inherit properties" option.
Printing
Fixed issue with print transparency when using "PublishToWeb JPG" and "PublishToWeb PNG".
Fixed issue with POINTCLOUDPOINTSIZE system variable when printing to a WinGDI-based device.
More fixes
Many fixes for working with fields.
Double-clicking a dimension now starts the DDEDIT command.
Fixed issues with the LIST command.
The IMAGECLIP command now supports selection of an existing polyline.
The Linetype dialog now saves the previously loaded .lin file between sessions.
The FINDTEXTINT now applies to attributes.
Annotation scales that are in use can now be deleted.
Added logging for font substitutions.
Select All (Ctrl+A) now works in the Linetypes dialog box.
Several fixes for working with helix entities.
Fixed issue when freezing layers in a current viewport and creating new viewports.

Important fixes in IntelliCAD 9.2

The following list details some of the 900+ fixes that were implemented since the 9.1 release.

Working with files
Several fixes when exporting 3D solids to .sat files.
Fixed issue when exporting blocks to .bmp files.
Fixed issue with opening and attempting to save read-only files.
User interface
When viewing the properties of a tool on the Tool Palettes pane, a preview of the tool icon now displays.
Fixed memory leak in Properties pane for reported updates of Microsoft Windows 10 operating systems.
Editing and selecting entities
Scale option fixed for the Sweep command.
Fixed scaling of annotation entities when the current annotation scale is changed.
Fixed issue when trimming ellipses.
Fixed display of the gunsight cursor when the PERSPECTIVE is turned On.
Fixed Undo error after using BEDIT.
Fixed issue with Properties pane when modifying fields.
Text
Fixed display of justified text.
Fixed issues with changing text styles.
Fixed several issues with lists, stacked text, and underlined/overlined text.
Fixed issues when converting fields to text.
Fixed issues when combining paragraphs.
Printing
Fixed issue when printing after previewing in 3D Hidden or Realistic.
Fixed reported issues when previewing or printing to specific printers.
Fixed scenario when printing with transparency was ignored.
More fixes
Fixed issue with visualizing 3D solids in Hidden and Shaded modes.
Fixed disappearing blocks after discarding changes.
Fixed color boundary of text with specific lineweights.
Fixed several issues when displaying 3D solids.
Fixed response error when drawing specific hatches.
Fixed display of progress bar when running multiple commands.
Highlighting fixed for the Linetypes dialog box.
Fixed incorrect view in a viewport with rotated UCS.
Several fixes for specific entities when using the LIST command.
(1 vote(s))
Helpful
Not helpful

Comments (0)