Knowledgebase
MSCAD 2008 SP1.3 v8.1.3 Release Notes
Posted by Brian Sloman on 23 July 2008 02:58 PM

Release History

8.0.0 (Release Version) - October 3, 2007

8.1.0 (Service Pack 1.0) - December 19, 2007

8.1.1 (Service Pack 1.1) - January 19, 2008

8.1.2 (Service Pack 1.2) - May 8, 2008

8.1.3 (Service Pack 1.3) - September 9, 2008


Important Notes

Updating your USB License Key to 8.1.3

You may or may not be required to update you USB key to run MicroSurvey CAD 2008 SP1.3. Any key registered with 8.1.0, 8.1.1 or 8.1.2 will run 8.1.3.

For a detailed explanation about how we use product version numbers and USB keys, you can can refer to the following article.

If your Maintenance Subscription has not yet expired, you can use the License Manager to update your key to work with the new version. We recommend installing and using the updated License Manager to do this, which can be installed from your MicroSurvey CAD 2008 SP 1.3 installation disc or downloaded from our online Helpdesk system.

If your Maintenance Subscription has expired, you can phone us at 1-800-668-3312 to renew it. Without a current maintenance subscription, you will not be able to update your key to work with the new version. You can confirm the expiry date for the maintenance plan by going to the About screen found in the Help menu.

Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may have different expiry dates.

Please refer to the following topic for detailed information about updating your key.

Retaining your Custom Toolbars

The first time you run MSCAD after installing the update, you will be prompted to reset to newer versions of the menus and toolbars. If you have created any custom toolbars / menus / aliases / hotkeys, be sure to answer No to this message, or else your custom toolbars will be lost! You should also be sure to export any of your customizations via the Customize command, so that you can re-import them again if needed.

Advanced Training Movies

MicroSurveyCAD 2008 includes over 11 hours of training movies which can be viewed from the Help file.  Most of these movies are automatically installed with the full version of the program, but additional movies on advanced features such as Digital Terrain Modelling and Road Design must be downloaded separately from our online Helpdesk system.

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users need to download a copy of the MicroSurvey Transfer Program to simplify the process of transferring FieldGenius projects from your data collector into MicroSurvey CAD 2008.

The MicroSurvey Transfer program has not changed between MicroSurvey CAD 2008 8.0.0 and MicroSurvey CAD 2008 8.1.3. This is only necessary for users who are setting up communications between FieldGenius (any version) and MicroSurvey CAD 2008 for the first time.

MicroSurvey Transfer can be installed from your FieldGenius installation disc or downloaded from our online Helpdesk system.

A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software. The MicroSurvey Network License Server program has not changed between MicroSurvey CAD 2008 8.0.0 and MicroSurvey CAD 2008 8.1.3. This is only necessary for users who are setting up a MicroSurvey CAD 2008 network license for the first time.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey CAD 2008 is compatible with 32-bit editions of Microsoft Windows 2000, Microsoft Windows XP (SP2 or SP3), Microsoft Windows Vista (Release or SP1). 64-bit editions of Windows XP and Windows Vista have NOT been tested.

MicroSurvey CAD 2008 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, except for a compatible video card for the 3D  Rendering engine. Please refer to the following webpage for a list of compatible video cards, as indicated under the "OGL" column:http://developer.techsoft3d.com/hoops/hoops-visualize/graphics-cards/

Windows Vista Users

Vista: Run as Administrator Once

If installing on Windows Vista you must run the program with "Elevated Admininstrator" permissions enabled the first time MicroSurvey CAD 2008 is run, even if you are already logged in as an Administrator. Once this is done once, MicroSurvey CAD can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MicroSurvey CAD 2008 icon.
  2. Choosed "Run as Administrator"
  3. Open or create a new scene.

Vista: What's This? Help

If you use the MicroSurvey CAD "What's this Help" feature under Windows Vista, you will need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note, that the main MicroSurvey CAD Help file will work without this update.

Vista: Help Movies

To play the MSCAD 2008 help movies under Windows Vista, you must open up the Help file by going to Start | Programs | MicroSurvey | MicroSurvey CAD 2008 | Help. If you open the help file from within MSCAD's Help pulldown menu, then Vista's security policies prevents the help file viewer from launching the movie player.

Known Issues

For a list of known issues please visit the MicroSurvey CAD Known Issues topic in our online helpdesk.


8.1.3 Notes

Release Date: September 9, 2008

New Features

  • Import/Export LandXML Files
    • Please refer to the 8.1.2 Notes for information about the beta version of our new LandXML import and export commands. Work continues on these two new features and we expect to officially include them in MicroSurvey CAD 2009.

Fixed Items

  • Import RW5/RAW Files
    • Instrument Heights from RW5/RAW files were being processed incorrectly in some situations where only note records such as check shot data was recorded between setups.
    • Importing a RW5/RAW file containing any comment lines more than 128 characters would cause MSCAD to crash. Comment lines are now truncated at a maximum length of 128 characters in the Active Traverse Editor.
    • The last character in any Comment Record was being truncated off so it was an incomplete record when viewed in the Active Traverse Editor.
  • Audit Database / Rescale Complete Drawing
    • The Audit Database command could cause the direction of arcs originally drawn in MSCAD 2005 to be reversed. For example, the CAD Curves Dialog would report that a 90 degree arc was instead 270 degrees.
    • The Rescale Complete Drawing command could cause any arcs which were incorrectly audited (see above) to be incorrectly redrawn, matching the incorrect information shown in the CAD Curves Dialog.
    • The Audit Database command could cause MSCAD to freeze in some projects during the "Testing Line/Arc database...." phase. Note that if you have experienced this, this was due to an error in the testing process, not due to an error in your database.
  • Helmerts Transformation
    • The Helmerts Transformation command in MSCAD 2008 could not process as many data points as MSCAD 2005 and previous versions (only 500 instead of 5000), and processing more than 500 points was resulting in a confusing "No pairs are entered, Program exits without processing Helmerts Transformation" message. You can again process up to 5000 points, and processing more than this will result in a clearer message.
  • Import LDD / Civil 3D Files
    • The LDD / Civil 3D Import commands would not allow you to select an .MDB file.
  • Raster Images
    • Some Raster Image commands were missing in the 8.1.2 Standard version.
  • Help Movies
    • Several help file movies had audio problems such as skipping, crackling, and other noises during playback in certain flash players. New versions of these movies are included only in the Full installation package, the Patch installation package does not include any movie files.

8.1.2 Notes

Release Date: May 8, 2008

New Features

In this service pack we've included a beta version of our LandXML import and export. Work continues on these two new features and we expect to officially include it in MicroSurvey CAD 2009.

For those of you wanting to quickly transfer points and smart lines and arcs between drawing will find the LandXML export and import functions to be very useful.

We will continue working on adding support for alignments and profiles and surfaces.

Landxml_in_temp:

You should be able to take any LandXML file and import these 3 types of data: CgPoints, PlanFeatures, Parcels and surfaces.

The importing should do this:

  • In the dialog, even though CgPoints is shown with a check box they will always be imported into the drawing as coordinate points (point protection should pop up as necessary).
  • In the dialog, even though there is no mention of PlanFeatures, they will always be brought into the drawing as smart lines/arcs
  • Parcels will be brought in the drawing as lots (the check box in the dialog should be honoured). The first element that it finds in each parcels will be set as the ‘front’ and all other elements will be the ‘left’
  • Surfaces will be brought in your drawing as either 3DFACES or Polyface meshes (the check box in the dialog should be honoured). Note: they will not be brought into Quicksurf memory.
  • *** Important *** - Use this at your own risk. This feature is in a beta state and careful anaylysis of the imported data should be done if used.

LandXML_out_temp:

You should be able to take an MSCAD drawing that contains any or all of the following 3 types of data: Coordinates, smart lines/arcs, and blocks/lots.

The exporting should do this:

  • In the dialog, even though CgPoints is shown with a check box they (ie, the MSCAD coordinate database) will always be exported (as CgPoints).
  • In the dialog, there is no mention of smart lines/arcs, but they will always be exported (as PlanFeatures).
  • Blocks and lots will be exported as Parcels (the check box in the dialog should be honoured).
  • *** Important *** - Use this at your own risk. This feature is in a beta state and careful anaylysis of the exported data should be done if used.

Updated Features

  • None

Fixed Items

  • MsModeling | View Options | Surface Zoom is currently running the SPLAN command, it should be running SZOOM.
  • MicroSurvey Project Manager now behaves similar to previous versions.
  • RTS command had a confusing option to enter the shift deltas. These ambiguous prompts were made more intuitive. Instead of entering X,Y,Z for the shift you are now prompted for Northing, Easting and Elevation.
  • Notes for points imported from FieldGenius could lose their notes when the raw file was recoordinated.
  • MsDesign and MsModeling toolbars should only be in Premium.
  • Basic Demo Install would fail on first run.
  • Basic build does not run in demo mode.
  • Save As or Save commands would ignore the default DWG format set in the Options dialog.
  • AutoRoute - Deleting POT is not consistent, this has been improved.
  • AutoRoute - Edit or enter a vertical design alignment. - the GRADE option can not be used.
  • AutoRoute - Labeling Report not formated correctly.
  • AutoRoute - General fixes to labeling, especially with NewPoint and ExistingPoint.
  • AutoRoute - Fixed problems with LWPolylines.
  • Featurelist Files Conflict When multiple FG Projects are Imported.
  • Importing LISCAD files could cause MSCAD to crash, or cause the point numbers to not get read correctly.
  • Raster - Some large images would not display when loaded.
  • Raster - Some raster files inserted with MSCAD 2005 would not display in 2008.
  • Raster - Zooming in on raster images could disappear from the screen.
  • Raster - Cannot attach images that have been detached.
  • Network - Eliminated lag issues that could occur when executing commands and drawing saves with projects opened over a network.

8.1.1 Notes

Release Date: January 19, 2008

New Features

  • None

Updated Features

  • None

Fixed Items

  • TDS or FieldGenius raw file import could sometimes not set the instrument height correctly during raw file import or SyncWizard import. This bug was introduced in Service Pack 1.
  • Made improvements to support LWPolylines in the alignment routines.
  • General fixes for labeling reports to remove formatting errors.
  • Opening lot closure files created with older version could generate an error RE88CC12.
  • Compute Stakes would only allow integers only for the offsets.
  • Labeling Defaults and AutoMap - added the ability to use characters in layer names. The following is a list of allowed layer names: 0123456789abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ!#$%&'()[email protected][]^_{}~ and spaces.

8.1.0 Notes

Release Date: December 19, 2007

New Features

  • When using a Network License, you can now connect multiple USB keys containing network licenses to one server (for example into a USB Hub) and the workstations will be able to pull licenses from any available key.
  • When using a Network License, you can now enter a list of servers (separated by a space, comma, or semicolon) and the MSCAD workstation will now scan through each of the servers in the list to get an available license from one of them.

Updated Features

  • Individual drawings can now be associated with various GIS feature list files. In MSCAD 2008 8.0.0 a link to one specific feature list file was maintained by the program. This was changed from a system setting to a project setting and is now recorded in the project’s database file.
  • Performance in projects linked to a GIS Feature List File has been sped up significantly.
  • Searching within the Help file has been improved to show more topics.
  • The License Manager application has been improved to be easier to use, and to provide more detailed feedback if a key can not be updated for any reason.

Fixed Items

Cad Engine

  • Changes made to the Support Paths in Cad Tools | Options were not being retained, so any customizations would revert back to their default settings.
  • A memory leak related to raster images was fixed. This would cause the amount of memory used by MSCAD to increase every time a drawing containing rasters was saved, leading to eventual slowdown and potential crashes due to a lack of available system resources.
  • Drawings from MSCAD 2005 containing raster images would sometimes no longer display the raster image when loaded into MSCAD 2008 8.0.0.
  • Drawings from MSCAD 2005 containing raster images would sometimes crash when printed or when a print preview was displayed.
  • The DWF Export routine was not working correctly with the default installation setup.
  • You can now Print Selection when printing from the RTF Log File Viewer.
  • Print offset does nothing. Entering any values in print offset doesn't affect print preview.
  • When printing a drawing at 1 to 1 scale, the actual print would be larger than it should be on large prints.

MicroSurvey Commands

  • Drawings containing horizontal or vertical alignments which were drawn as Polylines but then converted to LWPolylines could display inconsistent results when the alignment was later queried.
  • When running a Least Squares Adjustment, selecting the option to adjust sideshots had no effect.
  • The writexml command was not exporting CgPoints into the XML file.
  • Importing an ASCII Lat/Long file did not import any coordinates.
  • Lot Closures in drawings from MSCAD 2005 could not be edited in MSCAD 2008 8.0.0, it would generate an error RE88CC12.
  • Drawings containing multiple vertical alignments would not work properly for generating a new design surface; only one vertical alignment would be available to base the surface on.
  • Drawings from MSCAD 2005 containing Point Groups with multiple ranges (for example 1..10,15..20) that were brought into MSCAD 2008 8.0.0 could sometimes have extra points in the point group.
  • Using the CAD Pick button in the RTS Dialog to select point numbers from the drawing did not always select the correct point numbers.
  • For the first time when MSCAD is run on a computer, the time displayed on the dialog for playing the Introduction movie was corrected from 11 minutes to 23 minutes.
  • More than one instance of the RTF log file viewer could not be opened up at one time, so for example when creating Lot Reports the log file of the first lot would need to be closed before a report for subsequent lots could be opened.
  • In the Active Traverse Editor, defining the FG/TDS Record Filters was not working.
  • When importing a RAW or RW5 file containing multisets, an incorrect instrument height could be used for the multiset.
  • After editing a traverse file, opening a traverse using the File | Open command in the Active Traverse Editor would display traverse files appended with “_travtmp” in their names. These files are now being filtered out so they do not appear.
  • If you have a traverse file open in the Active Traverse Editor, and at the same time manually enter traverse data into that traverse using the dialog box option, errors or a crash could occur.
  • Placing a QuickPost onto a point was erasing the point’s original description, rather than appending the quickpost description onto the point as it did in MSCAD 2005 SP1.3.
  • When using the “Transfer Points Between MSCAD Jobs” command, it needed to be run twice before the command would actually start.
  • Canadian clients would receive error messages when converting coordinates between NAD83 and NAD27 due to some extra steps that need to be manually done in order to use Canada’s NT_V2 National Transformation Database. These extra steps have now been clearly documented in the updated help file.
  • Exporting an ASCII file with the Column Specific format was not correctly exporting the point ID, due to changes that were made to allow for alpha-numeric point names.
  • The RTF Log file for projects done in MSCAD 2008 8.0.0 could contain inconsistent page numbers in the header.
  • When printing from the RTF Log file, some users reported that an extra blank page would be printed out before the first page or after the last page. This has been fixed.
  • When printing from the RTF Log file, point columns would not line up due to point numbers with different number of digits. This has been fixed to allow a point number width of 5 digits; point id’s with more than 5 digits can still cause the columns to not line up.
  • Some .MSD database files from MSCAD 2005 / inCAD 2006 or previous were not being translated forward to the new .MSZ database format due to some missing .DEF files in the original database.
  • Coordinate Listing reports contained a /par at the end of every line.
  • In the Active Traverse Editor, if you use Ctrl-H to enter a new shot, in previous versions the ID field for that new shot was given focus, but this was broken in 8.0.0 so that you had to manually click into the point ID field to begin entering the data.
  • The MsModeling | Utilities | General Utilities | NUMBER command would ask for a text style and then give a rejected function error.
  • The MsModeling | Utilities | General Utilities | NUMTRI command would ask for a text style and then give a rejected function error.
  • Process Automap Library, automatic linework was being drawn connecting the wrong point id’s. The point id’s were being sorted alphabetically instead of numerically, so if you had 22 points numbered 1-22 with the same description, they would be joined 1-10-11-12-13-14-15-16-17-18-19-2-20-21-22-3-4-5-6-7-8-9.
  • When importing a traverse file containing TR shots which were recorded in a multiset, these TR shots were imported as a regular occupy point setup, not as a traverse station.
  • When using the Alignment Browser, the prompts were improved so that the Next and Name options did not both appear as N.
  • If you edit an alignment by adding then deleting a POT, an extra line could be left in the drawing to where the added/deleted POT was.
  • The Help button on the Edit Alignment, SCS Dialog did not work.
  • When connecting to a USB Network License key, if you normally connect to one server but it has run out of available licenses, if there are available licenses on another server, you could not previously get a license from the other server without manually editing a configuration file.

8.0.0 Notes (Release Version)

Release Date: October 3, 2007

What's New

MicroSurvey CAD 2008 includes the following new features:

  • Latest CAD Engine
    MicroSurvey CAD 2008 uses IntelliCAD’s newest release, IntelliCAD 6.4.
  • Work with DWG 2008 files
    MicroSurvey CAD supports opening, modifying, printing, and saving drawings in DWG 2007 format. The DWG 2007 format is now the default format in which MicroSurvey CAD drawings are saved. Note, the 2007 format is compatible with AutoCAD R 2008.
  • Advanced Rendering
    MicroSurvey CAD now includes an advanced rendering engine that allows you to view your whole drawing in a dynamic 3D view. Pan, rotate, zoom around your drawing using advanced viewing controls. Save and print high resolution images directly from the render window.
  • USB Licensing (Stand alone)
    MicroSurvey CAD is now activated by using a USB License Key. USB License Keys make MicroSurvey CAD more portable for companies who need flexibility in where and when their software is used. All activation is done over the internet, no more calling or faxing us for software passwords.
  • USB Licensing (Server)
    New for 2008 is the MicroSurvey USB License Server. The License Server is perfect for organizations that want to have a network license system for MicroSurvey CAD.
  • Microsoft Vista
    MicroSurvey CAD 2008 is fully compatible with Windows 2000, Windows XP and Vista.
  • Faster Importing and Processing
    Many of the routines you use on a daily basis have been sped up. Importing ASCII files, processing measurement files, and importing EVR projects is on average 25% faster.
  • Feature File Support
    You can now add, edit and view point feature data. If feature data is collected using FieldGenius, the feature files will automatically import back into MicroSurvey CAD.
  • Rock Walls
    We now have 4 new linetypes for Rock Walls. They are included in the ICAD.LIN and are also part of the default ICAD.DWT file and are called ROCK, ROCK1, ROCK2 and ROCK3.
  • LDD / Civil 3D Database support
    You can now import and export points to and from LDD and Civil 3D database files.
  • LandXML Support
    You can now import and export points using LandXML files. More support for other LandXML data elements will be added very soon.
  • Alphanumeric Support
    MicroSurvey CAD now has full alphanumeric point name support. Give your point names more relevant meaning such as STK1, or RP1, or CHK1.
  • Standardized Database
    New for 2008 is a standardized database (DBF) format for all databases created by MicroSurvey CAD. The new database format is quicker, more stable, and more compact than previous versions.
  • Compressed Database
    The main project database is now automatically compressed when you close your project. On average, the new compressed database is 90% smaller in size compared to previous versions. The new database has a “msz” extension. You can open older MicroSurvey CAD projects, but you cannot convert MicroSurvey CAD 2008 databases to older formats such as 2005.
  • Traverse Coordination (Northing / Easting Only)
    This new option will compute the horizontal position using a scaled distance which is derived by applying the input scale factor to the distances stored in the traverse file. However, the elevation will be computed using the raw (un-scaled) distance.
  • Rich Text Log File Editor
    Included in MicroSurvey CAD and Capture is an updated log file editor and viewer. Record all your notes regarding your project using the Log File command.
  • Work with images
    MicroSurvey CAD includes enhanced imaging features to help you work with images in your drawings. Working with images is similar as in previous versions, with easy-to-use features located on the Image menu.
  • FieldGenius Raw File Encryption Support
    MicroSurvey CAD now includes the ability to decrypt FieldGenius encrypted raw files.
  • New layout viewport features
    There are several new features for layout viewports:
    • Snap to model space entities from paper space.
    • Lock layout viewports to lock the model space view or location while panning or zooming in paper space.
    • Assign a unique UCS to a layout viewport.
  • Export to PDF and 3D DWF format
    You can export drawings to two new formats:
    • PDF — Portable Document Format files allow you to distribute your drawing to others for viewing with Adobe® Acrobat® Reader®, which is free software that users can download, and for viewing, reviewing, and editing with Adobe® Acrobat.
    • 3D DWF — 3D Design Web Format files can be viewed in a Web browser if Autodesk® DWF Viewer is also installed on the computer. DWF Viewer is a free tool from Autodesk® that always supported viewing 2D DWF files, but now supports viewing DWF files in three dimensions.
  • Edit text in the command line
    The command bar and Prompt History window include enhanced text editing, including cutting, copying, and pasting text; copying the last command line or the entire command history; and repeating a previously executed command.
  • Create wipeout entities
    Wipeouts are unique entities that can help you hide areas of your drawing. They display with the current background color, so the details behind the wipeout do not display or print. However, if your version of MicroSurvey CAD does not include raster image capability (that is, does not include an Image menu), wipeout entities display, but the details behind the wipeouts also display.
  • Create audio notes from existing *.wav files
    In addition to recording audio notes in MicroSurvey CAD and attaching them to entities, you can now create audio notes from existing *.wav files. Audio notes created from an existing *.wav file are saved in the drawing file and the separate *.wav file remains unchanged.
  • Create and edit color books
    You’ve always been able to add color to your drawings using index colors, but now you use two new color features:
    • True colors — Defined using 24-bit color, there are more than 16 million true colors from which you can choose.
    • Color books — Defined with a list of colors, color books help you organize collections of colors. For example, you can store a unique color scheme in a color book for a client and then use colors only from that color book for the client’s drawings.
(476 vote(s))
Helpful
Not helpful

Comments (0)