Knowledgebase
MicroSurvey CAD 2010 - Release Notes
Posted by Brian Sloman on 24 April 2009 12:47 PM

Release History

MicroSurvey CAD 2010 v10.0.0 - June 9, 2009

MicroSurvey CAD 2010 v10.0.1 - October 23, 2009

MicroSurvey inCAD 2010 v10.1.0 - December 18, 2009

MicroSurvey inCAD 2010 v10.1.1 - April 9, 2010

MicroSurvey CAD 2010 v10.2.0 - August 20, 2010

MicroSurvey CAD 2010 v10.3.0 - December 1, 2010

MicroSurvey inCAD 2011 v10.4.0 - December 31, 2010

MicroSurvey inCAD 2011 v10.5.0 - June 3, 2011

MicroSurvey inCAD 2011 v10.6.0 - July 29, 2011

MicroSurvey CAD 2010 v10.7.0 - September 12, 2011


Important Notes

Activating or Updating your USB License Key

If you are licensing MicroSurvey CAD for the first time, or if you are upgrading from MicroSurvey CAD 2005 or previous, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MicroSurvey CAD 2008 or 2009, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from a previous version of MicroSurvey CAD 2010, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MicroSurvey CAD 2010, or it can be downloaded from our online Helpdesk system and installed separately onto another computer which has internet access.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MicroSurvey CAD Service Pack updates. For a detailed explanation of MicroSurvey's Maintenance Subscription Support Plan (MSSP) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your Maintenance Subscription has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the MSSP by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date. If your MSSP has expired, you can phone us at 1-800-668-3312 to renew it. Without a current maintenance subscription plan, you will not be able to update your key to work with the new version.

MicroSurvey Transfer Program for FieldGenius Users

FieldGenius users need to download a copy of the MicroSurvey Transfer program to simplify the process of transferring FieldGenius projects between your data collector and MicroSurvey CAD 2010.

If you have a copy of MicroSurvey Transfer already installed from use with MicroSurvey CAD 2009 or older, you will need to update it to recognize MicroSurvey CAD 2010. Previous versions of MicroSurvey Transfer will NOT show MicroSurvey CAD 2010 as a sync option in the Options screen.

The MicroSurvey Transfer program has not changed between MicroSurvey CAD 2010 10.0.0 and MicroSurvey CAD 2010 10.2.0. This is only necessary for users who are setting up communications between FieldGenius (any version) and MicroSurvey CAD 2010 for the first time.

MicroSurvey Transfer can be downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software. The MicroSurvey Network License Server program has not changed since MicroSurvey CAD 2008 8.0.0. This is only necessary for users who are setting up a MicroSurvey CAD 2008 or newer network license for the first time.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MicroSurvey CAD 2010 is compatible with 32-bit and 64-bit versions of Microsoft Windows XP SP3, Windows Vista SP2, and Windows 7.

MicroSurvey CAD 2010 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, except for a compatible video card for the 3D Rendering engine. Please refer to the following webpage for a list of compatible video cards, as indicated under the "OGL" column:
http://developer.techsoft3d.com/hoops/hoops-visualize/graphics-cards/

Windows Vista / Windows 7 Users

Vista/7: Run as Administrator Once

If installing on Windows Vista or Windows 7 you must run the program with "Elevated Admininstrator" enabled the first time MicroSurvey CAD 2010 is run, even if you are already logged in with "Administrator" access on the computer. Once this is done once, MicroSurvey CAD can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MicroSurvey CAD 2010 icon.
  2. Choose "Run as Administrator"
  3. Open or create a new drawing.

Vista/7: What's This? Help

If you wish to use the MicroSurvey CAD "What's This? Help" feature under Windows Vista or Windows 7, you may need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note, that the main MicroSurvey CAD Help file will work without this update.


Online Resources

Known Issues

For a list of known issues please visit the MicroSurvey CAD 2010 Known Issues topic in our online helpdesk.

Upgrade Notes

For a list of questions and answers on upgrading from a previous version, please visit the MicroSurvey CAD 2010 Upgrade Notes topic in our online helpdesk.

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MicroSurvey CAD 2010 F.A.Q. & Tips topic in our online helpdesk.

Training Movies

For over 16 hours of training movies that you can watch online or download for offline viewing, please visit the Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all users via our online helpdesk at http://helpdesk.microsurvey.com/ where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are now answered in your Help file and Manuals.

For technical support, please visit our helpdesk at http://helpdesk.microsurvey.com/ to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Maintenance Subscription Support Plan (MSSP).

To purchase or renew your MSSP, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000 or visit our online store at store.microsurveysales.com.

Feature Request Forum

Help us make your MicroSurvey product better! To submit a feature request, or to vote on other users' feature requests, please visit our Feedback Forum at feedback.microsurvey.com.

User Forum

To discuss your MicroSurvey product with other users, please visit our User Forum at http://www.microsurvey.com/forum.


10.0.0 Notes

MicroSurvey CAD 2010 Release

New Features

  • Updated CAD Engine - IntelliCAD 6.6
    • MicroSurvey CAD 2010 is now built on the latest IntelliCAD engine, IntelliCAD 6.6. For a list of IntelliCAD fixes, see below.
  • Pad Builder
    • Draw and edit pads directly within your current drawing by specifying edge lengths, turned angles, deflection angles, or double-offsets. This is different than the previously existing House Library commands which creates drawings in an external house library.
    • New command: _BUILD_PAD (MsTools | Pad Builder)
  • Offset Grid Lines
    • Easily offset Lines in your drawing by varying offset distances. This is similar to the existing _PARALLEL or _OFFSET command but is easier to use.
    • New command: _MS_OFFSET (MsTools | Offset Grid Lines)
  • Auto-Add Points to Gridline Intersections
    • Automatically compute points at the 3D intersection of selected Lines in your drawing. This is intended primarily for calculating points on grid lines, but it can be used in many situations.
    • New command: _COORDINATE_GRID_LINES (MsTools | Coordinate Grid Lines)
  • Query Angle between Two Lines
    • Calculates a 3-point inverse to determine the interior or exterior angle between two lines, and displayes the angle to you in both decimal degrees and degrees-minutes-seconds.
    • New command: _MS_SHOW_ANGLE (MsCogo | 3-Point Inverse)
  • Point Patterns
    • Create a custom library of point patterns to use for calculating multiple points in relation to other key points in your drawing. This is used primarily for applying Bolt Patterns onto columns, beams, etc.
    • New command: _POINT_PATTERN (MsTools | Point Patterns)
  • Online Update Notification
    • MicroSurvey CAD now includes a "Check for Updates" feature. This new command is available in the Help Menu.
    • MicroSurvey CAD is now configured to silently look for updates according to the preferences setup by the user. When an update is available the user will be notified. Updates are automatically downloaded and installed.
    • New command: _UPDATECHECK (Help | Check For Updates)
    • New command: _UPDATECHECK_CFG (Help | Auto Update Preferences)
  • Layer States
    • Save and Restore Layer States in your drawing. A layer state contains a snapshot of the state of all layers in your drawing (including: On/Off, Frozen/Thawed, Locked/Unlocked, Color, Linetype, Lineweight) at that point in time, so that when loaded all of these layer settings get restored to the state they were in when that layer state was saved.
    • If the layer state file is imported into a new drawing, it will automatically create the layers that are missing.
    • New command: _LAYERSTATE (MsTools | Layer Control | Layer States)
  • Normalize Raw Traverse Measurements
    • A new command is now available in the Active Traverse Editor, which will normalize Face 2 total station measurements to Face 1. This is necessary for users who want to perform a 3D Least Squares Adjustment.
    • Improved command: _MS_EDIT_RAW_DATA (MsTraverse | Active Traverse Editor)
  • Improved Stakeout
    • More intuitive dialog layout and workflow.
    • You can now specify any description for the computed stake points instead of the previous "FSTAKE" description.
    • You can now specify zero offset distances to compute stake points directly on the line/arc.
    • As each new stake point is computed, if a point already exists at the same position then you are now prompted for whether you to store the new point or not.
    • Improved command: _COMPUTE_STAKES (MsPoints | Stake Out Points)
  • Improved Auto-Add Points to Objects
    • Now works with Polylines, LWPolylines, and 3DPolylines.
    • Improved command: _AUTOP (MsPoints | Auto-Add Points to Objects)
  • Improved Mapping Grid
    • Improved scaling of labels and "+" grid marks, and preview capabilities.
    • New preview capabilities so you can see the grid before placing it in your drawing.
    • Grid is now drawn onto a dedicated "MAPPING_GRID" layer (instead of the current layer).
    • Improved command: _MAPPING_GRID (MsTools | Mapping Grid)
  • Improved Star*Net Exporter
    • We have made several improvements to the star*net exporter, which allows traverses from MicroSurvey CAD to be adjusted in star*net more easily, including the following:
      • Units and Order records are now added to header section.
      • Date Processed note recorded in the header section.
      • Directory and traverse file that the export is based on is recorded as a note in the header section.
      • We do not record a C record for every setup anymore, only for the inital setup points.
      • FieldGenius Multiset backsight measurements are now exported as DV records.
      • FieldGenius Multiset foresight measurements are now exported as M records.
      • Angle format in the DAT file now uses the Starnet notation of degress-minutes-seconds. For example angles will look like: 90-00-34.55 instead of 90.003455
      • Distances are now displayed in the DAT file to four decimal places.
      • Undefined distances in DV and M records are now exported as ? instead of 0.0000.
      • Fixed odd behaviour when selecting the DAT file export directory. It would always default to C:\Star
      • Exported DAT file is automatically opened in Notepad after export for review.
      • Now available in MicroSurvey CAD Basic, Standard, and Premium versions. (Previously Standard and Premium only)
    • Improved command: _STAR_NET_EXPORT (MsTraverse | Star Net Interface)

Important Fixes

  • MicroSurvey CAD Fixes
    • [1346] Shift Points - Using the _ms_shift command to shift points causes database arcs on those points to be removed from the drawing.
    • [1347] Scale Points - Using the _ms_scale command to scale points causes database arcs on those points to be removed from the drawing.
    • [1348] Rotate Points - Using the _ms_rotate command to rotate points causes database arcs on those points to be removed from the drawing.
    • [2829] Rotate Points - Rotating Points from the Active Coordinate Editor could cause an incorrect north shift to be applied to the results if a 3D rotation point was snapped onto.
    • [2816] RTS Points - Output from the _rts command to the command history and log file was improved to reduce unnecessary and redundent information.
    • [2802] Store & Edit Points - If multiple points are at or near the same coordinate (within a distance of 0.0001) then picking on one point could select another point. (A similar issue still exists in the _connect_points command.
    • [1156] Active Coordinate Editor - If the Point Protection dialog comes up due to changing a point, but then Cancel is selected, the coordinate shown in the active coordinate editor is now reset to its previous value.
    • [2505] Active Coordinate Editor - Change Selection Layer command now enforces standard layer naming conventions.
    • [2598] Active Coordinate Editor - It is no longer possible to ignore the Point Protection dialog if it comes up, which would result in a crash if additional Point Protection events were triggered.
    • [2786] Active Coordinate Editor - Tiling the Active Coordinate Editor window when a drawing is not open would result in a crash.
    • [2803] Active Coordinate Editor - Using the Draw Table In Drawing From Selection command from within the Active Coordinate Editor would result in a crash if another command was currently active.
    • [2692] Batch COGO - It is no longer possible to ignore the dialog prompting you to Save changes when closing the Active Batch Editor, which would result in a crash if you tried to close the Active Batch Editor again.
    • [3062] Batch COGO - Bearing-Bearing intersections were not being recorded in the batch file in the latest 2009 update.
    • [3062] Batch COGO - Bearing-Distance intersections were not being recorded in the batch file in the latest 2009 update.
    • [2359] ASCII Import - Importing points whose descriptions contain commas now import completely without parsing the description at the first comma in it.
    • [3025] ASCII Import - Importing Lat/Long ASCII files could cause a crash if the file contains blank lines.
    • [3025] ASCII Import - Importing Lat/Long ASCII files with the "Store Coordinates in COGO Database" option turned off, would store them in the database anyways.
    • [2133] ASCII Import/Export - Help buttons on the ASCII Import and ASCII Export dialogs for the "Coordinates Column Specific" format was not opening the Help topic.
    • [2057] ASCII Export - A crash could occur if too many decimal places were exported into the ASCII file. You must now specify between 0 and 12 decimal places.
    • [3060] FieldGenius / TDS Raw Import - Angles read in a FieldGenius or TDS RAW/RW5 file were being rounded to the nearest second. This no longer occurs.
    • [2905] Traverse Adjustment - Using the _ms_pt_adjust Existing Point Traverse (Old) command was not performing a correct compass balance.
    • [2929] Traverse Adjustment - A 3D Least Squares Adjustment of a traverse containing reverse-face shots would cause errors. A new option in the Active Traverse Editor to normalize shots has been added as a temporary fix for this situation.
    • [2723] Copy Points between Jobs - the _ms_start_transfer command does not work with databases created in MicroSurvey CAD 2008 8.0.0 (pre-SP1). A messag now appears with instructions how to fix this situation by opening and re-saving the drawing.
    • [0608] Line and Curve Tables - The "Auto-Add Database" system toggle is now honored when creating line/curve table entries, so you can control whether or not points get created in the database.
    • [2992] Line and Curve Tables - Line Tables are now created showing lines in the order you selected them. Ensure SORTENTS variable is set to 96.
    • [2354] Lot Closure - A crash which could occur if incorrect linework was selected while defining a lot has been fixed.
    • [2634] Cutout Drawing Detail - The Cutout Drawing Detail command did not work, it would give an "Error: rejected function" message.
    • [2635] Surface Modeling - Area and Volume unit labels in the Configuration Settings dialog would only accept numeric values which is not desired, it now accepts alphanumeric values such as "Acres" or "Cu.Yds.".
    • [2744] Surface Modeling - Using the Draw Dots options in the _grd command was drawing Lines instead of Dots, this has been corrected.
    • [1632] Surface Modeling - Using the "Configure Colors" button in the _paint command did not work properly the first time it was run.
    • [2817] Surface Modeling - Using the "Configure Colors" button in the _paint command would cause the program to crash later when using the _exit command to close the program.
    • [2626] Surface Modeling - Auto-Loading a QSB file and automatically re-tinning a surface (via the Project Manager) could cause a crash in some situations.
    • [2745] AutoRoute - Using the _makealign command to create a horizontal alignment by picking lines and arcs did not always accept some arcs depending on which end of the arc was selected.
    • [2570] AutoRoute - Labeling Stations using the _labelalign command, the last station was not being labelled - a label is now drawn at the end station.
    • [2804] AutoRoute - Labeling Offsets using the _labelalign command would reverse the offset values used if different Left and Right offsets were specified.
    • [2787] AutoRoute - Labeling offsets using the _labelalign command, if an offset value of less than 10 was specified then it used 0 as the offset value and points were labelled directly along the alignment.
    • [2858] Sewers - Prompts presented at command line when using the "Keyboard" option in the _sorsewer command have been improved.
    • [2777] Unnamed Drawings - A crash which could occur when working in a new unnamed drawing (created with the _new or _newwiz commands) has been fixed.
    • [2864] Layer Control, Copy - The Copy command in the MSTools | Layer Control menu or MSLayers toolbar did not complete correctly (manually pressing Enter was required) in drawings with multiple copy mode enabled.
    • [F848] Layer Control, Thaw - The Thaw command in the MSTools | Layer Control menu or MSLayers toolbar had a performance problem which has been fixed.
    • [2726] CAD Lines/Curves Dialogs - Grouped entities now work with the CAD Lines or CAD Curves dialog, to retrieve information on the entity in the group which was selected. Ensure SORTENTS variable is set to 96.
    • [3008] 3D Offset - This command did not work correctly in drawings with multiple copy mode enabled.
    • [2925] Areas - Calculating an area with the _ms_calc_lot_swing_line command by swinging a line, would abort if the lot contained a curve, this has been fixed.
    • and more...
  • IntelliCAD Fixes
    • [81956] Stability & Crashes - Several fixes to threading/timing problems which could cause the program to crash seemingly at random have been fixed. These crashes occurred most frequently when modifying entities with the right-click menu, and in drawings with raster images.
    • [81748] Slow Saving - A performance issue when saving the drawing file, caused by querying printer driver details, has been fixed.
    • [81973] Printing/Plotting - The "Select Origin" button now correctly sets the print offset values in paper units (Inches or millimeters).
    • [81843] Printing/Plotting - The -PLOT command now correctly defaults to the previously configured "Print Lineweights" option at the command line prompt.
    • [D2986] Printing/Plotting - Entities no longer temporarily disappear (taking on the color of their print style) requiring a regen after printing.
    • [Dxxxx] Printing/Plotting - Entities outside the selected Print Area are no longer printed if the "Print only area within specified window" option is enabled.
    • [81815] External References - A severe performance problem due to redundant font substitutions in XREF drawings has been fixed.
    • [82212] External References - A crash which could occur on saving drawing after Binding an XREF has been fixed.
    • [81462] Raster Images - The Fade option in the image manager worked in reverse if the background color is White - this now works as expected.
    • [82184] Raster Images - A display issue with monochrome images where the white pixels would sometimes have a blue tinge in them has been fixed.
    • [82184] Raster Images - A display issue with monochrome images where the black and white pixels would spontaneously invert has been fixed.
    • [81707] Raster Images - The following unsupported filetypes were removed from the Browse dialog when attaching images: *.bil.
    • [82052] Raster Images - The following unsupported filetypes were removed from the Browse dialog when attaching images: *.img, *.ddf
    • [82036] Multiline Text - Some paragraph formatting codes were being displayed as text in the drawing - these embedded format codes no longer appear in the drawing.
    • [82191] Blocks - When inserting a block, the Z-scale factor is now set to the same value as the X- and Y-scale factors if they are equal. Previously, the Z-factor was set to 1 if not explicitly defined.
    • [81348] Boundary Hatches - Invalid/corrupt scale factor values in hatch entities could lead to the hatch not displaying properly, generating errors on save, and crashes on audit - this is now detected and handled correctly.
    • [82171] Boundary Hatches - Invalid/corrupt hatch entities could cause the program to generate errors on open and crash on audit or recover - Opening such a badly corrupted file is now prevented, and the Recover command can be used to repair the drawing.
    • [81255] Dimensions - Support for Dimension Tolerance Alignment formats has been added.
    • [82202] Dimensions - Dimensions drawn in Layout space now work consistently.
    • [79696] Coordinate Systems - New UCS can now be created from the IntelliCAD Explorer window.
    • [79971] Coordinate Systems - New UCS can now be created from the IntelliCAD Explorer window.
    • [82026] Custom Menus - A crash in the Customize command which could be caused by pressing "Add command" without first selecting a command to add has been fixed.
    • [81684] Digitizer Tablet - A crash on startup due to improper tablet configuration is now prevented.
    • [81389] Entity Selection - The PICKSTYLE variable is now a global profile setting and is not drawing specific.
    • [82194] Entity Selection - Selection Sets were being created with the entities sorted in a different order from which they were selected. This caused some custom LISP programs to not function correctly when a specific order was expected.
    • [81961] AutoCAD® Compatibility - Space characters were being removed from block attributes in some drawings from AutoCAD 2010.
    • [82037] AutoCAD® Compatibility - Support for display of Table entities has been added - they now display as Proxy entities.
    • [82190] AutoCAD® Compatibility - Dynamic Block entities are now being saved back into the drawing file properly and are not converted to normal Block entities.
    • [81854] Network Drives - Some network configurations prevented drawings from being opened from a network drive even if security permissions had been properly configured.
    • [82218] Program Interface - When changing the current layer via Entity Properties toolbar, the color for ByLayer shown on the toolbar did not immediately update to show the new layer's color. (Note: the correct color was actually being used when drawing entities.)
    • [82222] Program Interface - In some situations the maximized window was positioned incorrectly, leaving a small gap the width of the taskbar along the top of the screen. This is now prevented and the window should always maximize correctly.
    • and more...

10.0.1 Notes

MicroSurvey CAD 2010 Multilanguage Update

Important Fixes

  • Translations
    • Fixed various translation issues in the Chinese, Russian, and Spanish versions.
    • Changes do not affect the English version.

10.1.0 Notes

MicroSurvey inCAD 2010 for AutoCAD® 2009/2010 Release

  • License now includes both the IntelliCAD and AutoCAD versions
    • MicroSurvey is now offering flexibility in how you use our Desktop Applications. You can choose to run the IntelliCAD version (MicroSurvey CAD 2010 Basic/Standard/Premium) or the AutoCAD version (MicroSurvey inCAD 2010 Standard/Premium) with the same license. Licenses for MicroSurvey CAD will now run inCAD and inCAD licenses will run MicroSurvey CAD.
    • For general information on MicroSurvey CAD please visit http://www.microsurvey.com/products/mscad
    • For general information on MicroSurvey inCAD please visit http://www.microsurvey.com/products/incad
    • Complete inCAD 2010 release notes are available here

10.1.1 Notes

MicroSurvey inCAD 2010 for AutoCAD® 2009/2010 Service Pack 1

  • 64-bit AutoCAD 2010 Support
    • MicroSurvey inCAD 2010 SP1 adds support for 64-bit versions of AutoCAD 2010
    • Complete inCAD 2010 release notes are available here

10.2.0 Notes

MicroSurvey CAD 2010 Service Pack 1

New Features

  • AutoCAD 2010/2011 DWG/DXF Support
    • MicroSurvey CAD 2010 can now automatically convert and open 2010 DWG/DXF drawing files, then Save them as R12-2007 DWG/DXF format.
    • Or, use the standalone IntelliConvert conversion utility to manually convert R12-2010 DWG/DXF files.
  • RPN Calculator
    • An RPN Calculator is available to assist you with any manual calculations.
    • The RPN Calculator can now be launched as its own separate command, or directly from any numeric field in any other MicroSurvey command.
    • Easy-to-use stack based interface similar to the popular HP48 calculator.
    • Calculate with numbers, distances, angles, bearings, azimuths
    • Convert distances automatically between Meters, Feet, and US Survey Feet
    • Convert angles autimatically between Decimal Degrees, Degrees-Minutes-Seconds, Radians, Grads/Grades/Gradians/Gons
    • Easily add or subtract angles to Azimuth or Bearing directions
    • New command: _CALC (MsTools | RPN Calculator)
    • Improved commands: Calculator is available directly from hundreds of MicroSurvey commands
  • Photo Notes
    • Supports the new "Photo Notes" feature in FieldGenius 2010, whereby photographs can be taken in the field using the new Nautiz X7 data collector and attached directly to your points database.
    • Any Photo Notes taken with FieldGenius 2010 will be automatically imported into your project database during the SyncWizard import.
    • View or Delete your Photo Notes directly from the Store/Edit Points dialog, or from the Active Coordinate Editor.
    • Improved command: _SYNCWIZARD (MsTraverse | FieldGenius SyncWizard)
    • Improved command: _EDITP (MsPoints | Store & Edit Points)
    • Improved command: _COORDEDIT (MsPoints | Active Coordinate Editor)
  • 3D Curves
    • Draw new 3D Curves (3D Polylines with interpolated vertices) by picking points on the curve. Toggle between straight, curvey, and 3-point arc segments while drawing complex 3D linework.
    • New command: _3DCURVE (MsTools | Draw 3D Curve)
    • Convert existing 3D Polylines with straight segments to 3D Curves.
    • New command: _3DPOLY_TO_3DCURVE (MsTools | Convert 3D Polyline to 3D Curve)
  • Feet & Inches Entry
    • Distance values entered in feet and inches like 1'6" are normally interpreted by CAD as 18 (inches), we modified this behaviour to interpret it as 1.5 (feet) to maintain consistent units with the rest of the program.
    • Improved commands: All IntelliCAD Draw or Modify commands where you can enter distances: line, polyline, offset, chamfer, etc..
  • New Clipboard Copy/Paste Commands
    • When entities are copied to the clipboard you can now specify a Base Point. In comparison, the COPYCLIP (Edit | Copy) command automatically calculates the Base Point as the bottom-left corner of a virtual rectangle bounding the selected entities.
    • New command: _COPYBASE (Edit | Copy with Base Point)
    • When entities are copied to the clipboard you can now paste them to the original coordinates they were copied from without prompting for an insertion point. In comparison, the PASTECLIP (Edit | Paste) command always prompts for an insertion point.
    • New command: _PASTEORIG (Edit | Paste to Original Coordinates)

Notable Improvements

  • Active Coordinate Editor - When running the Change Selection Layer command, the four checkboxes for Point, Elevation, Description, Point Number are now unchecked by default, to prevent accidently changing their layers.
  • AutoMap Library - You can now automatically draw an Ellipse, Double Ellipse, or Rectangle around your Point ID labels, this is important for Alberta Land Surveyors.
  • AutoMap Library - You can now specify X and Y offset distances for the Description, Point ID, and Elevation labels in the AutoMAP Library, this will help with spacing out the labels for Design and Stake points, etc.
  • AutoMap Library - You can now process a point range (pt..pt) in addition to the previous method of processing all connections
  • AutoMap Library - A Save prompt has been added when pressing the "New Library" button, to avoid accidental data loss while customizing your Automap Library if you accidentally click "New Library" instead of "New".
  • Locked Points - The "Protected" column in the Active Coordinate Editor is now relabeled as "Locked" to avoid confusion between it and the global Point Protection feature.
  • Locked Points - A "Locked Point" checkbox is now available in the Store & Edit Points dialog, which corresponds to the "Locked" (formerly "Protected") option in the Active Coordinate Editor.
  • MS Backup - A save prompt has been added at the start of the MSBACKUP command, because it will copy the most recently saved drawing. Previously, you had to manually Save before Backup.
  • Project Manager - A "Browse For Drawing" function has been added to the Project Manager, which uses a standard Windows file browser dialog to select your drawing file.
  • Translated Help Files - Help files can now be translated on-the-fly and read in 31 different languages. (An internet connection is required, high-speed recommended.)
  • Traverse Re-coordination - A "Do not replace descriptions with field values" option has been added, this will prevent point descriptions in your database from changing when a traverse file is recoordinated.
  • Updated IntelliCAD Engine - The IntelliCAD 6.6 CAD engine has been updated to the latest version for improved performance and stability.
  • Updated Rendering Engine - The HOOPS 3D rendering engine has been updated to the latest version for improved rendering performance and stability.

Important Fixes

  • MicroSurvey CAD Fixes
    • [3885] Curvey Leaders - When using the Curvey Leader command, the drawing screen may flicker or disappear requiring you to close and reopen the drawing
    • [3693] Leica GSI Import - A crash could occur due to the GSI file being improperly formatted, an error message now appears instead
    • [3538] Lot Closures - The "pick" buttons for selecting bearing/azimuth labels when defining a lot closure did not work if the degrees sign was %%D instead of %%d
    • [3337] Menu Stability - When exiting and restarting the program, some of the menus could disappear if the profile was still being written out on exit while being read in on startup
    • [3091] Pad Builder - The dialog was not displaying properly, options appeared to be scattered around
    • [3931] Pad Builder - Entering values in feet & inches would produce an error message that the fraction was not formatted correctly
    • [2380] Raster Images - The Image Frame command did not work in the Standard version, it now works in both Standard and Premium.
    • [3309] Read-Only Files - When a drawing that is In Use is opened by a second user in Read-Only mode, the database is no longer opened for the read-only copy which prevents changes to the read-only copy from corrupting the live copy.
    • [2384] Rescale Complete Drawing - A crash could occur if the drawing was missing certain extended entity data on entities referenced in the database
    • [2730] Speed/Performance - If Active Coordinate Editor was open, if Hot Toggles was open, or if IPN Labels were on there was a major slowdown issue when storing/editing points for example when performing an RTS calculation, Locking/Unlocking Points, importing an ASCII file, or importing a FieldGenius project
    • [3373] Surface Modeling - A crash could occur when extracting cross sections, if the surface name contained a space
    • [3082] Surface Modeling - A crash could occur when removing points from DTM via the Active Coordinate Editor, if the drawing contains a layer called dont_use_me
    • [2961] Surface Modeling - The "Enable Range" contour configuration option checkbox behaviour was backwards, making it confusing to set the Minimum and Maximum values
    • [2917] Surface Modeling - The "Densify Step Size" extraction option had a display issue making the Auto vs Size options confusing to select
    • [3200] Surface Modeling - A crash could occur when importing a surface from an XML file containing data in an unrecognized format
    • [2882] Toolbars - Some of the toolbars had incorrect names or buttons in the Basic and Standard versions
    • [xxxx] Various broken Help buttons throughout the program have been corrected
    • [xxxx] Various spelling errors throughout the program have been corrected
  • IntelliCAD Fixes
    • [82466] A crash can occur when zooming/panning with the mouse while the program is under stress
    • [83110] A crash can occur when an sds_entget command is run on an SORTENTSTABLE entity (for example, this occurs after undoing a draworder command)
    • [85143] A crash can occur while moving entities
    • [82468] Audit/Recover - does not reset the count of objects audited, so the entity count ends up being multiplied in subsequent audits
    • [82568] Audit/Recover - auditing a corrupted drawing containing specific errors can cause it to lose layouts
    • [80930] Blocks - A crash can occur when using the "Previous" selection set after exploding a block
    • [82737] Blocks - A crash can occur when Unloading and Reloading an Xref
    • [82851] Blocks - Blocks with "Uniform" scale option do not display correctly when mirrored
    • [82919] Blocks - Blocks with a negative extrusion vector (3d rotation) cannot be moved using Grips
    • [83128] Blocks - A crash can occur when selecting Unnamed blocks for COPYCLIP and WBLOCK commands
    • [84631] Blocks - A crash can occur while purging anonymous blocks
    • [83083] Dimensions - Angular Dimensions can temporarily display incorrectly while moving via grips, for example showing 89°59'60.0" instead of 90°00'00.0"
    • [83126] Dimensions - DIMLIN and DIMALI Dimensions do not allow you to use entity snaps for the second point
    • [83366] Dimensions - AutoCAD MLEADER Multileader entities do not display
    • [85285] Display - REDRAW / REGEN difference in layout tab on attached drawing
    • [85330] Display - mouse cursor can disappear in certain situations
    • [83044] Entity Properties - A message "The parameter is incorrect" will pop up when selecting the Layers list on the Entity Properties toolbar, if entities from multiple layers are currently selected
    • [83768] Entity Properties - When changing color of a polyline through the Color list on the Entity Properties toolbar, too many entities can change color
    • [83869] Entity Selection - Window Polygon selection method selects all of the inserts in the drawing
    • [81746] File I/O - After printing, printer settings can bog down saving of drawings
    • [83065] File I/O - Cannot open any files where the filename contains a % character
    • [84487] File I/O - Attached drawing has trouble saving
    • [84925] File I/O - 2010 DWG/DXF IntelliConvert utility implemented for converting 2010 DWG drawings to 2007 DWG
    • [85352] File I/O - 2010 DWG/DXF automatic file conversion method implemented on opening drawings
    • [83164] Hatching - Associative Hatch Patterns are unassociated if the boundary is grip edited
    • [83737] Hatching - Hatch Pattern previews do not display in Windows x64 (or anytime the installation folder contains parentheses)
    • [84818] Hatching - Color SLD files are displayed as Black and White
    • [83062] Lisp - "command" command loses precision of numeric arguments being passed in
    • [83367] Lisp - A crash can occur when unloading a custom application
    • [83370] Lisp - "command" command is not correctly cancelled by escape
    • [83743] Lisp - Pasting a multiline Lisp expression into the commandline to run it does not work
    • [83744] Lisp - Entities on a locked/frozen layer can be erased via Lisp
    • [84729] Lisp - Corrupted pointer passed to SDS_CBCMDEND callback when a command results in changing the current drawing
    • [85551] Lisp - Function could improperly terminate if offset is called with an empty selection set
    • [79366] Printing - Print Window selection does not allow you to use entity snaps for the second corner
    • [81746] Printing - After printing, printer settings can bog down saving of drawings
    • [81964] Printing - Print Window area does not cut off entities at the selected window edge
    • [82455] Printing - Print Area option does not work if "Save changes to Layout" is not turned on
    • [82503] Printing - Ricoh/NRG/Nashuatec printers can cause the program to crash on print
    • [82662] Printing - Ricoh/NRG/Nashuatec printers can cause the program to crash on save
    • [82833] Printing - Print settings are not properly saved into layouts
    • [82312] Printing - When using "Print upside down" option from layout space, model space entities may not appear through viewport
    • [83155] Printing - After printing, entities are displayed using the printed color from .CTB print style table file until a REGEN is run
    • [84258] Printing - Specified paper tray is not remembered
    • [85271] Printing - Standard print scales are not saved properly
    • [84341] Raster Images - A crash can occur when clipping image if an invalid option is specified
    • [82433] Snaps - Entity snaps do not work properly for PFACE entities within a block, if UCS is not World
    • [82058] Snaps - Apparent Intersection entity snap does not work for extended intersections
    • [81765] Snaps - Polar Tracking interferes with window selection
    • [83371] Snaps - Polar tracking is turned off after temporary using ORTHO snap with SHIFT key
    • [82168] Text - changing Justification property of multiple text entities causes their insertion points to change to 0,0,0
    • [82513] Text - MTEXT containing negative indentation does not display correctly
    • [82681] Text - Text containing Russian fonts display the last character incorrectly
    • [83162] User Profiles - A crash can occur when using custom menu commands with an invalid reference
    • [82891] User Profiles - When running multiple instances of the program each with a different current profile, the profiles can contaminate each other in the registry
    • [82792] User Profiles - Custom menus containing a very large number of commands with many toolbars and submenus do not work, picking the commands at the bottom of the menu may not do anything
    • [84616] Viewports - layout space viewports can be automatically activated
    • [82567] Viewports - -LAYER Freeze command in a layout viewport causes the layer to be Frozen in All Viewports not just the Current Viewport

10.3.0 Notes

MicroSurvey CAD 2010 Service Pack 2

New Features

  • Introducing MicroSurvey CAD Ultimate
    • MicroSurvey CAD Ultimate contains all of the functionality of MicroSurvey CAD Premium plus advanced Point Cloud functionality.
    • MicroSurvey CAD Ultimate uses the latest Leica pcE engine, which is the same point cloud engine used in Leica Cyclone.
    • New command: _PCLW (MsTools | Point Cloud Linework)

Notable Improvements

  • XYZ-Coding
    • When processing XYZ-Codes to draw 3D linework, arcs are now drawn as 3D polylines with many vertices to approximate a 3D arc.
    • When processing XYZ-Codes to draw 2D linework, arcs are still drawn as 2D arcs as before.
    • When processing XYZ-Codes, figures will now be drawn as a single polyline or as individual line and curve segments, per AutoMap Library settings.
    • Improved command: _MS_DESC_TO_GRAPHICS (MsTraverse | AutoMap System | Connect Points by XYZ)
  • 3D Curves
    • When using the _3DCURVE or _3DPOLY_TO_3DCURVE commands, the number of interpolated vertices can now be controlled either by specifying an approximate inter-vertex distance (as before), or by specifying the number of vertices per curved segment (new, defaults to use the "SPLINESEGS" drawing variable).
    • Improved command: _3DCURVE (MsTools | Draw 3D Curve)
    • Improved command: _3DPOLY_TO_3DCURVE (MsTools | Convert 3DPolyline to 3DCurve)
  • Point Block Importer
    • A "Scan" function has been added which will report the names of all blocks with attributes in the drawing, to help you determine how to set the Block Name and Attribute Name options.
    • Wildcards are supported in the Block Name, for example "PAAL*" can be used to match all blocks whose names like PAAL1, PAAL2, etc. (MOUS drawings can contain dozens of block names all beginning with the same prefix.)
    • If the Point Number attribute is not available, then the point will be imported using the "Next Pt ID" from the Hot Toggles dialog.
    • If the Elevation attribute is not available, then the point will be imported with Z= elevation of the point block entity. (Eagle Point importer can now use 2D point blocks which do not have an elevation attribute.)
    • If the Description attribute is not available, then the point will be imported with either no description, or with the default description.
    • New command: _IMPORT_GENERIC_POINT_BLOCK (MsPoints | Other Program Ties | Import Generic Point Blocks)
    • Improved command: _IMPORT_EP (MsPoints | Other Program Ties | Eagle Point | Import Eagle Point Coordinates)
    •  
      • MicroSurvey Fixes
        • [4023] Active Coordinate Editor - drawings last saved in MicroSurvey CAD 2008 v8.0.0 would not display any point coordinates in the Active Coordinate Editor.
        • [4041] Active Coordinate Editor - a crash can occur when opening the coordinate editor, if a database record does not have the expected number of characters.
        • [2069] Active Coordinate Editor - a crash can occur when opening the coordinate editor, if the total length of the path and filename plus the point id is very long.
        • [4017] AutoMap Library - after selecting the "Skip XYZ Connection" option, a "Blank Description Codes(XYZ-._)?" prompt would appear anyways.
        • [2783] Batch COGO - Batch cogo fails on a distance-distance intersection with alphanumeric point IDs.
        • [4033] Batch COGO - Batch cogo fails on a distance-distance intersection with alphanumeric point IDs.
        • [3112] Leica GSI Import - store point records were not created in the traverse file for points which were stored on import.
        • [3999] Leica GSI Import - files with descriptions containing a space caused error message like "Problem found on line 23, unable to continue."
        • [4020] Leica GSI Import - setup records and backsight shots were incorrectly imported as sideshots.
        • [4046] Leica GSI Import - shot records containing descriptions in a 71 record (from using a codelist) were not imported.
        • [4046] Leica GSI Import - files with fixed coordinates recorded in "north,east" coordinate order ("east,north" is default) could not be properly imported.
        • [4058] Leica GSI Import - files with angles recorded in gons/grads were not converted correctly.
        • [4018] Project Units - when opening a drawing with angular units set to Grads, or when creating a new drawing using a template in Grads, it was automatically being changed to DMS format instead.
        • [4024] Quick Posts - fixed an issue with the insertion point of the RIP, PTH, PSRP quick post blocks to ensure they insert correctly.
        • [4028] Traverse Recoordination - When importing a RAW/RW5 file containing resections, a missing LS record could result in erroneous point elevations. If an expected LS record is not found a warning message is now displayed.
        • [4028] Traverse Recoordination - When importing a RAW/RW5 file containing resections, a trailing SP record containing the calculated resection point will now always be imported into the traverse file.

Important Fixes


10.4.0 Notes

MicroSurvey inCAD 2011 for AutoCAD® 2010/2011 (Release)

  • MicroSurvey inCAD 2011 adds support for AutoCAD 2011, and continuing support for AutoCAD 2010.
  • For general information on MicroSurvey inCAD please visit http://www.microsurvey.com/products/incad
  • Complete inCAD 2011 release notes are available here

 


 

10.5.0 Notes

MicroSurvey inCAD 2011 for AutoCAD® 2010/2011 (Service Pack 1)

  • MicroSurvey inCAD 2011 SP1 adds new features and bug fixes to inCAD 2011.
  • For general information on MicroSurvey inCAD please visit http://www.microsurvey.com/products/incad
  • Complete inCAD 2011 release notes are available here

 


 

10.6.0 Notes

MicroSurvey inCAD 2011 for AutoCAD® 2010/2011 (Service Pack 2)

  • MicroSurvey inCAD 2011 SP2 adds new features and bug fixes to inCAD 2011.
  • For general information on MicroSurvey inCAD please visit http://www.microsurvey.com/products/incad
  • Complete inCAD 2011 release notes are available here

10.7.0 Notes

MicroSurvey CAD 2010 Service Pack 3

New Features

  • [F0529] COGO - You can now repeat the last entered distance or direction in COGO by using the new Repeat option, or by using ++ on your numberpad.
  • [F0759] Cut Sheets - You can now copy elevation values from as-built points to design points using the Cut Sheet tool.
  • [F1392] First Available Point - A new command called FAP (MsPoints | List Points (Used and Unused) | First Available Point) is available for querying the first available point ID in any range and setting that as the Next ID.
  • [F1335] Inverse - You can now use the INVERSE command to calculate between any two selected points in the drawing, it is no longer restricted to only using points stored in the coordinate database.
  • [F0961] Label Points - The "Label N,E of Point" command will now label N,E or E,N depending on the "Use E,N format" system toggle.
  • [F1386] Licensing - You can now "snooze" the startup message reminding you about an expired or nearly-expired maintenance subscription plan for 14 days so that it does not appear every time you start the program.
  • [F1391] Tables - Line Table, Curves Table, and MultiTies Table commands now have a "Use Point IDs" option to include the point IDs directly in the table body, rather than creating named references like "L1" or "C2".
  • [F0791] Surface Modeling - The Contour Labeling command has a new option to draw a Wipeout for masking the contour line behind the text label, instead of trimming the contour line around the label.
  • [F1521] Text Editing - The MS_ROTEXT (MsAnnotate | Modify Text | Rotate Text 180 Degrees), MS_ROTOLINE (MsAnnotate | Modify Text | Rotate Text to Match Text/Line), and SLIDETEXT (MsAnnotate | Modify Text | Slide Text Along Axis) commands now allow selection of multiple text entities instead of just one at a time.
  • [F1336] Chainage - a new command called CHAINAGE (MsAnnotate | Chainage) is available for drawing customizable 2D or 3D stationing, station coordinates, deflection angles, and offset points along selected entities (lines, arcs, polylines), with highly customizable labeling options.

Important Fixes

  • [3984] Automatic Updater - The automatic update notification message was improved to clarify the fact that a USB key must be updated via the License Manager application in order to run the new version, and to prevent an update that is not licensed from being installed.
  • [3986] Automatic Updater - The automatic update notification message was not properly disabled through the appropriate option in Auto Update Preferences.
  • [3472] AutoRoute - Labeling offset points on an Alignment did not include the Offset Distance on points offset Right of the alignment.
  • [3536] Batch COGO - New records could not be added at the bottom of the Batch COGO Editor.
  • [4154] Figures Database - Using the _ERASE command to delete survey lines from the drawing did not remove the line from the figures database.
  • [4147] Rescale Complete Drawing - dramatically increased the speed performance of the _MS_RESCALE (MsPoints | Rescale Complete Drawing) command when rescaling line labels. Tests rescaling a drawing containing 2000 points and 1000 Bearing/Distance labeled lines shows an improvement from 6:20 to 0:10.
  • [D4543] Areas - The FASTAREA command could crash if you did not provide a lot name.
  • [D4021] ASCII Import - A crash could occur when importing an ASCII file exported from FieldGenius in "Standard With Header" or "Extended With Header" formats.
  • [D4368] ASCII Import - A crash could occur when importing an ASCII file containing any points with a description longer than 50 characters.
  • [D2219] COGO - New points could automatically assume a Locked status.
  • [D2970] COGO - New points could present an inappropriate default description, it now defaults to the last used description.
  • [D4205] COGO - Pressing Esc to abort from the Lines, Points, or Toggles prompts would proceed to the next prompt with no value specified in the previous prompt - you are now returned to that previous prompt.
  • [D2630] Cut Sheets - The option to copy as-built descriptions to design points did not update the drawing.
  • [D0644] FieldGenius Export - The DXF file could contain entities from paper space when using the "Use entire drawing" option to export a FieldGenius project.
  • [D4233] Help - The Help button on the Label Alignment command's Newpoint dialog did not work.
  • [F0922] Inverse - Dialog position is now retained, instead of always opening up in the middle of the screen.
  • [D4403] LandXML Import - When importing a file with a surface model, it could not be drawn as a Polyfase Mesh during import.
  • [D4404] LandXML Import - When importing a file with many (more than 128) parcels, only the first 128 would import.
  • [D4120] Licensing - When starting the program with a MicroSurvey STAR*NET license key connected, the error message now identifies the problem more clearly.
  • [D4352] Open Project - A crash could occur when opening drawing if the database contains a corrupt date field.
  • [D4364] Sheet and Title Block - ATTREQ variable setting could prevent being prompted for attribute values.
  • [D4232] Shift Points - A crash could result from entering an invalid entry in the From Point or To Point fields.
  • [D3001] Surface Modeling - The Extrapolate Surface command could result in a crash in some situations.
  • [D2844] Figures Database - Running the Rotate, Shift, or Scale commands from within the Active Coordinate Editor could result in arcs being removed from the figures database.
  • [D4053] Nikon Import - Alphanumeric Point IDs were not read from Nikon 500 and 700 files.
  • [D2813] Nikon Import - The Coordinate Order option was not honoured when reading Nikon 700 files. Coordinate Records are now imported as either NEZ or ENZ depending on this flag.
  • [D4085] Point Block Import - Alphanumeric Point IDs were not read from point blocks when using the Import Softdesk/Carlson/EaglePoint/Benchmark Point Blocks commands.
  • [D3957] Feet & Inches Entry - The Feet & Inches scaling feature added in SP1 (v10.2.0) introduced a problem for some drawings, where LUNITS=3 (Engineering) or LUNITS=4 (Architectural) because these two settings use the inch as their base unit rather than the foot, so it is no longer applied in these drawings. Note, it is still highly recommended to use the LUNITS=2 (Decimal) setting.

 

(463 vote(s))
Helpful
Not helpful

Comments (0)