Knowledgebase
MapScenes 2010 Release Notes
Posted by Brian Sloman on 22 July 2015 09:29 AM

Release History

MapScenes Forensic CAD / Capture 2010 v10.2.0 - October 2, 2009

MapScenes Forensic CAD / Capture 2010 SP1 v10.2.1 - June 25, 2010

MapScenes Forensic CAD / Capture 2010 SP2 v10.3.0 - August 20, 2010

MapScenes Forensic CAD / Capture 2010 SP3 v10.4.0 - August 26, 2011


Important Notes

Activating or Updating your USB License Key

If you are licensing MapScenes for the first time, or if you are upgrading from MapScenes 2006 or previous, you will need to activate your new USB License Key using the USB License Manager program on a computer with internet access.

If you are upgrading from MapScenes 2008, you will need to update your existing USB License Key using the USB License Manager program on a computer with internet access.

A copy of the USB License Manager program is automatically installed with MapScenes 2010, or it can be installed separately onto another computer from your MapScenes 2010 installation disc or downloaded from our online Helpdesk system.

Please refer to the following topic for detailed instructions about activating or updating your key.

You might not be required to update your USB key to run certain MapScenes Service Pack updates. For a detailed explanation of MicroSurvey's Maintenance Subscription Support Plan (MSSP) program, and how we use product version numbers and USB keys, you can can refer to the following online article.

If your Maintenance Subscription has not yet expired, you can use the USB License Manager to update your key to work with the most current version. You can confirm the expiry date for the MSSP by going to the About screen found in the Help menu. Each USB License Key has its own maintenance subscription plan, so if you have multiple keys it is possible that they may each have a different expiry date. If your MSSP has expired, you can phone us at 1-800-668-3312 to renew it. Without a current maintenance subscription plan, you will not be able to update your key to work with the new version.

MicroSurvey Transfer Program for Evidence Recorder Users

Evidence Recorder users need to download a copy of the MicroSurvey Transfer program to simplify the process of transferring Evidence Recorder projects between your data collector and MapScenes 2010.

If you have a copy of MicroSurvey Transfer already installed from use with MapScenes 2008 or older, you will need to update it to recognize MapScenes 2010. Previous versions of MicroSurvey Transfer will NOT show MapScenes 2010 as a sync option in the Options screen.

The MicroSurvey Transfer program has not changed since MapScenes 2010 10.2.0. This is only necessary for users who are setting up communications between Evidence Recorder (any version) and MapScenes 2010 for the first time.

MicroSurvey Transfer can be installed from your MapScenes 2010 installation disc or downloaded from our online Helpdesk system.

Note: A copy of Microsoft ActiveSync (for Windows XP or earlier) or Microsoft Windows Mobile Device Center (for Windows Vista or newer) must be installed before MicroSurvey Transfer can be installed. Both can be downloaded free from Microsoft.

MicroSurvey License Server for Network License Users

Users who have purchased a network license will need to install a copy of the MicroSurvey Network License software. The MicroSurvey Network License Server program has not changed since MapScenes 2008 8.0.0. This is only necessary for users who are setting up a MapScenes 2008 or newer network license for the first time.

If you have purchased a Network License and are setting it up for the first time, you can download the Network License Server application from our online Helpdesk system.

Note: You will be required to enter a password in order to install the Network License Server.

System Requirements

MapScenes 2010 is compatible with 32-bit and 64-bit versions of Microsoft Windows XP SP3, Windows Vista SP2, and Windows 7.

MapScenes 2010 does not have any hardware requirements above and beyond what is required by your version of Microsoft Windows, except for a compatible video card for the 3D Rendering, Capture Animation, and Point Cloud engines. Please refer to the following webpage for a list of compatible video cards, as indicated under the "OGL" column:
http://developer.techsoft3d.com/hoops/hoops-visualize/graphics-cards/

Windows Vista / Windows 7 Users

Vista/7: Run as Administrator Once

If installing on Windows Vista or Windows 7 you must run the program with "Elevated Admininstrator" enabled the first time MapScenes 2010 is run, even if you are already logged in with "Administrator" access on the computer. Once this is done once, MapScenes can be run by any user on the computer, including those who don't have administrative accounts.

To accomplish this, once the program is finished installing do the following:

  1. Right click on the MapScenes 2010 icon.
  2. Choose "Run as Administrator"
  3. Open or create a new drawing.

Vista/7: What's This? Help

If you wish to use the MapScenes "What's This? Help" feature under Windows Vista or Windows 7, you will need to download and install an update from Microsoft. Please refer to the following Microsoft Knowledge Base article for more information.

Please note, that the main MapScenes Help file will work without this update.

Vista/7: Help Movies

To play the MapScenes 2010 help movies under Windows Vista or Windows 7, you may need to open up the Help file by going to Start | Programs | MapScenes 2010 | Help. If you open the help file from within the MapScenes Help pulldown menu, then Vista's security policies will sometimes prevent the help file viewer from launching the movie player.


Online Resources

Release Notes

For the most up-to-date copy of the MapScenes 2010 Release Notes document please visit the MapScenes 2010 Release Notes topic in our online helpdesk.

Frequently Asked Questions

For a list of Frequently Asked Questions and Tips for New Users, please visit the MapScenes 2010 Frequently Asked Questions topic in our online helpdesk.

Upgrade Notes

For a guide on upgrading from a previous version of MapScenes, please visit the MapScenes 2010 Upgrade Notes topic in our online helpdesk.

Known Issues

For a list of known issues please visit the MapScenes 2010 Known Issues topic in our online helpdesk.

Training Movies

For training movies that you can watch online or download for offline viewing, please visit the MapScenes Training Movies topic in our online helpdesk.

Technical Support

MicroSurvey provides free 24x7 self-support to all MapScenes users via our online helpdesk at http://helpdesk.microsurvey.com/ where you can find knowledgebase articles, downloads, and a troubleshooter. This is a good starting point for any problems that are now answered in your Help file and Manuals.

For technical support, please visit our helpdesk at http://helpdesk.microsurvey.com/ to submit a helpdesk ticket to our technical support staff. If you do not have internet access you can phone our office at 1-800-668-3312 or 1-250-707-0000 and a ticket can be entered for you.

Technical Support is provided free of charge for 90-days following the purchase of your MicroSurvey product. Following this introductory period, additional technical support is available via your Maintenance Subscription Support Plan (MSSP).

To purchase or renew your MSSP, please phone MicroSurvey Software at 1-800-668-3312 or 1-250-707-0000.

Feature Request Forum

Help us make your MapScenes product better! To submit a feature request, or to vote on other users' feature requests, please visit our Feedback Forum at feedback.microsurvey.com.


MapScenes Forensic CAD / Capture 2010 (v10.2.0)

New Features

  • Updated CAD Engine - IntelliCAD 6.6
    • MapScenes 2010 is now built on the latest IntelliCAD engine, IntelliCAD 6.6. For a list of IntelliCAD fixes, see below.
    • Performance enhancements
      Performance has been enhanced considerably when using real-time zoom, real-time pan, and saving drawings.
    • Toolbar and menu icons
      The IntelliCAD user interface has been enhanced with new 24-bit icons for all color toolbar icons and menus.
    • Use polar tracking
      Polar tracking is a new tool used to help you draw with precision. When polar tracking is turned on, guides display on the screen automatically at specified polar angle increments.
    • Check the spelling of text
      You can check the spelling of single-line text, multiline text, paragraph text, attributes, attribute definitions, and dimension text. Additional features include loading dictionaries from different sources, including various languages, and adding your own words to a custom dictionary.
    • Copy multiple entities
      Now it’s easier to copy multiple entities. IntelliCAD defaults to prompting for additional copies of selected entities during the Copy command.
    • Work with additional image formats
      The number of image formats available for drawings has been expanded. You can include images in the following formats: ECW, JPG 2000, ERS, ALG, HDR, DAT, DOQ, FST, NTF, ASC, DEM, DT0 and DT1, and HDF (including MET, L1R, and L1G).
    • Layer toolbar
      You can now use the Layer toolbar to specify layout-specific layer settings. The Layer toolbar dynamically sizes, making it easier to manage large layer lists or drawings with long layer names.
    • Customize the status bar and menus using DIESEL
      You can use DIESEL from the command line, in MNU menu files, and in LISP to customize the status bar and menus.
    • Use new and enhanced system variables
      New or enhanced system variables include: AUTOSNAP, COPYMODE, DCTCUST, DCTMAIN, DCTMAINPATH, DIMTFAC, POLARADDANG, POLARANG, POLARDIST, POLARMODE, SNAPTYPE, and TRACKPATH.
  • Query Angle between Two Lines
    • Calculates a 3-point inverse to determine the interior or exterior angle between two lines, and displayes the angle to you in both decimal degrees and degrees-minutes-seconds.
    • New command: _MS_SHOW_ANGLE (MsCalc | Calculate Lines | 3-Point Inverse)
  • Layer States
    • Save and Restore Layer States in your drawing. A layer state contains a snapshot of the state of all layers in your drawing (including: On/Off, Frozen/Thawed, Locked/Unlocked, Color, Linetype, Lineweight) at that point in time, so that when loaded all of these layer settings get restored to the state they were in when that layer state was saved.
    • If the layer state file is imported into a new drawing, it will automatically create the layers that are missing.
    • New command: _LAYERSTATE (MsTools | Layer Control | Layer States)
  • Drawing Cleanup Wizard
    • Quickly cleanup your drawing with this new command which combines various CAD commands and variable settings into one easy-to-use interface. Purge unreferenced objects to make your dwg filesize smaller, delete zero- length lines and empty text which can cause zooming problems, deleted undesired entity types, explode blocks, bind external references, setup view options, and more!
    • New command: _DWG_CLEANUP (MsTools | Drawing Cleanup Wizard)
  • Online Update Notification
    • MapScenes now includes a "Check for Updates" feature. This new command is available in the Help Menu.
    • MapScenes is now configured to silently look for updates according to the preferences setup by the user. When an update is available the user will be notified. Updates are automatically downloaded and installed.
    • New command: _UPDATECHECK (Help | Check For Updates)
    • New command: _UPDATECHECK_CFG (Help | Auto Update Preferences)
  • Improved Auto-Add Points to Objects
    • Now works with Polylines, LWPolylines, and 3DPolylines.
    • Improved command: _AUTOP (MsPoints | Auto-Add Points to Objects)
  • Updated Vehicle Database Browser
    • Scene Analysis tool contains the most recent vehicle specifications database, including all 1971-2009 models and some 2010 models.
    • Improved command: _ANALYSIS (MsTools | Scene Analysis)
  • Side-by-Side Installations
    • You can now install both MapScenes Forensic CAD 2010 and MapScenes Capture 2010 onto the same computer and they will run independently from one another. Similarly, uninstalling one will not affect the other. Note: your USB Key must be licensed for the appropriate version.

Important Fixes (MapScenes 2010)

  • Coordinate Calculations
    • [2394] MSAudit - Running an MSAudit would cause the labels for any points created using the Auto-Add Points to Objects command to disappear.
    • [2486] Inverse - Vertical distances were being scaled by the Output Scale Factor if it was turned on. Only the horizontal components of the distances are now being scaled.
    • [2443] Point IDs - Alphanumeric Point IDs containing leading zeros after a letter would not increment as expected. For example, a01 would increment to a2 instead of a02.
    • [1346] Shift Points - Using the _ms_shift command to shift points causes database arcs on those points to be removed from the drawing.
    • [1347] Scale Points - Using the _ms_scale command to scale points causes database arcs on those points to be removed from the drawing.
    • [1348] Rotate Points - Using the _ms_rotate command to rotate points causes database arcs on those points to be removed from the drawing.
    • [2829] Rotate Points - Rotating Points from the Active Coordinate Editor could cause an incorrect north shift to be applied to the results if a 3D rotation point was snapped onto.
    • [2816] RTS Points - Output from the _rts command to the command history and log file was improved to reduce unnecessary and redundent information.
    • [2802] Store & Edit Points - If multiple points are at or near the same coordinate (within a distance of 0.0001) then picking on one point could select another point. (A similar issue still exists in the _connect_points command.
    • [1156] Active Coordinate Editor - If the Point Protection dialog comes up due to changing a point, but then Cancel is selected, the coordinate shown in the active coordinate editor is now reset to its previous value.
    • [2505] Active Coordinate Editor - Change Selection Layer command now enforces standard layer naming conventions.
    • [2598] Active Coordinate Editor - It is no longer possible to ignore the Point Protection dialog if it comes up, which would result in a crash if additional Point Protection events were triggered.
    • [2786] Active Coordinate Editor - Tiling the Active Coordinate Editor window when a drawing is not open would result in a crash.
    • [2803] Active Coordinate Editor - Using the Draw Table In Drawing From Selection command from within the Active Coordinate Editor would result in a crash if another command was currently active.
    • [2359] ASCII Import - Importing points whose descriptions contain commas now import completely without parsing the description at the first comma in it.
    • [2133] ASCII Import/Export - Help buttons on the ASCII Import and ASCII Export dialogs for the "Coordinates Column Specific" format was not opening the Help topic.
    • [2057] ASCII Export - A crash could occur if too many decimal places were exported into the ASCII file. You must now specify between 0 and 12 decimal places.
  • Line/Arc Calculations
    • [2345] Line Labels - Bearing Labels with 4 or more spaces after the Quadrant would cause a crash.
    • [2481] Line Labels - Occasionally line labels would be drawn over top of the line rather than offset from it.
    • [2443] XYZ Coding - Alphanumeric Point IDs containing leading zeros after a letter (ie, "a01") could cause the program to lock up when processing XYZ-coded linework.
    • [2726] CAD Lines/Curves Dialogs - Grouped entities now work with the CAD Lines or CAD Curves dialog, to retrieve information on the entity in the group which was selected. Ensure SORTENTS variable is set to 96.
    • [0608] Line and Curve Tables - The "Auto-Add Database" system toggle is now honored when creating line/curve table entries, so you can control whether or not points get created in the database.
    • [2992] Line and Curve Tables - Line Tables are now created showing lines in the order you selected them. Ensure SORTENTS variable is set to 96.
    • [3008] 3D Offset - This command did not work correctly in drawings with multiple copy mode enabled.
  • Raw Measurement Calculations
    • [2498] Very long descriptions in an Evidence Recorder or TDS RW5 Raw file would cause a crash. When this occurs, the description is now shortened to a valid length, a note record is added to the traverse indicating it was shortened, and a pop-up message also appears to notify you.
    • [2499] If a traverse contains any sideshots before the first setup, the traverse can no longer be re-coordinated because it contains invalid data.
    • [3060] Evidence Recorder / TDS Raw Import - Angles read in an Evidence Recorder or TDS RAW/RW5 file were being rounded to the nearest second. This no longer occurs.
  • Surface Modeling
    • [2526] MSFlatten - If a profile is drawn without a grid, the baseline is drawn with an invalid elevation which can lead to a crash if viewed through the CAD Lines Dialog.
    • [2136] Erase Selected - This command was missing from the MsModeling | Utilities | General Utilities menu in MicroSurvey CAD 2008.
    • [2549] Surface Operations - The Multiply operator appeared be missing from the list because it was shown as a blank entry.
    • [xxxx] Drape Configuration - A Drape Step Size value could not be entered normally into the Configuration Settings | Draping dialog.
    • [2635] Area and Volume unit labels in the Configuration Settings dialog would only accept numeric values which is not desired, it now accepts alphanumeric values such as "Acres" or "Cu.Yds.".
    • [2744] Using the Draw Dots options in the _grd command was drawing Lines instead of Dots, this has been corrected.
    • [1632] Using the "Configure Colors" button in the _paint command did not work properly the first time it was run.
    • [2817] Using the "Configure Colors" button in the _paint command would cause the program to crash later when using the _exit command to close the program.

      Note: The three following items are "under-the-hood" changes only, there is no change to the interface/procedures/options when running the surface modeling routines in MicroSurvey CAD 2009 compared to previous versions.

    • [2181] Settings - The Configuration File Options dialog has been updated and improved, it was converted from LISP to C++. (New command: _SURF_CNFG_DLG)
    • [2181] Settings - The Configuration Settings dialog has been updated and improved, it was converted from LISP to C++. (New command: _CNFG_FILE_DLG)
    • [2152] The entire set of Surface Modeling routines have been updated and improved, they were converted from C to C++ to allow for upcoming Unicode capabilities.
  • LISP Programming Extensions
    • [2492] The following lisp commands were not working: (set_scale_factor xx.xx), (set_coordinate_decimal_places x), (set_stationing_decimal_places x), (set_slope_decimal_places x).
  • Other Fixes
    • [2634] Cutout Drawing Detail - The Cutout Drawing Detail command did not work, it would give an "Error: rejected function" message.
    • [2777] Unnamed Drawings - A crash which could occur when working in a new unnamed drawing (created with the _new or _newwiz commands) has been fixed.
    • [2864] Layer Control, Copy - The Copy command in the MSTools | Layer Control menu or MSLayers toolbar did not complete correctly (manually pressing Enter was required) in drawings with multiple copy mode enabled.
    • [F848] Layer Control, Thaw - The Thaw command in the MSTools | Layer Control menu or MSLayers toolbar had a performance problem which has been fixed.
    • and more...

Important Fixes (IntelliCAD 6.6)

  • Open and save files
    • IntelliCAD now uses the DWGdirect 2.5.2 libraries.
    • QSAVE works properly now when zoomed in closely in a drawing.
    • A performance issue when saving the drawing file, caused by querying printer driver details, has been fixed.
    • Some network configurations prevented drawings from being opened from a network drive even if security permissions had been properly configured.
    • Saving a drawing after exploding its contents no longer produces errors.
    • In some specific cases, the following items were inconsistent when opening and saving drawings, which have been fixed: VIEWCTR, elliptical arcs, splines, text thickness, draw order.
    • Improved behavior when attempting to reopen an already opened drawing file.
    • When opening a DWG 2006 file created originally in Autodesk® AutoCAD®, the ATTRIB no longer changes in IntelliCAD. Also, hard pointer is no longer changed from LEADER to MTEXT.
    • Space characters were being removed from block attributes in some drawings from Autodesk® AutoCAD 2010.
    • Support for display of Table entities in DWG files from Autodesk® AutoCAD® has been added - they now display as Proxy entities.
    • Dynamic Block entities in DWG files from Autodesk® AutoCAD® are now being saved back into the drawing file properly and are not converted to normal Block entities.
    • Block Attributes with "Middle" justification format now display correctly.
  • Import and export files
    • When exporting to PDF, IntelliCAD now includes external references and OLE objects.
    • Exporting to 3D DWF works correctly now.
    • OLE objects are exported to PDF files correctly now.
  • Raster images
    • Attaching a raster image now properly releases memory.
    • Stretching images with clipped boundaries could cause IntelliCAD to crash.
    • TFW positioning files are used correctly.
    • Images can now be attached that have non-English file paths.
    • Image file sizes no longer change when saving drawings.
    • Images that cannot be found or loaded no longer cause delays on REGEN.
    • Fixed problem when attaching invalid images.
    • You can now attach images even when FILEDIA is turned off.
    • The Fade option in the image manager worked in reverse if the background color is White - this now works as expected.
    • A display issue with monochrome images where the white pixels would sometimes have a blue tinge in them has been fixed.
    • A display issue with monochrome images where the black and white pixels would spontaneously invert has been fixed.
  • Layers
    • Inconsistencies in distinguishing layers named "0" and "00" have been corrected.
    • Layers in external references now appear on the Properties toolbar.
  • Blocks
    • Fixed block selection when block is coincident with a line.
    • Files created with the WBLOCK command save preview images now.
    • When inserting a block, the Z-scale factor is now set to the same value as the X- and Y-scale factors if they are equal. Previously, the Z-factor was set to 1 if not explicitly defined.
    • Fixed problem inserting a block containing a wipeout.
  • Dimensions
    • DIMFAC implemented for dimension tolerances in Dimension Settings dialog.
    • In some cases, dimension positions were incorrect; this has been fixed.
    • Support for Dimension Tolerance Alignment formats has been added.
    • Dimensions drawn in Layout space now work consistently.
  • Text
    • ASCII line text characters interpretation problem fixed.
    • In some cases entering multiple DTEXT entities resulted in only the last entity being created; this has been fixed.
    • Some Multiline Text paragraph formatting codes were being displayed as text in the drawing - these embedded format codes no longer appear in the drawing.
  • Hatching
    • Problem with loading hatches fixed.
    • Improved hatch stability for certain complex boundary conditions.
    • Invalid/corrupt scale factor values in hatch entities could lead to the hatch not displaying properly, generating errors on save, and crashes on audit - this is now detected and handled correctly.
    • Invalid/corrupt hatch entities could cause the program to generate errors on open and crash on audit or recover - Opening such a badly corrupted file is now prevented, and the Recover command can be used to repair the drawing.
  • View drawings
    • Zoom Extents fixed to work properly in drawings with proxy entities.
    • Fixed viewing inconsistencies when zooming in and out in paperspace.
    • Fixed viewing inconsistencies when undoing changes made in paperspace, if model space has a view twist applied.
    • Anonymous blocks did not display properly in some cases; this has been fixed.
    • Block attributes now display properly during drag operations.
    • Significant performance increase for toolbar controls when running certain LISP and SDS routines.
  • Printing
    • IntelliCAD no longer changes the current directory after loading a printer configuration file.
    • Fixed print preview and printing of specific attributes.
    • Print Preview now displays print offsets correctly.
    • Drawings print correctly with 1 to 1 scale.
    • The "Select Origin" button now correctly sets the print offset values in paper units (Inches or millimeters).
    • The -PLOT command now correctly defaults to the previously configured "Print Lineweights" option at the command line prompt.
    • Entities no longer temporarily disappear (taking on the color of their print style) requiring a regen after printing.
    • Entities outside the selected Print Area are no longer printed if the "Print only area within specified window" option is enabled.
  • External References
    • A severe performance problem due to redundant font substitutions in XREF drawings has been fixed.
    • A crash which could occur on saving drawing after Binding an XREF has been fixed.
    • Specific drawing was unable to load as an external reference until fixed text height was set to 0.
  • Digitizer Tablet Support
    • TABLET command allows non-interactive input and wrapping of tablet calibration and other routines.
    • Significant startup performance improvement when digitizer is installed but disconnected.
    • A crash on startup due to improper tablet configuration is now prevented.
  • APIs
    • COM: Fixed problem canceling an active command.
    • COM: Layouts can no longer be assigned a duplicate name.
    • COM: Plotmanager.setpapersize, Plotmanager.Getpapersize, and Points.Add now work properly.
    • LISP: Using the Lisp entity snap nearest function in a drawing with an XREF underlay containing an empty MTEXT entity, IntelliCAD no longer hangs.
    • LISP: Implemented RGB color support for the CHPROP and CHANGE commands.
    • LISP: LISP environment settings are preserved per drawing when opening additional drawings.
    • DCL: problem with dlg_slide_image fixed.
  • Other fixes
    • Full color persists for layers after turning layers on and off.
    • Hiding three-dimensional entities could fail inside viewports.
    • Entities with Xdata attached can now be trimmed and edited properly.
    • IntersectWith now works properly with ray entities.
    • AUDIT works properly for drawings that contain external references.
    • Regions created from polylines that contain arc segments are exploded correctly.
    • Fixed crash after using CTRL+V after UNDO.
    • Fixed problem when running a command and switching between two drawings.
    • Fixed trimming a circle at very large coordinates.
    • Fixed crash when undoing the deletion of certain proxy entities.
    • Linking problem fixed for entities with a hyperlink assigned.
    • Search path order for finding drawings fixed.
    • Snapping to a point twice no longer causes crash.
    • WIPEOUT command fixed to better hide lines.
    • New User-Defined Coordinate Systems can now be created from the IntelliCAD Explorer window.
    • Entity Selection - The PICKSTYLE variable is now a global profile setting and is not drawing specific.
    • Entity Selection - Selection Sets were being created with the entities sorted in a different order from which they were selected. This caused some custom LISP programs to not function correctly when a specific order was expected.
    • Program Interface - When changing the current layer via Entity Properties toolbar, the color for ByLayer shown on the toolbar did not immediately update to show the new layer's color. (Note: the correct color was actually being used when drawing entities.)
    • Program Interface - In some situations the maximized window was positioned incorrectly, leaving a small gap the width of the taskbar along the top of the screen. This is now prevented and the window should always maximize correctly.
    • A crash in the Customize command which could be caused by pressing "Add command" without first selecting a command to add has been fixed.
    • and more...

MapScenes Point Cloud 2010 (v10.3.0)

New Features

  • MapScenes PointCloud 2010
    • MapScenes PointCloud 2010 adds new PointCloud technology for working with 3D Laser Scanner and LiDAR data sets to our proven MapScenes Capture 2010 engine. Collect evidence, draw linework, and produce animations directly within your scan data!

MapScenes Forensic CAD / Capture 2010 SP1 (v10.2.1)

New Features

  • Feet & Inches Entry
    • Distance values entered in feet and inches like 1'6" are normally interpreted by CAD as 18 (inches), we modified this behaviour to interpret it as 1.5 (feet) to maintain consistent units with the rest of the program.
    • Improved commands: All IntelliCAD Draw or Modify commands where you can enter distances: line, polyline, offset, chamfer, etc..
  • Photo Notes
    • Supports the new "Photo Notes" feature in Evidence Recorder 7, whereby photographs can be taken at the scene using the new Nautiz X7 data collector and attached directly to your points database.
    • Any Photo Notes taken with Evidence Recorder 7 will be automatically imported into your project database during the SyncWizard import.
    • View or Delete your Photo Notes directly from the Store/Edit Points dialog, or from the Active Coordinate Editor.
    • Improved command: _SYNCWIZARD (MsMeasurement | Evidence Recorder SyncWizard)
    • Improved command: _EDITP (MsPoints | Store and Edit Points)
    • Improved command: _COORDEDIT (MsPoints | Active Coordinate Editor)
  • RPN Calculator
    • An RPN Calculator is available to assist you with any manual calculations.
    • Stack based interface similar to the popular HP48 calculator.
    • Calculate with numbers, distances, angles, bearings, azimuths
    • Convert distances automatically between Meters, Feet, and US Survey Feet
    • Convert angles autimatically between Decimal Degrees, Degrees-Minutes-Seconds, Radians, Grads/Grades/Gradians/Gons
    • Add or subtract angles to Azimuth or Bearing directions
    • New command: _CALC (MsTools | RPN Calculator)
  • Spanish Version
    • A Spanish version of MapScenes Forensic CAD 2010 and Capture 2010 is now available.

Notable Improvements

  • Translated Help Files - Help files can now be translated on-the-fly and read in 31 different languages. (An internet connection is required, high-speed recommended.)
  • Updated Rendering Engine - The HOOPS 3D rendering engine has been updated to the latest version (v18.02) for improved rendering performance and stability.

Important Fixes

  • MapScenes Fixes
    • [3373] Surface Modeling - A crash could occur when extracting cross sections, if the surface name contained a space.
    • [3082] Surface Modeling - A crash could occur when removing points from DTM via the Active Coordinate Editor.
    • [2961] Surface Modeling - The "Enable Range" contour configuration option checkbox behaviour was backwards, making it confusing to set the Minimum and Maximum values.
    • [2917] Surface Modeling - The "Densify Step Size" extraction option had a display issue making the Auto vs Size options confusing to select.
    • [xxxx] Various broken Help buttons throughout the program have been corrected.
    • [xxxx] Various spelling errors throughout the program have been corrected.

MapScenes Forensic CAD / Capture 2010 SP2 (v10.3.0)

New Features

  • AutoCAD 2010/2011 DWG/DXF Support
    • MicroSurvey CAD 2010 can now automatically convert and open 2010 DWG/DXF drawing files, then Save them as R12-2007 DWG/DXF format.
    • Or, use the standalone IntelliConvert conversion utility to manually convert R12-2010 DWG/DXF files.
  • New Clipboard Copy/Paste Commands
    • When entities are copied to the clipboard you can now specify a Base Point. In comparison, the COPYCLIP (Edit | Copy) command automatically calculates the Base Point as the bottom-left corner of a virtual rectangle bounding the selected entities.
    • New command: _COPYBASE (Edit | Copy with Base Point)
    • When entities are copied to the clipboard you can now paste them to the original coordinates they were copied from without prompting for an insertion point. In comparison, the PASTECLIP (Edit | Paste) command always prompts for an insertion point.
    • New command: _PASTEORIG (Edit | Paste to Original Coordinates)

Notable Improvements

  • Active Coordinate Editor - When running the Change Selection Layer command, the four checkboxes for Point, Elevation, Description, Point Number are now unchecked by default, to prevent accidently changing their layers.
  • AutoMap Library - You can now automatically draw an Ellipse, Double Ellipse, or Rectangle around your Point ID labels.
  • AutoMap Library - You can now specify X and Y offset distances for the Description, Point ID, and Elevation labels in the AutoMAP Library, this will help with spacing out the labels for Design and Stake points, etc.
  • AutoMap Library - You can now process a point range (pt..pt) in addition to the previous method of processing all connections
  • AutoMap Library - A Save prompt has been added when pressing the "New Library" button, to avoid accidental data loss while customizing your Automap Library if you accidentally click "New Library" instead of "New".
  • Locked Points - The "Protected" column in the Active Coordinate Editor is now relabeled as "Locked" to avoid confusion between it and the global Point Protection feature.
  • Locked Points - A "Locked Point" checkbox is now available in the Store & Edit Points dialog, which corresponds to the "Locked" (formerly "Protected") option in the Active Coordinate Editor.
  • MS Backup - A save prompt has been added at the start of the MSBACKUP command, because it will copy the most recently saved drawing. Previously, you had to manually Save before Backup.
  • Traverse Re-coordination - A "Do not replace descriptions with field values" option has been added, this will prevent point descriptions in your database from changing when a traverse file is recoordinated.
  • Updated IntelliCAD Engine - The IntelliCAD 6.6 CAD engine has been updated to the latest version for improved performance and stability.
  • Updated Rendering Engine - The HOOPS 3D rendering engine has been updated to the latest version (v18.10) for improved rendering performance and stability.

Important Fixes

  • MapScenes Fixes
    • [3895] Materials - An error message (Windows Vista/7) or a crash (Windows XP) could occur when running the Materials command.
    • [3926] Baseline/Offset - It was not possible to specify positive offsets to be right of the baseline.
    • [3928] Baseline/Offset and Triangulation - Unrelated record types were listed in the Edit menu and the Right-click mouse menu.
    • [3898] RPN Calculator - The new RPN Calculator command was missing from the menus and toolbars.
    • [3660] Scene Wizard - The Recent Files List in the Scene Wizard did not show any files.
    • [3698] Scene Wizard - The obsolete "Website Newsletter" and "Check for Service Packs" buttons were removed from the Scene Wizard.
  • IntelliCAD Fixes
    • [82466] A crash can occur when zooming/panning with the mouse while the program is under stress
    • [83110] A crash can occur when an sds_entget command is run on an SORTENTSTABLE entity (for example, this occurs after undoing a draworder command)
    • [85143] A crash can occur while moving entities
    • [82468] Audit/Recover - does not reset the count of objects audited, so the entity count ends up being multiplied in subsequent audits
    • [82568] Audit/Recover - auditing a corrupted drawing containing specific errors can cause it to lose layouts
    • [81650] Copy/Paste - Two new commands have been added, _COPYBASE (Edit | Copy with Base Point) and _PASTEORIG (Edit | Paste to Original Coordinates)
    • [80930] Blocks - A crash can occur when using the "Previous" selection set after exploding a block
    • [82737] Blocks - A crash can occur when Unloading and Reloading an Xref
    • [82851] Blocks - Blocks with "Uniform" scale option do not display correctly when mirrored
    • [82919] Blocks - Blocks with a negative extrusion vector (3d rotation) cannot be moved using Grips
    • [83128] Blocks - A crash can occur when selecting Unnamed blocks for COPYCLIP and WBLOCK commands
    • [84631] Blocks - A crash can occur while purging anonymous blocks
    • [83083] Dimensions - Angular Dimensions can temporarily display incorrectly while moving via grips, for example showing 89°59'60.0" instead of 90°00'00.0"
    • [83126] Dimensions - DIMLIN and DIMALI Dimensions do not allow you to use entity snaps for the second point
    • [83366] Dimensions - AutoCAD MLEADER Multileader entities do not display
    • [85285] Display - REDRAW / REGEN difference in layout tab on attached drawing
    • [85330] Display - mouse cursor can disappear in certain situations
    • [83044] Entity Properties - A message "The parameter is incorrect" will pop up when selecting the Layers list on the Entity Properties toolbar, if entities from multiple layers are currently selected
    • [83768] Entity Properties - When changing color of a polyline through the Color list on the Entity Properties toolbar, too many entities can change color
    • [83869] Entity Selection - Window Polygon selection method selects all of the inserts in the drawing
    • [81746] File I/O - After printing, printer settings can bog down saving of drawings
    • [83065] File I/O - Cannot open any files where the filename contains a % character
    • [84487] File I/O - Attached drawing has trouble saving
    • [84925] File I/O - 2010 DWG/DXF IntelliConvert utility implemented for converting 2010 DWG drawings to 2007 DWG
    • [85352] File I/O - 2010 DWG/DXF automatic file conversion method implemented on opening drawings
    • [83164] Hatching - Associative Hatch Patterns are unassociated if the boundary is grip edited
    • [83737] Hatching - Hatch Pattern previews do not display in Windows x64 (or anytime the installation folder contains parentheses)
    • [84818] Hatching - Color SLD files are displayed as Black and White
    • [83062] Lisp - "command" command loses precision of numeric arguments being passed in
    • [83367] Lisp - A crash can occur when unloading a custom application
    • [83370] Lisp - "command" command is not correctly cancelled by escape
    • [83743] Lisp - Pasting a multiline Lisp expression into the commandline to run it does not work
    • [83744] Lisp - Entities on a locked/frozen layer can be erased via Lisp
    • [84729] Lisp - Corrupted pointer passed to SDS_CBCMDEND callback when a command results in changing the current drawing
    • [85551] Lisp - Function could improperly terminate if offset is called with an empty selection set
    • [79366] Printing - Print Window selection does not allow you to use entity snaps for the second corner
    • [81746] Printing - After printing, printer settings can bog down saving of drawings
    • [81964] Printing - Print Window area does not cut off entities at the selected window edge
    • [82455] Printing - Print Area option does not work if "Save changes to Layout" is not turned on
    • [82503] Printing - Ricoh/NRG/Nashuatec printers can cause the program to crash on print
    • [82662] Printing - Ricoh/NRG/Nashuatec printers can cause the program to crash on save
    • [82833] Printing - Print settings are not properly saved into layouts
    • [82312] Printing - When using "Print upside down" option from layout space, model space entities may not appear through viewport
    • [83155] Printing - After printing, entities are displayed using the printed color from .CTB print style table file until a REGEN is run
    • [84258] Printing - Specified paper tray is not remembered
    • [85271] Printing - Standard print scales are not saved properly
    • [84341] Raster Images - A crash can occur when clipping image if an invalid option is specified
    • [82433] Snaps - Entity snaps do not work properly for PFACE entities within a block, if UCS is not World
    • [82058] Snaps - Apparent Intersection entity snap does not work for extended intersections
    • [81765] Snaps - Polar Tracking interferes with window selection
    • [83371] Snaps - Polar tracking is turned off after temporary using ORTHO snap with SHIFT key
    • [82168] Text - changing Justification property of multiple text entities causes their insertion points to change to 0,0,0
    • [82513] Text - MTEXT containing negative indentation does not display correctly
    • [82681] Text - Text containing Russian fonts display the last character incorrectly
    • [83162] User Profiles - A crash can occur when using custom menu commands with an invalid reference
    • [82891] User Profiles - When running multiple instances of the program each with a different current profile, the profiles can contaminate each other in the registry
    • [82792] User Profiles - Custom menus containing a very large number of commands with many toolbars and submenus do not work, picking the commands at the bottom of the menu may not do anything
    • [84616] Viewports - layout space viewports can be automatically activated
    • [82567] Viewports - -LAYER Freeze command in a layout viewport causes the layer to be Frozen in All Viewports not just the Current Viewport

MapScenes Forensic CAD / Capture 2010 SP3 (v10.4.0)

New Features

  • [F1277] XYZ-Coding - When processing XYZ-Codes to draw 3D linework, arcs are now drawn as 3D polylines with many vertices to approximate a 3D arc. When processing XYZ-Codes to draw 2D linework, arcs are still drawn as 2D arcs as before.
  • [F1296] XYZ-Coding - When processing XYZ-Codes, figures will now be drawn as a single polyline or as individual line and curve segments, per AutoMap Library settings.
  • [F1320] 3D Curves - When using the _3DCURVE (MsTools | Draw 3D Curve) or _3DPOLY_TO_3DCURVE (MsTools | Convert 3DPolyline to 3DCurve) commands, the number of interpolated vertices can now be controlled either by specifying an approximate inter-vertex distance (as before), or by specifying the number of vertices per curved segment (new, defaults to use the "SPLINESEGS" drawing variable).
  • [F1392] First Available Point - A new command called FAP (MsPoints | List Points Used and Unused | First Available Point) is available for querying the first available point ID in any range and setting that as the Next ID.
  • [F1335] Inverse - You can now use the INVERSE command to calculate between any two selected points in the drawing, it is no longer restricted to only using points stored in the coordinate database.
  • [F1386] Licensing - You can now "snooze" the startup message reminding you about an expired or nearly-expired maintenance subscription plan for 14 days so that it does not appear every time you start the program.
  • [F1391] Tables - Line Table command now has a "Use Point IDs" option to include the point IDs directly in the table body, rather than creating named references like "L1" or "C2".

Notable Improvements

  • Updated Vehicle Specifications Database - The Vehicle Specifications Database, published by the Canadian Association of Road Safety Professionals, has been updated to the latest version (v2011.2) to include all 1971-2011 models and some 2012 models.

Important Fixes

  • MapScenes Fixes
    • [D4041] Active Coordinate Editor - a crash can occur when opening the coordinate editor, if a database record does not have the expected number of characters.
    • [D2069] Active Coordinate Editor - a crash can occur when opening the coordinate editor, if the total length of the path and filename plus the point id is very long.
    • [D4017] AutoMap Library - after selecting the "Skip XYZ Connection" option, a "Blank Description Codes(XYZ-._)?" prompt would appear anyways.
    • [D3112] Leica GSI Import - store point records were not created in the traverse file for points which were stored on import.
    • [D3999] Leica GSI Import - files with descriptions containing a space caused error message like "Problem found on line 23, unable to continue."
    • [D4020] Leica GSI Import - setup records and backsight shots were incorrectly imported as sideshots.
    • [D4046] Leica GSI Import - shot records containing descriptions in a 71 record (from using a codelist) were not imported.
    • [D4046] Leica GSI Import - files with fixed coordinates recorded in "north,east" coordinate order ("east,north" is default) could not be properly imported.
    • [D4058] Leica GSI Import - files with angles recorded in gons/grads were not converted correctly.
    • [D4018] Project Units - when opening a drawing with angular units set to Grads, or when creating a new drawing using a template in Grads, it was automatically being changed to DMS format instead.
    • [D4028] Recoordination - When importing a RAW/RW5 file containing resections, a missing LS record could result in erroneous point elevations. If an expected LS record is not found a warning message is now displayed.
    • [D4028] Recoordination - When importing a RAW/RW5 file containing resections, a trailing SP record containing the calculated resection point will now always be imported into the traverse file.
    • [D3984] Automatic Updater - The automatic update notification message was improved to clarify the fact that a USB key must be updated via the License Manager application in order to run the new version, and to prevent an update that is not licensed from being installed.
    • [D3986] Automatic Updater - The automatic update notification message was not properly disabled through the appropriate option in Auto Update Preferences.
    • [D4154] Figures Database - Using the _ERASE command to delete survey lines from the drawing did not remove the line from the figures database.
    • [D4147] Rescale Complete Drawing - dramatically increased the speed performance of the _MS_RESCALE (MsPoints | Rescale Complete Drawing) command when rescaling line labels. Tests rescaling a drawing containing 2000 points and 1000 Bearing/Distance labeled lines shows an improvement from 6:20 to 0:10.
    • [D4021] ASCII Import - A crash could occur when importing an ASCII file exported from FieldGenius in "Standard With Header" or "Extended With Header" formats.
    • [D4368] ASCII Import - A crash could occur when importing an ASCII file containing any points with a description longer than 50 characters.
    • [D2630] Cut Sheets - The option to copy as-built descriptions to design points did not update the drawing.
    • [D0644] Evidence Recorder Export - The DXF file could contain entities from paper space when using the "Use entire drawing" option to export an Evidence Recorder project.
    • [F0922] Inverse - Dialog position is now retained, instead of always opening up in the middle of the screen.
    • [D4352] Open Project - A crash could occur when opening drawing if the database contains a corrupt date field.
    • [D4364] Sheet and Title Block - ATTREQ variable setting could prevent being prompted for attribute values.
    • [D2844] Figures Database - Running the Rotate, Shift, or Scale commands from within the Active Coordinate Editor could result in arcs being removed from the figures database.
    • [D4053] Nikon Import - Alphanumeric Point IDs were not read from Nikon 500 and 700 files.
    • [D2813] Nikon Import - The Coordinate Order option was not honoured when reading Nikon 700 files. Coordinate Records are now imported as either NEZ or ENZ depending on this flag.
(389 vote(s))
Helpful
Not helpful

Comments (0)