RSS Feed
Knowledgebase : Downloads > Forensics > IMS Map360
Please link to our new Support website dedicated to our forensic users: Link to IMS Support [http://ims.microsurvey.com/] page
MicroSurvey CAD Ultimate and Studio editions require Leica Geosystems Cyclone 9.1.1 or newer, but the latest version is recommended for maximum compatibility and performance. A Cyclone license is not required, the free viewer is sufficient for all MicroS...