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About MicroSurvey CAD 2008 

Q) What CAD Engine is used in MicroSurvey CAD 2008?   

A) MicroSurvey CAD 2008 uses the newest version of the IntelliCAD engine, 
IntelliCAD 6.4.  MicroSurvey CAD 2005 used IntelliCAD 6.0 and since then, there have 
been a lot of bug fixes, a lot of speed improvements, and some new features.  The 
updated IntelliCAD engine also now works with drawing files in the 2008 DWG format, 
which is now the default file format in which MicroSurvey CAD drawings are saved. 

Q) Who and What is IntelliCAD?  

A) The IntelliCAD Technology Consortium is an independent organization committed to 
promoting a cooperatively developed CAD engine.  This is what we like about 
IntelliCAD:  

• They have a strong development team.  
• They run extensive regression tests on their cad engine.  Hundreds of thousands of 

drawings are used during their testing sessions.  
• They also use thousands of script files that test the integrity and stability of the 

CAD engine.  
• They have an online web site that allows their Commercial members to access 

their bug database to see what bugs have been reported, and what bugs they are 
currently working on.  

• They are currently working on a new version that has incredible speed 
enhancements.  

• They hate bugs as much as we do, and try to fix them as quickly as possible.  

IntelliCAD has been around for many years and they have a very loyal following.  In mid 
November 2004 we joined the IntelliCAD Technology Consortium as a Commercial 
Member which gives us full access to the source code.  This is something that we have 
never had before and it will give us even more flexibility and control over the product.   

To learn more about the consortium visit the web site at www.intellicad.org. 

Q) Will it be a big adjustment learning MicroSurvey  CAD 2008?  

A) Overall you should not find it difficult to get up to speed with MicroSurvey CAD 
2008.  The “look and feel” of MicroSurvey CAD 2008 is very similar when compared to 
MicroSurvey CAD 2005.  Most of the new features that were added, such as the new 
alphanumeric point database, are primarily behind-the-scenes.  While you will see 
enhanced functionality and stability, it will not seem like learning a new program. 
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Installing MicroSurvey CAD 2008 

Q) Will MicroSurvey CAD 2008 overwrite my existing copy of 
MicroSurvey CAD?  

A) No - MicroSurvey CAD 2008 will install, by default, to C:\Program 
Files\MicroSurvey\MSCAD 2008\.  We recommend that you leave it there.  This will 
allow your previous versions to continue to run in its original folder so you can transition 
cleanly and easily. MicroSurvey CAD 2008 does not interfere with or over-write any files 
from earlier versions of MicroSurvey CAD. 

Q) Should I un-install my current version of MicroS urvey CAD prior to 
installing MicroSurvey CAD 2008?  

A) We suggest keeping your current version installed until after you install MicroSurvey 
CAD 2008 and have tested it to make sure it installed ok.  

If you are upgrading from MicroSurvey CAD 2004 or previous, you will need to use that 
older version to convert your FLX files to DWG so that they can be opened in 
MicroSurvey CAD 2008.  When you're satisfied that everything is running ok, and you 
have converted all your FLX drawings to DWG, you can un-install your older version. 

Please remember that if you have purchased MicroSurvey CAD 2008 as an upgrade from 
a previous version, then you no longer own the license for that previous version and 
should not be using it for production work. 

Q) How do I install the new version?  

A) To install, you must be logged in with an Administrator account.  Please contact your 
network administrator if you do not have Administrator access.  Insert the CD that you 
received when you purchased the upgrade into your CDROM drive.  The install wizard 
should automatically start for you.  If it doesn't simply browse to your CDROM drive and 
execute the setup.exe file.  Follow the on-screen instructions to step through the 
installation.  

Q) Do I really need an Administrator account?  

A) You need an Administrator account only to install MicroSurvey CAD 2008 and then 
to run it for the very first time on your computer.  After that, you can use your normal 
account; it will not matter whether it is an Administrator or Limited account. 
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Q) I inserted the new CD in my drive and nothing se ems to happen. Is 
the CD damaged or did I do something wrong?  

A) If your CD does not automatically start the install wizard you can try the following. 
 1)  Insert the CD into your drive and close the CD door while holding the <shift> key 
down on the keyboard.  2)  Go to the Windows Explorer program and change to the CD 
drive that contains your new CD.  3)  Double click on the setup.exe file to start the install 
procedure. 

If this doesn't work you may have a damaged CD, contact your sales representative for 
another CD. 

Q) I was lucky enough to have a prerelease or Beta copy of 
MicroSurvey CAD 2008. What do I do now with the new  CD?  

A) We appreciate your assistance as a Beta tester and we thank you all for your assistance 
in getting MicroSurvey CAD 2008 completed.  We do recommend that you un-install 
your beta copy of MicroSurvey CAD 2008.  Any changes you have made to customize 
MicroSurvey CAD 2008 should be backed up.  We recommend that you copy the 
changes out to a safe location prior to installing the new CD and then if desired, copy the 
files back in over the new ones, after looking at what we have done.  

Q) How do I remove my old MicroSurvey CAD Version?  

A) Please use the Control Panel | Add / Remove Programs option and remove the 
program. This will remove any extra files that we installed into the Windows System 
directory.  After the program is removed, there will be a few configuration files left in the 
C:\Program Files\MicroSurvey\MSCAD2005\ directory. After you have examined the 
remaining files in this directory and subdirectories to verify that you haven't placed any 
valuable files in here, you can delete this directory and subdirectories.  

Q) After installation of MicroSurvey CAD 2008, I no ticed all of my 
icons in My Computer for DWG files are now showing a different 
picture. 

A) Windows can only maintain 1 icon picture for each file extension.  So the last 
installed program, using that file extension, will be the default one used by Windows.  
Being you just installed MicroSurvey CAD 2008, this is the program Windows will 
associate with the DWG file extension (and any others we use as well).  Windows is not 
converting or changing the existing files, just which program Windows thinks can open 
them. 
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Files used by MicroSurvey CAD 2008 

Q) What will happen to all my old jobs?  Can I stil l use them?  

A) MicroSurvey CAD 2008 uses an updated version of the IntelliCAD engine which 
works with AutoCAD 2008 DWG files.  MicroSurvey CAD 2005 used AutoCAD 2004 
DWG files, which will open up in MicroSurvey CAD 2008.   

You will only need to convert your files from FLX to DWG if you are upgrading from 
MicroSurvey CAD 2004 or earlier.  We've posted a movie on our website that shows you 
how easy this is to do.  

This can be done very easily using the Batch Processing abilities in MicroSurvey CAD 
2004 or 2002 to convert your FLX files to DWG: 

1. Open up MicroSurvey CAD 2004 or 2002 
2. Press Cancel on the Project Manager window without opening any drawings. 
3. Pause MicroSurvey CAD by typing the following at the command line:  (setq 

mscadpause 1) 
4. Start up the Batch Processing command by typing BATPROC at the command 

line 
5. The Batch Plotting and Converting dialog will open.  Start at the top center of the 

dialog and make sure that the checkbox "Include Subdirectories" is checked. 
 Make sure that .FLX is checked, but .DXF and .DWG are NOT checked.   

6. Press the Select Directory to add Files from button << and select your data 
directory (for example, c:\Jobs 2006), and press OK.  Repeat this step for any 
other data directories on your computer. 

7. In the Convert to section, select DWG 
8. Press Start to begin processing your files.  You will see your drawings open one at 

a time as they are saved to a DWG file.  This may take quite some time if you 
have a lot of FLX drawings. 

9. After batch processing is complete type the following at the command line:  (setq 
mscadpause nil) 

For more information, refer to the online tech note Batch Conversion from FLX to DWG 

If you no longer have a copy of MicroSurvey CAD 2004 or 2002 installed, you can 
download a cheap little program called PowerCAD DWG Viewer from 
www.graebert.com which will allow you to open and convert the FLX files to DWG 
files.  This program is from the makers of the CAD engine we licensed and used in 
MicroSurvey CAD 2004 and previous. 

Q) What about the drawing file?  Is it different fo r 2008?  

A) Yes, MicroSurvey CAD 2008 uses an updated version of the IntelliCAD engine which 
uses industry standard 2008 format DWG files.  MicroSurvey CAD 2005 uses an older 
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2004 format DWG file.  So MicroSurvey CAD 2008 will read any DWG files created by 
older versions.  While older versions of MicroSurvey CAD can read DWG files, you will 
need to convert any drawing files created with MicroSurvey CAD 2008 to an older DWG 
format depending on your version of MicroSurvey CAD.   

From the File Menu you can use the SAVEAS command and save your project back to 
previous DWG versions.  Refer to the table to see what DWG version can be handled by 
your version of MicroSurvey CAD.  

MicroSurvey CAD Version Compatible File Types 
MicroSurvey CAD 3.1 / 2001 R12-2000 DWG / DXF 
MicroSurvey CAD 2002 R12-2002 DWG / DXF 
MicroSurvey CAD 2004 R12-2004 DWG / DXF 
MicroSurvey CAD 2005 R12-2006 DWG / DXF 
MicroSurvey CAD 2008 R12-2008 DWG / DXF 

Q) What about the database file?  Is it different f or 2008?  

A) Yes, MicroSurvey CAD 2008 uses a smaller, faster, and more stable database file, 
called a MSZ file.   

If you open a drawing that has an MSD database file, MicroSurvey CAD 2008 will 
automatically convert the MSD database file to the new MSZ format database file (a 
backup copy of the original MSD file is created and called MS5).  However, MSZ 
database files can not be converted back to a previous version.  If you need to open a 
MicroSurvey CAD 2008 drawing in a previous version, you can export the point database 
as an ASCII file to import it into the older version of MicroSurvey CAD.  And always 
use the SAVEAS command in the File Menu, and save the drawing file to an older DWG 
format, as discussed above.  

Q) What about the log file?  Is it different for 20 08?  

A) Yes, MicroSurvey CAD 2008 now creates a rich text format log file with a RTF 
extension.  The existing .log files from previous versions of MicroSurvey CAD are not 
affected. 

Q) What about all the other files?  Are they differ ent for 2008?  

A) All other files types created by MicroSurvey CAD 2008 such as surface files, 
alignment files, batch files etc, are completely interchangeable between previous versions 
of MicroSurvey CAD.  
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Q) When using FieldGenius with MicroSurvey CAD 2008 , where do my 
jobs go now?  

A) You will need to ensure that you are using the new version of MicroSurvey Transfer, 
and that it is set to use MicroSurvey CAD 2008.  The Upload and Download folders are 
now located in C:\Documents and Settings\All Users\Application 
Data\MicroSurvey\MSCAD\2008\SyncWizard\ if your computer is running Windows 
2000 or XP, or in C:\Program Data\MicroSurvey\MSCAD\2008\SyncWizard\ if your 
computer runs Windows Vista. 

Customizing MicroSurvey CAD 2008 

Q) I have taken many hours to setup my AutoMap Libr ary to work as 
desired in MicroSurvey CAD 2005. What is going to h appen to all that 
work?  

A) All you need to do is copy the CSV file that you created with MicroSurvey CAD 2005 
into MicroSurvey CAD 2008. Then as you have done before, load it and use it anytime 
you require. If you had saved your CSV file under the name mscad.csv then we 
recommend that you give it a new name in MicroSurvey CAD 2008 to help keep track of 
which one is which. 

The Automap Library files for MicroSurvey CAD 2005 are located in C:\Program 
Files\MicroSurvey\MSCAD 2005\mscad\.  The Automap Library files for MicroSurvey 
CAD 2008 are located in C:\Documents and Settings\All Users\Application 
Data\MicroSurvey\MSCAD\2008\mscad\ if your computer runs Windows 2000 or 
Windows XP, or in C:\Program Data\MicroSurvey\MSCAD\2008\mscad\if your 
computer runs Windows Vista. 

You will need to update the paths for all of the symbols that may be associated with your 
AutoMAP library if you used MicroSurvey CAD specific symbols. For example, if you 
created your library with MicroSurvey CAD 2005 you may see something like: 
C:\Program Files\MicroSurvey\MSCAD2005\mscad\Blocks\ICI_AP.DWG for a symbol 
path. When you remove MicroSurvey CAD 2005 from your computer the path will no 
longer exist and you will need to update your AutoMap library to look in C:\Documents 
and Settings\All Users\Application Data\MicroSurvey\MSCAD\2008\mscad\blocks\ if 
your computer runs Windows 2000 or Windows XP, or in C:\Program 
Data\MicroSurvey\MSCAD\2008\mscad\blocks\ if your computer runs Windows Vista. 
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Q) I have setup several Toolbars in MicroSurvey CAD  2005 and I 
really would prefer not to have to do them all agai n in MicroSurvey 
CAD 2008. Is there a quick way to convert these ove r so I don't lose 
them?  

A) Yes.  Open MicroSurvey CAD 2005, and go to Cad Tools > Customize.  Click on the 
Toolbars tab, and press the Export button.  Place a checkmark in the box for each of the 
custom toolbars you created, and uncheck any of the toolbars that you did not create (be 
especially sure to uncheck the Entity Properties toolbar) then press OK.  Specify a 
filename and location that you will easily find later – for example, save a file called 
MicroSurvey CAD 2005 Toolbars in your My Documents folder. 

Now open MicroSurvey CAD 2008, and go to Cad Tools > Customize.  Click on the 
Toolbars tab, and press the Import button.  Locate the file that was exported from 
MicroSurvey CAD 2005, highlight it, and press Open. 

Q) I have setup many Aliases in MicroSurvey CAD 200 5 and I really 
would prefer not to have to do them all again in Mi croSurvey CAD 
2008. Is there a quick way to convert these over so  I don't lose them?  

A) Yes.  Open MicroSurvey CAD 2005, and go to Cad Tools > Customize.  Click on the 
Aliases tab, and press the Export button.  Specify a filename and location that you will 
easily find later – for example, save a file called MicroSurvey CAD 2005 Aliases in your 
My Documents folder. 

Now open MicroSurvey CAD 2008, and go to Cad Tools > Customize.  Click on the 
Aliases tab, and press the Import button.  Locate the file that was exported from 
MicroSurvey CAD 2005, highlight it, and press Open. 

Q) I have setup several Keyboard Hotkeys in MicroSu rvey CAD 2005 
and I really would prefer not to have to do them al l again in 
MicroSurvey CAD 2008. Is there a quick way to conve rt these over so 
I don't lose them?  

A) Yes.  Open MicroSurvey CAD 2005, and go to Cad Tools > Customize.  Click on the 
Keyboard tab, and press the Export button.  Specify a filename and location that you will 
easily find later – for example, save a file called MicroSurvey CAD 2005 Hotkeys in 
your My Documents folder. 

Now open MicroSurvey CAD 2008, and go to Cad Tools > Customize.  Click on the 
Hotkeys tab, and press the Import button.  Locate the file that was exported from 
MicroSurvey CAD 2005, highlight it, and press Open. 
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Q) I have created an extensive Building Library, ca n I transfer it into 
MicroSurvey CAD 2008?  

A) The Building/Structure Library is stored in a file called DB_POLY.ASC which is 
found in the following folder: 

C:\Program Files\MicroSurvey\MSCAD2005\mscad\ or C:\MSCAD200x\mscad\ 

Then copy this file into C:\Documents and Settings\All Users\Application 
Data\MicroSurvey\MSCAD\2008\mscad\ if your computer runs Windows 2000 or 
Windows XP, or into C:\Program Data\MicroSurvey\MSCAD\2008\mscad\ if your 
computer runs Windows Vista, overwriting the existing file if there is one already there. 

Q) What about the Description Translation Library f rom MicroSurvey 
CAD 2005?  

A) You can export your Description Translation Library from MicroSurvey CAD 2005 
by typing in the command (dumpccpd) at the command line, including the parenthesis. 
 This will create a file C:\Program Files\MicroSurvey\MSCAD2005\mscad\desctran.db.  

Then copy this file into C:\Documents and Settings\All Users\Application 
Data\MicroSurvey\MSCAD\2008\ if your computer runs Windows 2000 or Windows 
XP, or into C:\Program Data\MicroSurvey\MSCAD\2008\ if your computer runs 
Windows Vista, and rename it to DESCTRANS.CSV. 

Q) I have customized or added my own Blocks in the Symbol 
Librarian, can they be transferred into MicroSurvey  CAD 2008?  

A) Yes, the MSCAD 2005 Symbol Librarian is found in C:\Program 
Files\MicroSurvey\MSCAD2005\Symbols\ 

Just copy any customized DWG files from there into C:\Documents and Settings\All 
Users\Application Data\MicroSurvey\MSCAD\2008\Symbols\ if your computer runs 
Windows 2000 or XP, or C:\ProgramData\MicroSurvey\MSCAD\2008\Symbols\ if your 
computer runs Windows Vista. 

If you are upgrading from MSCAD 2004 or previous, you will have to convert the FLX 
files to DWG files first using the Batch Converter. 

Q) I have customized the generic title blocks used by the Add Sheet 
and Title Block routines, can they be transferred i nto MicroSurvey 
CAD 2008?  

A) Yes, the title blocks used by MicroSurvey CAD 2005 are located in C:\Program 
Files\MicroSurvey\MSCAD2005\Design\ 
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Just copy any customized files from there into C:\Documents and Settings\All 
Users\Application Data\MicroSurvey\MSCAD\2008\Design\ if your computer runs 
Windows 2000 or XP, or C:\ProgramData\MicroSurvey\MSCAD\2008\Design\ if your 
computer runs Windows Vista. 

If you are upgrading from MSCAD 2004 or previous, you will have to convert the FLX 
files to DWG files first using the Batch Converter. 

Q) I want to plot my first MicroSurvey CAD 2008 dra wing. Can I get 
my MicroSurvey CAD 2005 Print Style Tables for line  width and colors 
into MicroSurvey CAD 2008?  

A) Yes, the CTB and STB print style tables are completely interchangeable so you can 
simply copy and paste the files from MicroSurvey CAD 2005 into MicroSurvey CAD 
2008. 

MicroSurvey CAD 2005 keeps its print style files in C:\Program 
Files\MicroSurvey\MSCAD2005\Print Styles\. 

MicroSurvey CAD 2008 keeps its print style files in two locations, C:\Program 
Files\MicroSurvey\MSCAD2008\Print Styles\ and also in your My Documents\Print 
Styles\ folder. 

The print style files found in the Program Files location are used only as templates, so 
that when a user runs MSCAD 2008 for the first time, the files contained there will be 
automatically copied to their personal My Documents\Print Styles folder.  Then any time 
you use or edit a print style table in MSCAD 2008, it uses the copy contained in your My 
Documents\Print Styles folder, while the copy in the Program Files location is left in its 
default condition.  This allows multiple users on one computer to customize their own 
individual print style table files. 

Q) I have some custom Linetypes and Hatch Patterns,  what do I do 
with them?  

A) All you need to do is copy the files to the new program folder.  For LIN files they 
should go in the C:\Program Files\MicroSurvey\MSCAD2008 folder.  For PAT files they 
should go in the C:\Program Files\MicroSurvey\MSCAD2008\patterns folder. 

 Do not over-write any existing files or you will lose some of the new linetypes that we 
supply in MicroSurvey CAD 2008. 

Q) Labeling Defaults – how do I get them into Micro Survey CAD 2008 
without manually redoing them all again?  

A) You have two options here: 
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1) All labeling defaults are saved in each drawing.  If you simply open a drawing 
from MicroSurvey CAD 2005 into MicroSurvey CAD 2008, that drawing will 
still have all the labeling defaults as you had set them in MicroSurvey CAD 2005.  
To make them permanent for MicroSurvey CAD 2008, after you open the job 
with the labeling defaults set as you desire, go to the MsTools menu | 
MicroSurvey System Defaults | Save as Default Configuration.  Confirm the save 
and from this point forward, any new jobs you create in MicroSurvey CAD 2008 
will now have the same settings as the job you set them from. 

2) In MicroSurvey CAD 2005, if you go to the MsTools menu | MicroSurvey 
System Defaults | Save Configuration File, and give the file a name and note it’s 
folder location.  Then in MicroSurvey CAD 2008, go to MsTools menu | 
MicroSurvey System Defaults |  Read Configuration File.  That loads the labeling 
defaults into the current job.  Then you would still need to go to MsTools menu | 
MicroSurvey System Defaults | Save as Default Configuration, to make them 
permanent for all new jobs created in MicroSurvey CAD 2008. 

Q) Can I use my Custom Template files in MicroSurve y CAD 2008?  

A) Yes you can.  DWT files created in MicroSurvey CAD 2005 can be used in 
MicroSurvey CAD 2008.  All you need to do is set our MicroSurvey Project Manager to 
find and use the desired DWT file.  Some DWT files created in other CAD engines may 
not work correctly due to the version they were created in. 

DWG files can also be used as Templates.  It does not matter where the DWG came from 
or what version it was created in, it should still work correctly for you. 

Q) What is this Floating Menu?  Can I get rid of it ?  

A) When using MicroSurvey CAD 2008, like MicroSurvey CAD 2005, you will notice a 
floating menu that will appear as you use different commands at the command line.  If 
you want to turn it off, type Config at the command line, and turn off Display Prompt 
Boxes in the display tab.  

Q) How do I load Toolbars?  

A) You can load toolbars by right-clicking on any of your toolbars, to get a pop-up list of 
the toolbars available within MicroSurvey CAD 2008.  Toolbars shown with a 
checkmark are already loaded.  Clicking on a toolbar name will either load or unload it. 

You can also load toolbars by going to the menu that the toolbar resides in.  You will 
note that each menu item has a toolbar or toolbars listed towards the bottom of the menu.  
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Registering MicroSurvey CAD 2008 

Q) I've got it installed.  How do I register it?  

A) First, you need to activate the USB License Key you received when you purchased 
MicroSurvey CAD 2008.  Plug the USB License Key into any computer that is connected 
to the internet and run the License Manager software that was installed with MicroSurvey 
CAD. 

Q) How do I register it with my network license?  

A) First, you need to activate the USB License Key you received when you purchased 
MicroSurvey CAD 2008.  Plug the USB License Key into any computer that is connected 
to the internet and execute the License Manager software that was installed with 
MicroSurvey CAD. 

Then install the MicroSurvey Network License Server application on any computer on 
your network with an available USB port. Once your USB License Key has been 
activated online, just plug it into any available USB port on any computer on your 
network which has the MicroSurvey Network License Server installed.  Make sure you 
know the name of the computer that the USB License Key is plugged into.  If you are 
unsure of the computer name, please contact your IT Department for assistance. 

Then run MicroSurvey CAD 2008 on any computer on the same network.  When asked, 
simply provide MicroSurvey CAD 2008 with the computer name that the USB License 
Key is plugged into, and then press the Connect to Server USB Key button and it will 
automatically detect the USB License Key and unlock the program if there is an available 
seat available.  You must leave the USB License Key plugged in to the server computer 
for the entire duration that anyone is running MicroSurvey CAD 2008 – if you unplug the 
key, MicroSurvey CAD 2008 will become disabled on any computer it is running on. 

Unlike with MicroSurvey CAD 2005, the MicroSurvey CAD 2008 network license no 
longer requires that a shared network folder be setup for accessing the MapScenes 
network license. 

Q) Do you have hardware locks available?  

A) Yes, all of our MicroSurvey CAD 2008 licenses use a USB License Key for activating 
the program.  Simply plug the USB License Key in to the computer, and then start 
MicroSurvey CAD 2008.  Want to work on MicroSurvey CAD 2008 at home or on 
another computer?  Just take the USB License Key with you, wherever you want to use 
MicroSurvey CAD 2008! 
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Q) Can I use MicroSurvey CAD 2008 without a hardwar e lock?  

A) No, all of our MSCAD 2008 licenses use a USB key for activating the program. 
 Simply plug the USB key in to the computer, and then start MSCAD 2008.  Want to 
work on MSCAD 2008 at home or on another computer?  Just take the USB License Key 
with you, wherever you want to use MSCAD 2008! 

Help and Training with MicroSurvey CAD 2008  

Q) I've heard that there are many hours of training  movies, how do I 
play the training movies?  

A) The training movies have been built into the help system.  Not only is there a topic 
listing the available movies you will find that many individual topics will have a link to 
corresponding movies. 

Q) I've heard that the online help file was improve d for MicroSurvey 
CAD 2008?  

A) We have updated the help file for the both the updated IntelliCAD engine and the 
survey commands have also been updated.   

Q) Are there any tutorials or other examples of how  to use the 
program?  

A) Yes, there are several tutorials available in the “Getting Started Guide”.  If you do not 
have a printed copy of the Getting Started Guide, you can access the PDF version through 
your Start Menu | Programs | MicroSurvey | MicroSurvey CAD 2008 | Getting Started. 

Q) What about classroom-type training, is anything like that 
available?  

A) Training courses are sometimes offered if there is sufficient demand in a particular 
region.  Please phone your Sales Representative at 1-800-668-3312 to enquire about any 
upcoming training sessions. 

 


