Knowledgebase
Labeling Contours
Posted by Jason Poitras on 14 July 2015 10:33 AM

I have had a few customers call with problems relating to Labelling Contours. The problem is not the labelling command but it has to do with the contours and whether or not they have been smoothed.

If you decide to smooth your contours to make them look more like hand drawn contours you must make sure that you do all labelling of the contour elevations prior to running the smoothing command.

If you do not then you may get a"Resource Error"or you may just get labels that do not follow the contour and the contour does not get broken for the labelling. See below for good and bad labelling examples;

The Bad Example had the contours all smoothed and then labelling was attempted. You can see the results - no break in the contours and the labelling can come in at weird angles. Not what most people require.

The Good Example had the labelling done first then the contours were smoothed. The labels follow the contours and the contours are broken for the text. Much better results.

If you have already smoothed your contours and now have found the same labelling problems, you have two options. First you can erase the contours and redraw them, then label and smooth (in this order). Or second you could Decurve the contours you need to label and then re-smooth them after labelling. This can be done by running the following command; PCURVE and use the DECURVE option of this command. It only allows you to pick one contour at a time to decurve so it may be the slower of the two options.

Both the Label Contours and Smooth Contours commands are found under the Modelling pulldown menu under the Annotate option. As an aside - The Index Contours command will only work on non-smoothed contours. The Hature Contours command will work on any contour before or after smoothing.


Created on:June 9, 1998

(361 vote(s))
Helpful
Not helpful

Comments (0)