Knowledgebase
Microsoft .NET Framework may cause installation failure on Windows 8 or newer
Posted by Brian Sloman on 31 March 2016 10:52 AM

Nearly all MicroSurvey desktop products released between 2008 and 2014 include a component called "Microsoft .NET Framework 2.0":

  • MicroSurvey CAD 2008-2014
  • MicroSurvey inCAD 2010-2014
  • MicroSurvey embeddedCAD 2011-2014
  • MicroSurvey Point Prep 2013
  • MicroSurvey Data Exchange (MSDX) 2012
  • MicroSurvey PointCloud CAD 2010
  • MicroSurvey STAR*NET V6-V7
  • MapScenes Pro 2008
  • MapScenes Forensic CAD 2010-2013
  • MapScenes Capture 2010
  • MapScenes Point Cloud 2010
  • OfficeSync Office Manager
  • OfficeSync Job Monitor

This component was required by computers running the Windows 2000 and Windows XP operating systems, but it is no longer required in Windows Vista and newer and may cause an error message during installation in Windows 8 and newer:

Operating SystemNotes
Windows 2000
Windows XP
Not included in Windows, but can be installed separately.
MicroSurvey installation package will detect whether or not it is already installed, and will install it if necessary.
Windows Vista
Windows Server 2008
Included in Windows.
MicroSurvey installation package will always detect that it is already installed, and will therefore not install it.
Windows 7
Windows Server 2008 R2
Included in Windows as part of .NET Framework 3.5.
MicroSurvey installation package will always detect that it is already installed, and will therefore not install it.
Windows 8
Windows 8.1
Included with Windows as part of .NET Framework 3.5 SP1 but not enabled by default.
MicroSurvey installation package will detect whether or not it is already installed, and will attempt to install it if necessary but the installation will fail.
If necessary, users must manually enable .NET Framework 3.5 via the Control Panel. In Control Panel, choose "Programs and Features", choose "Turn Windows features on or off", and then select the ".NET Framework 3.5 (includes .NET 2.0 and 3.0)" check box. This option requires an Internet connection.
Click here for more information from Microsoft.
Windows Server 2012
Windows Server 2012 R2
Included with Windows as part of .NET Framework 3.5 SP1 but not enabled by default.
MicroSurvey installation package will detect whether or not it is already installed, and will attempt to install it if necessary but the installation will fail.
If necessary, users must manually enable .NET Framework 3.5 via the Server Manager.

Future MicroSurvey installation packages will not attempt to install this component on Windows Vista or newer.

Special Note: The .NET Framework 2.0 can be downloaded from Microsoft and installed separately onto supported systems.

(0 vote(s))
Helpful
Not helpful

Comments (0)