Knowledgebase
MapScenes 2010 Upgrade Notes
Posted by Brian Sloman on 30 September 2009 11:20 AM

Upgrade Notes

Here you will find some information that will help you get started with MapScenes 2010. If you don't find an answer to your question here, try searching our Helpdesk, or submit a support ticket.

 


 

About MapScenes 2010

What CAD Engine is used in MapScenes 2010?

MapScenes 2010 uses the newest version of the IntelliCAD engine, IntelliCAD 6.6. MapScenes has been built on IntelliCAD since version 6.1 back in MapScenes 2006, and since then there have been a lot of bug fixes, a lot of speed improvements, and some new features. The updated IntelliCAD engine works with drawing files in the latest 2007/2008/2009 DWG format which is the default file format in which MapScenes 2010 drawings are saved, as well as legacy DWG and DXF drawing formats.

Who and What is IntelliCAD?

The IntelliCAD Technology Consortium is an independent organization committed to promoting a cooperatively developed CAD engine. This is what we like about IntelliCAD:

  • They have a strong development team.

  • They run extensive regression tests on their cad engine. Hundreds of thousands of drawings are used during their testing sessions.

  • They also use thousands of script files that test the integrity and stability of the CAD engine.

  • They have an online web site that allows their Commercial members to access their bug database to see what bugs have been reported, and what bugs they are currently working on.

  • They are currently working on a new version that has incredible speed enhancements.

  • They hate bugs as much as we do, and try to fix them as quickly as possible.

IntelliCAD has been around for many years and they have a very loyal following. In mid November we joined the IntelliCAD Technology Consortium as a Commercial Member which gives us full access to the source code. This is something that we have never had before and it will give us even more flexibility and control over the product.

To learn more about the consortium visit the web site at www.intellicad.org.

Will it be a big adjustment learning MapScenes 2010?

Overall you should not find it difficult to get up to speed with MapScenes 2010. The "look and feel" of MapScenes 2010 is very similar when compared to MapScenes 2006/2008, and other major CAD packages. Most of the new features that were added in 2010 provide enhanced functionality, stability, and performance; it will not seem like learning a new program.

 


 

Installing MapScenes 2010

Will MapScenes 2010 overwrite my existing copy of MapScenes?

MapScenes 2010 will install by default to C:\Program Files\MicroSurvey\MapScenes 2010\. We recommend that you leave it there. This will allow your previous version to continue to run in its original folder so you can transition cleanly and easily.

Should I un-install my current version of MapScenes prior to installing MapScenes 2010?

We suggest keeping your current version installed until after you install MapScenes 2010 and have tested it to make sure it installed ok. If you are upgrading from MapScenes 2002, you will need to use that older version to convert your FLX drawings to DWG so that they can be opened in MapScenes 2010. When you're satisfied that everything is running ok, and you have converted your FLX drawings to DWG, you can un-install your older version.

Please remember that if you have purchased MapScenes 2010 as an upgrade from a previous version, then you no longer own the license for that previous version and should not be using it for production work.

How do I install the new version?

To install, you must be logged in with an Administrator account. Please contact your network administrator if you do not have Administrator access. Insert the CD that you received when you purchased the upgrade into your CDROM drive. The install wizard should automatically start for you. If it doesn't simply browse to your CDROM drive and execute the setup.exe file. Follow the on-screen instructions to step through the installation.

Do I really need an Administrator account?

You need an Administrator account only to install MapScenes 2010 and then to run it for the very first time on your computer. After that, you can use your normal account; it will not matter whether it is an Administrator or Limited account.

I inserted the new CD in my drive and nothing seems to happen. Is the CD damaged or did I do something wrong?

If your CD does not automatically start the install wizard you can try the following. 1) Insert the CD into your drive and close the CD door while holding the <shift> key down on the keyboard. 2) Go to the Windows Explorer program and change to the CD drive that contains your new CD. 3) Double click on the setup.exe file to start the install procedure.

If this doesn't work you may have a damaged CD, contact your sales representative for another CD.

I was lucky enough to have a prerelease or Beta copy of MapScenes 2010. What do I do now with the new CD?

We appreciate your assistance as a Beta tester and we thank you all for your assistance in getting MapScenes 2010 completed. We do recommend that you un-install your beta copy of MapScenes 2010. Any changes you have made to customize MapScenes 2010 should be backed up. We recommend that you copy the changes out to a safe location prior to installing the new CD and then if desired, copy the files back in over the new ones, after looking at what we have done.

How do I remove my old MapScenes version?

Please use the Control Panel | Add / Remove Programs option and remove the program. This will remove any extra files that we installed into the Windows System directory. After the program is removed, there will be a few configuration files left in the MapScenes 2010 directories. After you have examined the remaining files in these directories and subdirectories to verify that you haven't placed any valuable files there, you can delete them.

 


 

Files used by MapScenes 2010

What will happen to all my old jobs? Can I still use them with MapScenes 2010?

MapScenes 2010 uses an updated version of the IntelliCAD engine which works with AutoCAD R2.5 to R2009 DWG files. DWG files from MapScenes 2006/2008 can be opened with MapScenes 2010. You will only need to convert your files from FLX to DWG if you are upgrading from MapScenes 2002. We've posted a movie on our website that shows you how easy this is to do.

This can be done very easily using the Batch Processing abilities in MapScenes 2002 to convert your FLX files to DWG:

  1. Open up MapScenes 2002

  2. Press Cancel on the Project Manager window without opening any drawings.

  3. Pause MapScenes by typing the following at the command line: (setq mscadpause 1)

  4. Start up the Batch Processing command by typing BATPROC at the command line

  5. The Batch Plotting and Converting dialog will open. Start at the top center of the dialog and make sure that the checkbox "Include Subdirectories" is checked. Make sure that .FLX is checked, but .DXF and .DWG are NOT checked.

  6. Press the Select Directory to add Files from button << and select your data directory (for example, c:\Jobs2004), and press OK. Repeat this step for any other data directories on your computer.

  7. In the Convert to section, select DWG

  8. Press Start to begin processing your files. You will see your drawings open one at a time as they are saved to a DWG file. This may take quite some time if you have a lot of FLX drawings.

  9. After batch processing is complete type the following at the command line: (setq mscadpause nil)

For more information, refer to the online tech note Batch Conversion from FLX to DWG.

What about the drawing file? Is it different for MapScenes 2010?

MapScenes 2010 uses an updated version of the IntelliCAD engine which uses industry standard 2007/2008/2009 format DWG files. MapScenes 2008/2010 uses the same DWG format. MapScenes 2006 uses an older 2004 DWG format. So, MapScenes 2010 will read any DWG files created by older versions. While older versions of MapScenes can read DWG files, you may need to convert any drawing files created with MapScenes 2010 to an older DWG format depending on your previous version of MapScenes.

From the File Menu you can use the SAVEAS command and save your project back to previous DWG versions. Refer to the table to see what DWG version can be handled by your version of MapScenes.

MapScenes Version

Compatible File Types

MapScenes 2002

R12-2002 DWG / DXF

MapScenes 2006

R2.5-2006 DWG / DXF

MapScenes 2008

R2.5-2009 DWG / DXF

MapScenes 2010

R2.5-2009 DWG / DXF

What about the database file? Is it different for MapScenes 2010?

Yes, MapScenes 2008/2010 uses a smaller, faster, and more stable database file, called a MSZ file.

If you open a drawing that has an MSD database file, MapScenes 2008/2010 will automatically convert the MSD database file to the new MSZ format database file. However, MSZ database files can not be converted back to the previous MSD format. If you need to open a MapScenes 2008/2010 drawing in a previous version, you can export the point database as an ASCII file to import it into the older version of MapScenes. And always use the SAVEAS command in the File Menu, and save the drawing file to an older DWG format, as discussed above.

When a database is first converted from the older MSD format to the new MSZ format, a backup copy of the current MSD file will be created with an MS5 extension. It will not be updated again with any changes you make while in the new format, but if necessary it can be used to re-open the pre database in the previous version of MapScenes.

What about the log file? Is it different for MapScenes 2010?

MapScenes 2010 creates a rich text format log file with a RTF extension; this is the same format used since MapScenes 2008. The existing .log files from prior versions of MapScenes are not affected.

What about all the other files? Are they different for MapScenes 2010?

All other files types created by MapScenes 2010 such as surface files, alignment files, batch files etc, are completely interchangeable between previous versions of MapScenes.

When using Evidence Recorder with MapScenes 2010, where do my jobs go now?

You will need to ensure that you are using the new version of MicroSurvey Transfer, and that it is set to use MapScenes 2010.

 


 

Registering MapScenes 2010

I've got it installed. How do I register it?

First, you need to activate the USB License Key you received when you purchased MapScenes. Plug the USB License Key into any computer that is connected to the internet and run the License Manager software that was installed with MapScenes.

How do I register it with my network license?

First, you need to activate the USB License Key you received when you purchased MapScenes. Plug the USB License Key into any computer that is connected to the internet and execute the License Manager software that was installed with MapScenes.

Then install the MicroSurvey Network License Server application on any computer on your network with an available USB port. Once your USB License Key has been activated online, just plug it into any available USB port on any computer on your network which has the MicroSurvey Network License Server installed. Make sure you know the name of the computer that the USB License Key is plugged into. If you are unsure of the computer name, please contact your IT Department for assistance.

Then run MapScenes 2010 on any computer on the same network. When asked, simply provide MapScenes 2010 with the computer name that the USB License Key is plugged into, and then press the "Connect to Server USB Key" button and it will automatically detect the USB License Key and unlock the program if there is an available seat available. You must leave the USB License Key plugged in to the server computer for the entire duration that anyone is running MapScenes 2010 – if you unplug the key, MapScenes 2010 will become disabled on any computer it is running on.

Unlike with MapScenes 2006, the MapScenes 2010 network license does not require a shared network folder be setup for accessing the MapScenes 2010 network license.

Do you have hardware locks available?

Yes, all of our MapScenes 2010 licenses use a USB License Key for activating the program. Simply plug the USB License Key into the computer, and then start MapScenes 2010. Want to work on MapScenes 2010 at home or on another computer? Just take the USB License Key with you, wherever you want to use MapScenes 2010!

Can I use MapScenes 2010 without a hardware lock?

No, all of our MapScenes 2010 licenses use a USB key for activating the program. Simply plug the USB key in to the computer, and then start MapScenes 2010. Want to work on MapScenes 2010 at home or on another computer? Just take the USB License Key with you, wherever you want to use MapScenes 2010!

 


 

Customizing MapScenes 2010

I have taken many hours to setup my AutoMap Library to work as desired in my previous version of MapScenes. What is going to happen to all that work?

All you need to do is copy the CSV file that you created with a previous version into MapScenes 2010. Then as you have done before, load it and use it anytime you require. If you had saved your CSV file under the name survey.csv then we recommend that you give it a new name in MapScenes 2010 to help keep track of which one is which.

The Automap Library files for MapScenes 2006 are located in C:\Program Files\MicroSurvey\MapScenes 2006\mscad\. The Automap Library files for MapScenes 2008 are located in C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2008\mscad\ if your computer runs Windows 2000 or Windows XP, or in C:\Program Data\MicroSurvey\MapScenes\2008\mscad\ if your computer runs Windows Vista. The Automap Library files for MapScenes 2010 are located in C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2010\mscad\ if your computer runs Windows 2000 or Windows XP, or in C:\Program Data\MicroSurvey\MapScenes\2010\mscad\if your computer runs Windows Vista.

You will need to update the paths for the symbols that may be associated with your AutoMAP library if you used MapScenes specific symbols. For example, if you created your library with MapScenes 2006 you may see something like: C:\Program Files\MicroSurvey\MapScenes 2006\mscad\Blocks\ICI_AP.DWG for a symbol path. When you remove MapScenes 2006 from your computer the path will no longer exist and you will need to update your AutoMap library to look in C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2010\mscad\blocks\ if your computer runs Windows 2000 or Windows XP, or in C:\Program Data\MicroSurvey\MapScenes\2010\mscad\blocks\ if your computer runs Windows Vista.

I have setup several Toolbars in MapScenes 2006/2008 and I really would prefer not to have to do them all again in MapScenes 2010. Is there a quick way to convert these over so I don't lose them?

Yes. Open MapScenes 2006/2008, and go to Cad Tools | Customize. Click on the Toolbars tab, and press the Export button. Place a checkmark in the box for each of the custom toolbars you created, and uncheck any of the toolbars that you did not create (be especially sure to uncheck the Entity Properties toolbar) then press OK. Specify a filename and location that you will easily find later – for example, save a file called MSCAD Toolbars in your My Documents folder.

Now open MapScenes 2010, and go to Cad Tools | Customize. Click on the Toolbars tab, and press the Import button. Locate the file that was exported from your previous version of MapScenes, highlight it, and press Open.

I have setup many Aliases in MapScenes 2006/2008 and I really would prefer not to have to do them all again in MapScenes 2010. Is there a quick way to convert these over so I don't lose them?

Yes. Open MapScenes 2006/2008, and go to Cad Tools | Customize. Click on the Aliases tab, and press the Export button. Specify a filename and location that you will easily find later – for example, save a file called MSCAD Aliases in your My Documents folder.

Now open MapScenes 2010, and go to Cad Tools | Customize. Click on the Aliases tab, and press the Import button. Locate the file that was exported from MapScenes 2006/2008, highlight it, and press Open.

I have setup several Keyboard Hotkeys in MapScenes 2006/2008 and I really would prefer not to have to do them all again in MapScenes 2010. Is there a quick way to convert these over so I don't lose them?

Yes. Open MapScenes 2006/2008, and go to Cad Tools | Customize. Click on the Keyboard tab, and press the Export button. Specify a filename and location that you will easily find later – for example, save a file called MSCAD Hotkeys in your My Documents folder.

Now open MapScenes 2010, and go to Cad Tools > Customize. Click on the Hotkeys tab, and press the Import button. Locate the file that was exported from MapScenes 2006/2008, highlight it, and press Open.

I have created an extensive Description Translation Library, can I transfer it into MapScenes 2010?

2008 to 2010:

You can copy your Description Translation Library from MapScenes 2008 by copying the file called desctrans.csv from one of the following folders:

C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2008\ (Windows XP/2000)

or, C:\Program Data\MicroSurvey\MapScenes\2008\ (Windows Vista)

to one of the following folders:

C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2010\ (Windows XP/2000)

or, C:\ProgramData\MicroSurvey\MapScenes\2010\ (Windows Vista)

2006 to 2010:

You can export your Description Translation Library from MapScenes 2006 by typing in the command (dumpccpd) at the command line, including the parenthesis. This will create a file in the following location:

C:\Program Files\MicroSurvey\MapScenes 2006\mscad\desctran.db

Then copy this file into C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2010\ if your computer runs Windows 2000 or Windows XP, or into C:\ProgramData\MicroSurvey\MapScenes\2010\ if your computer runs Windows Vista, and rename it to desctrans.csv.

I have customized or added my own Blocks in the Symbol Librarian, can they be transferred into MapScenes 2010?

Yes, the MapScenes Symbol Librarian is found in one of the following folders:

MapScenes 2006:

C:\Program Files\MicroSurvey\MapScenes 2006\Symbols\

MapScenes 2008:

C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2008\Symbols\ (if your computer runs Windows 2000 or Windows XP)

C:\ProgramData\MicroSurvey\MapScenes\2008\Symbols\ (if your computer runs Windows Vista)

Just copy any customized DWG or DXF files from there into C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2010\Symbols\ if your computer runs Windows 2000 or XP, or C:\ProgramData\MicroSurvey\MapScenes\2010\Symbols\ if your computer runs Windows Vista.

If you are upgrading from MapScenes 2002, you will have to convert the FLX files to DWG files first using the Batch Converter.

I have customized the generic title blocks used by the Add Sheet and Title Block routines, can they be transferred into MapScenes 2010

Yes, the title blocks can be copied from one of the following folders into MapScenes 2010.

MapScenes 2006:

C:\Program Files\MicroSurvey\MapScenes 2006\Design\

MapScenes 2008:

C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2008\Design\ (if your computer runs Windows 2000 or XP)

C:\ProgramData\MicroSurvey\MapScenes\2008\Design\ (if your computer runs Windows Vista)

Just copy any customized files from there into C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2010\Design\ if your computer runs Windows 2000 or XP, or C:\ProgramData\MicroSurvey\MapScenes\2010\Design\ if your computer runs Windows Vista.

If you are upgrading from MapScenes 2002, you will have to convert the FLX files to DWG files first using the Batch Converter.

I want to plot my first MapScenes 2010 drawing. Can I get my prior Print Style Tables for line width and colors into MapScenes 2010?

Yes, MapScenes 2006/2008/2010 can use the same CTB and STB print style tables which are completely interchangeable so you can simply copy and paste the files between any version since 2006.

MapScenes 2006 keeps its print style files in C:\Program Files\MicroSurvey\MapScenes 2006\Print Styles\.

MapScenes 2008 keeps its print style files in two locations, C:\Program Files\MicroSurvey\MapScenes 2008\Print Styles\ and also in your My Documents\Print Styles\ folder.

MapScenes 2010 keeps its print style files in two locations, C:\Program Files\MicroSurvey\MapScenes 2010\Print Styles\ and also in your My Documents\Print Styles\ folder.

The print style files found in the Program Files location are used only as templates, so that when a user runs MapScenes 2010 for the first time, the files contained there will be automatically copied to their personal My Documents\Print Styles folder. Then any time you use or edit a print style table in MapScenes 2010, it uses the copy contained in your My Documents\Print Styles folder, while the copy in the Program Files location is left in its default condition. This allows multiple users on one computer to customize their own individual print style table files.

How can I transfer my custom Linetype files into MapScenes 2010?

MapScenes 2006/2008/2010 can use the same Linetype files, which are also compatible with AutoCAD. Simply copy your customized *.LIN files from C:\Program Files\MicroSurvey\MapScenes 20xx\ (or wherever else you may have stored them) into C:\Program Files\MicroSurvey\MapScenes 2010\. Also remember to copy any required shape/font files used by any advanced linetypes. Note: Do not overwrite the ICAD.LIN or LTYPESHP.SHX files that are included with MapScenes 2010, or you may lose any new line types that have been added into MapScenes.

How can I transfer my custom Hatch Pattern files into MapScenes 2010?

MapScenes 2006/2008/2010 can use the same Hatch Pattern files, which are also compatible with AutoCAD. Simply copy your customized *.PAT and *.SLD files from C:\Program Files\MicroSurvey\MapScenes 20xx\patterns\ (or wherever else you may have stored them) into C:\Program Files\MicroSurvey\MapScenes 2010\patterns\.

How can I transfer my custom Templates into MapScenes 2010?

MapScenes 2006/2008/2010 can use the same .DWG and .DWT template drawings. If you have customized the default icad.dwt template file, copy it from C:\Program Files\MicroSurvey\MSCAD200x\Support\ into C:\Program Files\MicroSurvey\MapScenes 2010\Support. If you use any other .DWG or .DWT file as your template, simply select it in the MicroSurvey Project Manager.

How can I transfer my custom MicroSurvey Defaults into MapScenes 2010?

The very easiest way to transfer your MicroSurvey defaults from any previous version of MapScenes into MapScenes 2010, is to just open up an existing project in MapScenes 2010, then go to MsTools | MicroSurvey System Defaults | Save As Default Configuration. This will set everything from its Labeling defaults, System Toggles, and Job Defaults.

Or, you can open your previous version of MapScenes and run the MsTools | MicroSurvey System Defaults | Save Configuration File command, then open MapScenes 2010 and run the MsTools | MicroSurvey System Defaults | Load Configuration File command and then run the MsTools | MicroSurvey System Defaults | Save As Default Configuration command.

How can I transfer my custom Modeling Defaults into MapScenes 2010?

Open your previous version of MapScenes and run the MsModeling | Configuration File Options | Save Configuration File command. Save it as follows:

Windows XP/2000: C:\Documents and Settings\All Users\Application Data\MicroSurvey\MapScenes\2010\QS\QS.QCF

Windows Vista: C:\ProgramData\MicroSurvey\MapScenes\2010\QS\QS.QCF

MapScenes 2010 will then automatically use that new configuration file.

What is this Floating Menu? Can I get rid of it?

When using MapScenes 2010, like MapScenes 2006/2008, you will notice a floating menu that will appear as you use different commands at the command line. If you want to turn it off, type Config at the command line, and turn off Display prompt boxes in the display tab.

How do I load Toolbars?

You can load toolbars by right-clicking over any of your visible toolbars, to get a pop-up list of the toolbars available within MapScenes 2010. Toolbars shown with a checkmark are already loaded. Clicking on a toolbar name will either load or unload it.

You can also load toolbars by going to the menu that the toolbar resides in. You will note that each menu item has a toolbar or toolbars listed towards the bottom of the menu.

 


 

Help and Training with MapScenes 2010

I've heard that there are many hours of training movies, how do I play the training movies?

The training movies have been built into the help system. Not only is there a topic listing the available movies you will find that many individual topics will have a link to corresponding movies.

I've heard that the help file was improved for MapScenes 2010?

We have updated the help file for the both the updated IntelliCAD engine and the survey commands have also been updated.

Are there any tutorials or other examples of how to use MapScenes 2010?

Yes, there is a Forensic CAD tutorial available in the Getting Started Guide, and an additional Capture tutorial is available in the Help file. You can access the PDF document through your Start Menu | Programs | MapScenes 2010 | Getting Started.

What about classroom-type training, is anything like that available?

Training courses are sometimes offered if there is sufficient demand in a particular region. Please phone your Sales Representative at 1-800-668-3312 to enquire about any upcoming training sessions.

(320 vote(s))
Helpful
Not helpful

Comments (0)